Showing results for 
Search instead for 
Did you mean: 

Installing CMA in managed mode from VSE package

Is it possible to install ePO agent (CMA) in managed mode from VSE package created with Installation Designer?

It seems that VSE setup always installs the agent in Updater mode even though the Framepkg.exe that I supplied to Installation Designer is from the ePO server (the one that by default installs in managed mode).

Is this by design and is there away to workaround it so that the agent installs in managed mode?

I know that this can be done in other ways but I am interested to know about this specific scenario.
Tags (1)
5 Replies

Using Microsoft BDD/MDT (LTI) to deploy CMA?

Question update: Is anyone using Microsoft BDD/MDT (LTI) to deploy CMA?

Since I cannot install CMA (in managed mode) with VSE package, I have created two separate applications in BDDnull - one for VSE and one for CMA. The problem is that when CMA installation package (FramePkg.exe) runs as part of LTI it can't install and stops the whole process. No matter how I run it, it stops and FrmInst_xxx.log shows only two lines:

20080905153041 I #3320 Stub Pkg
20080905153041 I #3320 Stub Pkg START [FramePkg.exe /install=agent /silent]
20080905153041 I #3320 Common Pkg CreateDirectory (C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\unz238.tmp)

When installing manually, it installs no problem.

Has anyone encountered this problem.
Level 13
Report Inappropriate Content
Message 3 of 6

RE: Using Microsoft BDD/MDT (LTI) to deploy CMA?

have you tried using the force install switch?


we use this on manually applied batches and unattended VBS scripts and it works for us (also make sure your script has admin rights)

RE: Using Microsoft BDD/MDT (LTI) to deploy CMA?

Yes, I tried using FORCEINSTALL switch and get the same thing.

When installed manually the install log file looks something like this:

20080506173917 I #3624 Stub Pkg START [FramePkg.exe" /install=agent /silent]
20080506173917 I #3624 Common Pkg CreateDirectory (C:\WINDOWS\TEMP\unz2BE.tmp)
20080506173923 I #3624 Stub Pkg System=0
20080506173923 I #3624 Common Pkg CreateProcess (C:\WINDOWS\TEMP\unz2BE.tmp\FrmInst.exe, ...

So I wonder whether maybe the installer is having a problem determining the context or starting the frminst.exe process when running under BDD/LTI.
Level 7
Report Inappropriate Content
Message 5 of 6

RE: Using Microsoft BDD/MDT (LTI) to deploy CMA?

Hi davidpyu

I'm experiencing a similar issue, did you find a solution?

RE: Using Microsoft BDD/MDT (LTI) to deploy CMA?

No, but it works from a batch file.
More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community