cancel
Showing results for 
Search instead for 
Did you mean: 
vvadim
Level 9
Report Inappropriate Content
Message 1 of 10

Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution

Environment:
ePO 5.9.1
Data Loss Prevention Extension 11.3.0.19
DLP Client 11.3.2.82
MA Extension 5.6.1.150
MA 5.6.1.308
All software packages in Evaluation branch


OS Windows 10 1903 Ent. x64


The sequence of actions:
1. Installing MA 5.6.1.308
2. Running "Run Client Task Now"
3. Select Product Deployment DLP Client 11.3.2.82 and run task
4. Waiting, when the installation complete.
On this step problems has began.


ePO console says: Run now task McAfee Agent > Product Deployment received.
Installation takes quite a long time - 10-20 minutes, 'Status' displayed 2 green bars, but the third bar turns red and displays the error: Run now task McAfee Agent > Product Deployment failed.

Other software, like ENS, MCP, MA - installs fine, but quite a long time.
Manual installation from downloaded from Software Manager archive - installs fine
On Windows 10 1809 - installs fine from ePo.
What I'm doing wrong?

2 Solutions

Accepted Solutions
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 8 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution
The mcscript deploy logs and the product install logs when pushed from epo are where to look. You can open a ticket with McAfee with the agent team to troubleshoot, and run a procmon possibly when running the update. There could be some injection going on (mfemactl log). If you see some of our processes the ones blocked, then that could be causing the problem. It would seem a detailed analysis of logs would be in order, so you might want to just go ahead an open a ticket.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

vvadim
Level 9
Report Inappropriate Content
Message 9 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution
Found the cause of this behavior of the installer on Windows 10 1903. If you first install the ENS and then the try to to install DLP Agent - the ENS blocks installation of DLP. On Windows 10, 1809 and earlier, this problem is not occurs. As workaround you can install DLP Agent in first or disable ENS Access Protection before DLP Agent installation.
9 Replies
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 2 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution
Follow this article to pin down whether it is an agent, repository or point product issue. https://community.mcafee.com/t5/ePolicy-Orchestrator/HOW-TO-TROUBLESHOOT-CLIENT-UPDATE-DEPLOYMENT-FA...

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

vvadim
Level 9
Report Inappropriate Content
Message 3 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution

In 'Running Client Task Status' appears next:
Task started at 9/10/19 10:59:41 AM

Run now task started.
Run now task McAfee Agent > Product Deployment failed.
Details: Product "DLPAGENT11200" installation failed, reason "Unknown error"..Task Completed

logs in attach, I can't see in them nothing strange

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 4 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution
It invoked the setup file, which means it is past the agent and on to the point product. This line in the log shows what log you should be looking at for the failure. Executing "C:\ProgramData\McAfee\Agent\\Evaluation\DLPAGENT11200\Install\0409\DLPAgentInstaller.x64.exe" REBOOT=ReallySuppress /q /L*V "C:\WINDOWS\TEMP\McAfeeLogs\DLPAgentInstall.log"

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

vvadim
Level 9
Report Inappropriate Content
Message 5 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution

Hi, thanks for answer.

but C:\WINDOWS\TEMP\McAfeeLogs\DLPAgentInstall.log won't creating after installation process. I'm check twice

And it strange to see 'DLPAGENT11200' when installing DLP 11.3 Agent

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 6 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution
The product code for it is correct, even if it is 11.3. I would suggest opening a ticket with the dlp team for why it is failing. If you run the install locally, does it fail with any better logging or error message?

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

vvadim
Level 9
Report Inappropriate Content
Message 7 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution

If I run installation locally, from downloaded from Software Manager installation pack, installation of 11.3 client ends fine. It is not failed. And I want to understand, where to dig.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 8 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution
The mcscript deploy logs and the product install logs when pushed from epo are where to look. You can open a ticket with McAfee with the agent team to troubleshoot, and run a procmon possibly when running the update. There could be some injection going on (mfemactl log). If you see some of our processes the ones blocked, then that could be causing the problem. It would seem a detailed analysis of logs would be in order, so you might want to just go ahead an open a ticket.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

vvadim
Level 9
Report Inappropriate Content
Message 9 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution
Found the cause of this behavior of the installer on Windows 10 1903. If you first install the ENS and then the try to to install DLP Agent - the ENS blocks installation of DLP. On Windows 10, 1809 and earlier, this problem is not occurs. As workaround you can install DLP Agent in first or disable ENS Access Protection before DLP Agent installation.
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 10 of 10

Re: Installation of Client DLP 11.2 from ePO 5.9.1 fails

Jump to solution

Thanks for the info - very helpful!

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community