cancel
Showing results for 
Search instead for 
Did you mean: 
jtornos
Level 7

Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

Hi,

I need to test the deployment of the full package of VSE 8.8 p4 to machines that have VSE 8.8 p1 or p2 installed. I don't want to uninstall / install because reasons and i don't want to install just the patch. I have tried to install the full package "on top" of the previous install but to no success. The process i've done is this:

I've added the full package of VSE 8.8 in the "evaluation" branch of my ePO server and i've created a new deployment task.

Mcafee01.JPG

Mcafee02.JPG

The machine in the test deployment environment is a Windows XP SP3 with VSE 8.8 p2 installed. The task executes OK but the product is not deployed.

What am i doing wrong?

Thanks a lot in advance.

1 Solution

Accepted Solutions
McAfee Employee

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

If the machines already have VSE 8.8 installed on them, then this is expected: the deployment task effectively works on major versions, so the task will run and execute the installer, which then sees that 8.8 is present and exits without doing anything.

To apply P4 to machines already running 8.8, you should check in the 8.8 P4 patch package, and then apply this to the client machines using an upgrade task configured to upgrade 8.8. If you absolutely want to use the full install package, you would need to uninstall VSE from the client machines first, then run the deployment task - but I would not recommend this.

HTH -

Joe

8 Replies
akill
Level 9

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

Can you show us the task assignment please?

0 Kudos
McAfee Employee

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

If the machines already have VSE 8.8 installed on them, then this is expected: the deployment task effectively works on major versions, so the task will run and execute the installer, which then sees that 8.8 is present and exits without doing anything.

To apply P4 to machines already running 8.8, you should check in the 8.8 P4 patch package, and then apply this to the client machines using an upgrade task configured to upgrade 8.8. If you absolutely want to use the full install package, you would need to uninstall VSE from the client machines first, then run the deployment task - but I would not recommend this.

HTH -

Joe

les85
Level 7

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

Joe,

I'm having difficulty applying VSE patch 4.  I read your 4/15 10:32am post and understand why I still see patch 2 or 3 for my pre Windows 8.1 workstations but I don't understand why the 8.1 machines still show patch 3 after running the update task.  I have set my policy to Evaluation for VSE 8.8 which is where I have the patch checked in.  Any ideas?  We are on ePO 4.6.4 using MA 4.8.  Any help would be appreciated.

One more note.  If I download and run the patch on Windows 7 or 8.1 it installs successfully.  I really need to do this through EPO because of the number of machines involved.

Thanks,

Leslie

Message was edited by: les85 on 6/25/14 3:25:39 PM CDT
McAfee Employee

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

The first thing is to check the logs on an affected client - the agent_<machinename>.log and the mcscript.log - that cover an update task. Do they show any errors running the task?

If you attach the logs here we can take a look.

Thanks -

Joe

les85
Level 7

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

I was getting ready to send you the logs when I noticed that the workstations I did yesterday now show the update.  I hadn't seen any errors in the logs but couldn't understand why they showed the old patch level.  I guess everything is working but there's some delay in accurately reporting the results in the interface.  I'll have to research that but I guess all is well for now.  Thanks for your quick response!

Regards,

Leslie

0 Kudos
jtornos
Level 7

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

That's what i feared... :/

Thanks a lot for the answer.

0 Kudos
ssadlocha
Level 10

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

I am attempting to test VSE 8.8 P4 now, and running into the same issue. I have placed both the full install and P4 into the Eval branch. As a first attempt, I am trying to deploy this patch to members of my team. I configured a Client Task to install, but it fails. I suspect this is because it is the full install as noted above, and requires that VSE be uninstalled first, and then this run. Unfortunately, I can't do this, because we are using Cisco NAC and one of our requirements is AV. The minute I uninstall VSE, I will no longer be able to connect to our network. This would not be a viable option going forward.

So then I look at the Patch 4 package alone. While this would most likely work, I am not sure how to deploy it. I configured a Product Update task, but as far as I know, you are unable to specify branch or specifics. In this case, the patch has to be in Current for the agent to pick it up. If I place the patch in Current and run the job quickly to update my PC, there is still a chance that another PC will update in the meantime and pick up the patch as well. This is not really a good method for testing.

Can anyone tell me a good way that I can deploy VSE 8.8 Patch 4 to a handful of computers without affecting other computers? This seems ridiculous that I can't do this easily through ePO. Perhaps I am missing something obvious.

parmaleer
Level 7

Re: Install VSE 8.8 patch 4 on evaluation branch

Jump to solution

Don't know if you still needed this info. It is located under the assigned policies, McAfee Agent product, under General. Within this policy, under the Updates tab, is where you can assign an evaluation branch for the machines to get their updates from.

0 Kudos