cancel
Showing results for 
Search instead for 
Did you mean: 

Having problem while deploying agent to new system.

when i try to deploy agent to new system. Getting following error:

"Failed to authenticate with remote system, system error: The specified network name is no longer available.

We already Enabled all of the following on the network and the client computer:

  • NetBIOS protocol
  • Network protocols and ports required for machine name resolution
  • ADMIN$ share
  • File and Print sharing
  • Server service
  • Remote Registry service

Also From the ePO server we are able to access following command, without appearing credential prompt

\\Hostname\admin$

Request your suggestions/solutions !

Thanks in advance !!

5 Replies
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 2 of 6

Re: Having problem while deploying agent to new system.

Are you sure that is the right system you are accessing via admin$?  I have seen dns entries stale where the ip the hostname resolves to actually belongs to another system.  You can tell if it is the right system by going to c$ instead of admin$, then to c:\programdata\mcafee\agent\logs.  The logs will be named with masvc_computername.log, for example.  Validate you are hitting the right system.

 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Having problem while deploying agent to new system.

Hello cdinet !!

Thanks for the reply !!

I have checked for the two client machines

1)  I went to \\computername\c$ and then to c:\programdata\mcafee\agent\logs.  But I didn't find any logs by this name type masvc_computername.log

2) For the second client machine, I received error "The specified network name no longer available." for both \\computername\c$  and \\computername\admin$ 

3) Third one is having the log file masvc_computername.log, but on epo console still it shows as 'Unmanaged'

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: Having problem while deploying agent to new system.

1)  I went to \\computername\c$ and then to c:\programdata\mcafee\agent\logs.  But I didn't find any logs by this name type masvc_computername.log

That indicates something broken with agent or it was uninstalled partially possibly.  There should be logs there.  You may have to get on the system locally to reinstall the agent.  What does nslookup show for the ip address of that hostname? 

2) For the second client machine, I received error "The specified network name no longer available." for both \\computername\c$  and \\computername\admin$ 

Perhaps that system no longer exists.  Does nslookup return anything?

3) Third one is having the log file masvc_computername.log, but on epo console still it shows as 'Unmanaged'

Check that masvc log for asci - is the communication failing for some reason?  What version of the agent?  You might try upgrading it to the latest. 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Having problem while deploying agent to new system.

1)  I went to \\computername\c$ and then to c:\programdata\mcafee\agent\logs.  But I didn't find any logs by this name type masvc_computername.log

That indicates something broken with agent or it was uninstalled partially possibly.  There should be logs there.  You may have to get on the system locally to reinstall the agent.  What does nslookup show for the ip address of that hostname? 

ME: nslookup show: "dc.domain.local can't find ***.**.**.**. (IP): Non-existent domain"

2) For the second client machine, I received error "The specified network name no longer available." for both \\computername\c$  and \\computername\admin$ 

Perhaps that system no longer exists.  Does nslookup return anything?

ME: nslookup returns the ip address for the hostname

3) Third one is having the log file masvc_computername.log, but on epo console still it shows as 'Unmanaged'

Check that masvc log for asci - is the communication failing for some reason?  What version of the agent?  You might try upgrading it to the latest. 

ME: AS this is the fresh set up, McAfee agent  is  5.6.0.702.. Also how to Check masvc log for asci - is the communication

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: Having problem while deploying agent to new system.

1) ME: nslookup show: "dc.domain.local can't find ***.**.**.**. (IP): Non-existent domain"

You may have to go to that system either remote desktop or physically and validate hostname/ip and install the agent locally

2) ME: nslookup returns the ip address for the hostname

Try adding the system in epo as IP address and deploy agent that way.  If that works, then when it checks in, delete the IP entry that it might add.

3) ME: AS this is the fresh set up, McAfee agent  is  5.6.0.702.. Also how to Check masvc log for asci - is the communication.  Asci stands for agent-server communication interval.  search for when the agent is starting asci and follow that step to see if it receives a failure or 200 or 202 response from server for success.  If it is successful, check epo to make sure there are no duplicate entries in the system tree for that system.  also, if these are vpn clients, check to see if KB52949 applies.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator