Showing results for 
Search instead for 
Did you mean: 

HIPS installation causes reboots

I am using ePO 4 and pushed out HIPS 7 to a test system and it says its installed fine and asks to reboot. When I reboot, it comes back up and in a few mins says it has finished updating and wants to reboot again. This just keeps going on and on. Any ideas?

8 Replies

i've had a similar problem

i'm seeing the same thing but only on certain systems. So far I've seen behaviors that just simply prompt for reboot and another issue that causes the computer to reboot on it's own. In most cases simply removing the HIPS deployment task from the EPO fixed the issue on those systems but on one I had to use the windows revert to last know good settings option at startup. this issue is extremely frustrating.

Another thing I've noticed is that on those systems with this issue, it is not possible to install HIPS manually either. It keeps saying that there is a pending reboot, however I can't seem to figure out what would be causing the reboot required condition.

EDIT: I just found something that may be useful. At "c:\doucments and settings\all users\application data\mcafee\common framework" i noticed one file in common on all the affected systems. They all seem to have a reboot.ini at that location. inside the file it seems to be indicating that there is a reboot pending. I haven't had a chance to test this out yet but thought I should mention it. i'll post again if it fixes the problem.

EDIT: Well i tried removing the reboot.ini file with no luck. The HIPS client install still asks for a reboot. i'm out of ideas for now.

RE: i've had a similar problem

I recently had a similar problem. What finally fixed it for me was to delete the file


I also changed the C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\reboot.ini settings but I don't know if that is part of the solution.

I hope this helps someone in the future. It was very frustrating to me.

Cannot modify Reboot.ini...


I spoke with platinum support on this and they recommended I uninstall the Agent and then re-install.

You'll notice when you uninstall the agent all the files in Common Framework go and therefore so does reboot.ini. I've just uninstalled the Agent and then re-installed. The agent is dynamic so you shouldn't, in theory, have to reboot.

This was successful although in my case like an idiot I had a task running against the workstation that I forgot about, so check to make sure you don't have any install tasks running against the respective computers.


Level 9
Report Inappropriate Content
Message 5 of 9

Installing HIPS leads to repeated reboots (uselessly)

I have the same issue on three systems so fare (out of a few thousands).

Uninstalling McAfee Host IPS "solves" the issue -- but then, there's no FW on the system. Smiley Sad

I uninstalled all McAfee products (i.e. VSE and HIPS) cleaned the registry, waited a few days (i.e. +1 reboot per day). Then, I reinstalled VSE (through our ePO task) and waited a few more days.

Today, I decided to install HIPS... same error "multiple reboots".

After finding KB60078 - Verifying a successful Host Intrusion Prevention 7.0 Windows agent installation in checked into McAfeeHIP7_Install.log and found an error message:

MSI (s) (9C:D8) [16:11:04:625]: Product: McAfee Host Intrusion Prevention --
Error 1406.Could not write value LanguageID to key \SOFTWARE\McAfee\HIP.
System error . Verify that you have sufficient access to that key, or contact
your support personnel.

I'm local admin on PC.

I had a reboot.ini file as well, didn't touch it.
I did check in the registry and key HKLM\SOFTWARE\McAfee\HIP was missing. I (unwittingly) created it (empty).
Now reboot.ini file has disappeared and it's stopped asking for reboots... but HIPS is still missing!!
And the "Buffer overflow" module of VSE is disabled Smiley Sad

I'm thinking of copying the \SOFTWARE\McAfee\HIP registry group from another PC onto mine... :confused:


RE: Installing HIPS leads to repeated reboots (uselessly)

Do a manual uninstall of HIPS and all related components/files per the kb article KB51699

Reboot then reinstall.
Level 9
Report Inappropriate Content
Message 7 of 9

RE: Installing HIPS leads to repeated reboots (uselessly)

I did (cf. my post just above)!

Some of the files and keys were missing. After it all was gone, I cleaned the registry (CCleaner) and rebooted...

I reinstalled it all on monday and it still doesn't work.


Re: RE: Installing HIPS leads to repeated reboots (uselessly)

Hello All,

Please I am having the same issue with HIPS causing a continuous reboot and the ePOserver. I am running ePO 4.0 patch 7.

I cant do a system restore because it is a server OS.

It also causes a blue screen which i have troubleshooted but the hotfix that resolve it, my server is even running a higher version.

Please HELP

Re: HIPS installation causes reboots


having the same problem with reboots being issued. have tried uninstalling, reinstalling, only installing minimal point products, etc...