cancel
Showing results for 
Search instead for 
Did you mean: 

Frameworkservice stopping

Hi

I have some strange behaviour on some clients/server. For example
In our network i have setup about 13 distributed repos with super agent funktionality.
on 1-3 of them i get every day a task log that the Repo Replikation failed. When i look local on these puter i see framwork service is not running. I start the service and everything is fine.Until the next time the repo repl. failed again.
Is there a reason why the framwork service is stop working?
This server is Win 2003 SP2 and is running in VMWare.
Agent is 3.6.0.546
Epo 3.6.1
Virusscan 8.0i hotfix 15
Engine 5200


Hades
20 Replies
psolinski
Level 10
Report Inappropriate Content
Message 2 of 21

RE: Frameworkservice stopping

I experience the same problem on my w2k3 servers holding superagent repositories

ePO 3.6.1.220 (patch 2)
CMA 3.6.0.546
VSE 8.5.0.781
tonyb99
Level 13
Report Inappropriate Content
Message 3 of 21

RE: Frameworkservice stopping

Can you post logs for an affected server?
are they behind an ISA server?

RE: Frameworkservice stopping

Hi Tony

No our distr. Repositorys are not behind a ISA.
Wich logs do you need exactly?

Hades
psolinski
Level 10
Report Inappropriate Content
Message 5 of 21

RE: Frameworkservice stopping

Hi Tony,

Our agents are actually on ISA server.....

From agent log:

20070922140742 I #7332 InetMgr HTTP Server returned success, HTTP return code: HTTP/1.0 200 OK

20070922140742 I #7332 InetMgr
20070922140742 I #7332 InetMgr Downloading a file of total size: 64, content-length: 64
20070922140742 I #7332 InetMgr Downloaded file \SiteStat.xml successfully
20070922140742 I #7332 InetMgr After calling download()
20070922140742 I #7332 InetMgr return code = 0
20070922140742 I #7332 InetMgr HTTP Session closed
20070922140742 I #7332 InetMgr ------------------------------------------------------------
20070922140742 I #2104 LstnSvr CAsyncSocket::DoCallBack for event: FD_CLOSE
20070922140742 I #7332 Script ePOSA_AKM1ADC1 site is valid and available.
20070922140742 I #2112 LstnSvr CAsyncSocket::DetachHandle hSocket=1536
20070922140742 I #4988 Script ScriptEngine connected back to Framework successfully
20070922140742 I #2052 Sched Spyware module scan - Last run time is : not run yet
20070922140742 I #2052 Sched 0 fields of the task 416 are updated successfully
20070922140742 I #2052 Sched RunAtEnforcementEnabled not found in the task settings
20070922140742 I #2052 Sched >>--CSchedule::ModifyTask
20070922140742 I #2052 Sched <<--CSchedule::ModifyTask
20070922140742 E #2104 Stack Exception c0000005 address 7c8396d0
20070922140742 I #2104 Stack 7c359629
20070922140742 I #2104 Stack 7c3598ad
20070922140742 I #2104 Stack 7c35994a
20070922140742 I #2104 Stack 7c359b9d
20070922140742 I #2104 Stack 7c82eeb2
20070922140742 I #2104 Stack 7c82ee84
20070922140742 I #2104 Stack 7c82ecc6
20070922140742 I #2104 Stack 7c839620
20070922140742 I #2104 Stack 643a82a7
20070922140742 I #2104 Stack 643221ed
20070922140742 I #2104 Stack 643227ce
20070922140742 I #2104 Stack 00010036
20070922140742 I #2104 Stack 64326210
20070922140742 I #2104 Stack fffffd59
20070922140742 I #2104 Stack Can't read e8f18b56
20070922140742 E #2104 Stack Exception c0000005 address 7c8396d0
20070922140742 I #2104 Stack 7c359629
20070922140742 I #2104 Stack 7c3598ad
20070922140742 I #2104 Stack 7c35994a
20070922140742 I #2104 Stack 7c359bfe
20070922140742 I #2104 Stack 7c82ee84
20070922140742 I #2104 Stack 7c82ecc6
20070922140742 I #2104 Stack 7c839620
20070922140742 I #2104 Stack 643a82a7
20070922140742 I #2104 Stack 6432221a
20070922140742 I #2104 Stack 643227ce
20070922140742 I #2104 Stack 00010036
20070922140742 I #2104 Stack 64326210
20070922140742 I #2104 Stack fffffd59
20070922140742 I #2104 Stack Can't read e8f18b56
20070922140742 E #2104 Stack Exception c0000005 address 7c8396d0
20070922140742 I #2104 Stack 7c359629
20070922140742 I #2104 Stack 7c3598ad
20070922140742 I #2104 Stack 7c35994a
20070922140742 I #2104 Stack 7c359b9d
20070922140742 I #2104 Stack 7c82eeb2
20070922140742 I #2104 Stack 7c82ee84
20070922140742 I #2104 Stack 7c82ecc6
20070922140742 I #2104 Stack 7c839620
20070922140742 I #2104 Stack 643a82a7
20070922140742 I #2104 Stack 6432221a
20070922140742 I #2104 Stack 643227ce
20070922140742 I #2104 Stack 00010036
20070922140742 I #2104 Stack 64326210
20070922140742 I #2104 Stack fffffd59
20070922140742 I #2104 Stack Can't read e8f18b56
andyd
Level 7
Report Inappropriate Content
Message 6 of 21

RE: Frameworkservice stopping

Hi

I have the exact same problem

"Stack Can't read e8f18b56"

Restart the service and it works again for a couple of days. Ive only noticed it on the super repositories.

I have a call open with 2nd level McAfee Support.

I will let you know how i get on.

Many Thanks

Andy
psolinski
Level 10
Report Inappropriate Content
Message 7 of 21

RE: Frameworkservice stopping

Andy,

I'm only at tier 1 level at the moment.... and I'm pretty sure will climb higher.

My service request number is 1-307707001, maybe they should investigate our requests at the same time.
Please keep me updated.

I've provided them with results of the MER tool, and had to explain what I mean by "framework service crashes"....

Some kind of solution I use in our system is setting automatic restart for this service.

Regards
Piotr
psolinski
Level 10
Report Inappropriate Content
Message 9 of 21

RE: Frameworkservice stopping

Thanks Tony,

None of them fits our case. We use ISA 2004 as cache only, with 1 NIC. We havent experienced this problem with previous version of CMA. On workstations we also experience more CMA releted problems since upgrade to 3.6.0.546.

Any rumors about new CMA? One for ePO 4.0?

Andy, any progress with McAfee support? I cant get trough Level 1 support, they keep asking basic questions and due to time diference it takes ages.

Regards
Piotr
andyd
Level 7
Report Inappropriate Content
Message 10 of 21

RE: Frameworkservice stopping

Hi Piotr,

They asked me to upgrade from ePO 3.6.1 patch 1 to patch 2.
I did this but i still get the error. I think the problem started to occur after either

a) Upgrading to the latest CMA
b) Upgrading ePO from 3.6.0 to 3.6.1 patch 2

This has now been escalated to Tier III.

Ill reply to the forum when i have some new info.

Many Thanks

Andy
More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community