cancel
Showing results for 
Search instead for 
Did you mean: 

Frameworkmanifest.xml stopping agent from installing

Afternoon

I have finally implemented Rogue System Detection and setup an action to install an agent on the machine when a rogue machine is detected.

The Frampkg.exe downloads into c:\windows directory, therefore i can confirm epo is able to authenticate with the machine.

The agent install bombs out because of frameworkmanifest.xml.

Log below

20080116150352 I #2788 Stub Pkg
20080116150352 I #2788 Stub Pkg START [FramePkg.exe /ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\Network Associates\Common Framework"]
20080116150352 I #2788 Common Pkg CreateDirectory (C:\WINDOWS\TEMP\unz148.tmp)
20080116150355 I #2788 Stub Pkg System=1
20080116150355 I #3452 Common Pkg CreateProcess (C:\WINDOWS\TEMP\unz148.tmp\FrmInst.exe, /ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\Network Associates\Common Framework" /FramePkg /Cleanup="C:\WINDOWS\TEMP\unz148.tmp" /LOGDIR="C:\WINDOWS\TEMP\NAILogs")
20080116150357 I #2788 Stub Pkg END 0
20080116150357 I #1048 naCmnLib Ins Random seed = 0xe942****
20080116150357 I #1048 Setup Ins START [/ForceInstall /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\Network Associates\Common Framework" /FramePkg /Cleanup="C:\WINDOWS\TEMP\unz148.tmp" /LOGDIR="C:\WINDOWS\TEMP\NAILogs"]
20080116150357 I #1048 Setup Ins Windows 5.1.2600 Service Pack 2
20080116150357 I #1048 Setup Ins Attempting to perform a setup operation
20080116150357 I #1048 UI Ins Starting setup...
20080116150357 I #1048 UI Ins Validating setup options...
20080116150357 E #1048 Xml Ins Error trace:
20080116150357 E #1048 Thread Ins [Main thread]->
20080116150357 E #1048 Setup Ins [Attempting to perform a setup operation]->
20080116150357 E #1048 Script Ins [Script generation]->
20080116150357 E #1048 Cmalib Ins [Update manifest product count]->
20080116150357 E #1048 Xml Ins [useExistingFile,D:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\FrameworkManifest.xml]->
20080116150357 E #1048 Xml Ins [ReadBufferFromFileNoExp,D:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\FrameworkManifest.xml]->
20080116150357 E #1048 Xml Ins Couldn't convert to Unicode
20080116150357 E #1048 Xml Ins Error trace:
20080116150357 E #1048 Thread Ins [Main thread]->
20080116150357 E #1048 Setup Ins [Attempting to perform a setup operation]->
20080116150357 E #1048 Script Ins [Script generation]->
20080116150357 E #1048 Xml Ins [useExistingFile,D:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\FrameworkManifest.xml]->
20080116150357 E #1048 Xml Ins [ReadBufferFromFileNoExp,D:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\FrameworkManifest.xml]->
20080116150357 E #1048 Xml Ins Couldn't convert to Unicode
20080116150357 I #3736 Main Cle
20080116150357 I #3736 Main Cle START [2908 0 /LOGDIR="C:\WINDOWS\TEMP\NAILogs" "C:\WINDOWS\TEMP\unz148.tmp" ]
20080116150357 I #3736 Common Cle WaitForSingleObject (MCAFEE_FRAMEWORK_CLEANUP_INSTANCE, -1)
20080116150357 I #3736 Common Cle OpenEvent (MCAFEE_FRAMEWORK_CLEANUP_MUTEX_CREATED)
20080116150357 I #3736 Common Cle WaitForSingleObject (calling FrmInst.exe, -1)
20080116150357 E #1048 UI Ins Error trace:
20080116150357 E #1048 Thread Ins [Main thread]->
20080116150357 E #1048 UI Ins Can't access path 'D:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\FrameworkManifest.xml'.
20080116150357 I #1048 Thread Ins Exit program
20080116150357 I #1048 Setup Ins END 1603
20080116150357 I #3736 Main Cle END 0

If i delete the file and push the install again, the agent installs successfully.

Has anyone come across this problem or does anyone have a way of automatically deleting the xml file otherwise i'm going to have to remotely connect to each machine! Smiley Sad

Many Thanks
1 Reply

RE: Frameworkmanifest.xml stopping agent from installing

This has been discussed before. The only solution i can give is to add this to your batch file, either delete or replace frameworkmanifest.xml within the batch file. I encounter this more often than not and this was the only way i can make sure that the agent gets installed without worrying about any errors.