cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to open remote system environment, system error: access denied - Mcafee agent

Im trying to roll out the McAfee agent (v4.x) to Vista and 2008 clients on a domain. When I select the clients and perform a manual roll out, I get the erorr stated above.

I have tried to roll out to 20 clients. 5 vista, 15 2008. Only 1 of the vista clients has accepted the agent and only 1 of the 2008 clients has accepted the agent. The rest generate the error stated above.

The clients that have received the agent are exactly the same as the ones who have rejected it. I am working with sysprep'd windows images. No difference between them.

Anyone know what might be causing this? VERY Annoying.

Also, is there a suggestions forum where you can offer input in to the console?
Tags (1)
8 Replies

RE: Failed to open remote system environment, system error: access denied - Mcafee agent

Ive managed to sort this out. I changed the 3 McAfee services (services.msc) to run as a domain administrator, instead of the local service account.

I looked in the EpoApsvr.txt file to ascertain what was happening when the installation failed. It stated that the installation was running as system as elevation to administrator had failed.

I have since rolled out all the agents. Sorted. grin

RE: Failed to open remote system environment, system error: access denied - Mcafee agent



I had the same error, i have to disable user account control, new of windows vista.

http://www.howtogeek.com/howto/windows-vista/disable-user-account-control-uac-the-easy-way-on-window...

RE: Failed to open remote system environment, system error: access denied - Mcafee agent

Thanks for the reply!

Ive managed to get this to work with out disabling the access control. Doing that had little effect for me :mad:

RE: Failed to open remote system environment, system error: access denied - Mcafee agent



What's wrong? :confused:

worked fine for me. I succesfully installed, connected and applied policies for McAfee Agent under Windows Vista ultimate.

RE: Failed to open remote system environment, system error: access denied - Mcafee agent

It's all good thanks! Smiley Very Happy

The problem I had was getting the agents on to the hosts. Now that is sorted, I can manage them like a dream! :cool:

RE: Failed to open remote system environment, system error: access denied - Mcafee agent




when you say the 3 Mcafee services, you mean the 3 Mcafee EPO services right? please let me know. thanks.

RE: Failed to open remote system environment, system error: access denied - Mcafee agent

Yes, the 3 ePO services..

RE: Failed to open remote system environment, system error: access denied - Mcafee agent

I thik this issue will be adressed with MA 4.0 patch 2:

https://kc.mcafee.com/corporate/inde...tp=LIST_RECENT