cancel
Showing results for 
Search instead for 
Did you mean: 
smalldog
Level 12
Report Inappropriate Content
Message 1 of 14

Failed to enumerate domains, authentication required

Jump to solution

Hi All, i setup ePO on windows server 2008 r2 (not AD). i'm using on workgroup enviroments. So when i add new systems i can not browser computers to deploy agent that have error "Failed to enumerate domains, authentication required". I try this KB70414 but didn't work. Any advices? Thanks!

1 Solution

Accepted Solutions
smalldog
Level 12
Report Inappropriate Content
Message 14 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

My problems was solved by changing the Application Server service to local admin account. Thanks All!

13 Replies
hem
Level 15
Report Inappropriate Content
Message 2 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

I will check if 'Computer browser' service is running or not. I will suggest to set it to Automatic.

If still issue persists then please check the below.

Are the machines you are adding to the ePO server are in the same domain or in different domain?

If in different domain then do you have  the trust between the domains?

Are you able to browe the machine from 'My network places'?

rackroyd
Level 16
Report Inappropriate Content
Message 3 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

How are you entering credentials to connect to the remote machine ?

You would presumably need to use a local machine account that has local admin rights.

As this is a workgroup and not a domain this could be complicated as it could vary machine to machine.

Rgds,

Rob.

smalldog
Level 12
Report Inappropriate Content
Message 4 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

Thanks for reply, this multi workgroup (not domains). In ePO machine i can browse the machines from 'My network places', 'computer browser' service is running. I have entering credential by local admins that ePO installed and also entering credential by local admins that remote machine but no one work.

rackroyd
Level 16
Report Inappropriate Content
Message 5 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

Local admin credentials are certainly necessary.

It may be off track with the nature of the error message, but you could try entering the username as either ./<username> or <machinename>/<username>

Make sure you've enabled NetBIOS over TCP/IP this will likely be required in this environment.

See if there is a firewall (rule) or network device in the path that is blocking.

I guess you can test by trying install to machine in same workgroup as the ePO server to see if you get the same problem.

Verify your DNS lookups are good from ePO to client.

Otherwise you might need to look at a network trace from ePO server to failed client to see if it sheds more light on the problem.

Rgds,

Rob.

smalldog
Level 12
Report Inappropriate Content
Message 6 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

Hi All, i still have problems. NetBIOS over TCP/IP enabled, 'computer browsers' started. I can not browse to computer when input credentials (can browse by network places). I use account local on ePO server (see attach). Can you show me steps to config. Thanks!

rackroyd
Level 16
Report Inappropriate Content
Message 7 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

What you are doing looks reasonable, I don't have exact steps to give to you unfortunately.

If you need that I suggest opening a McAfee support case.

I guess you could try without the domain = workgroup entry as this would be irrelevant with no domain in place.

As an alternative you can install the agent other was than by pushing, but these would be outside the ePO console.

Details are in the user guide for agent deployment options.

Rgds,

Rob.

smalldog
Level 12
Report Inappropriate Content
Message 8 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

Thanks Rob, i try your suggested but didn't work. I try to demo push agent from ePO for my customers because their company haven't AD. So i must install agent from workgroup. In ePO 45 i can select workgroup for browsing but on ePO 46 win2k8 r2 that you must input credentials to browse computer . Could you remote to my pc to see problems? Thanks!

rackroyd
Level 16
Report Inappropriate Content
Message 9 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

'Fraid not. If you want someone from McAfee to remote connect and investigate you will need to open a support call and discuss with them.

Thanks,

Rob.

smalldog
Level 12
Report Inappropriate Content
Message 10 of 14

Re: Failed to enumerate domains, authentication required

Jump to solution

Ok thanks Rob!