cancel
Showing results for 
Search instead for 
Did you mean: 
Mal09
Level 12
Report Inappropriate Content
Message 1 of 4

Failed to download site status file

Around the same time as I applied Patch 3 to my EPO 4.5 box (and uploaded McAfee Agent 4.5 Patch 1), I get the following error message "Failed to download site status file" when looking at the Packages under Distributed Repositories.

Eg:

Menu..Software..Distributed Repositories.

Actions..View Packages.

returns the error on each repository. Each repository is a Linux FTP server.

Any suggestions?

3 Replies
apoling
Level 14
Report Inappropriate Content
Message 2 of 4

Re: Failed to download site status file

Hello,

what does ePOApSrv.log say?

Attila

Message was edited by: Attila Polinger on 7/12/10 8:21:00 AM CEST
Mal09
Level 12
Report Inappropriate Content
Message 3 of 4

Re: Failed to download site status file

I've commented out sensitive data, but the log during the error looks like:

20100712163104    I    #4184    naInet      ------------------------------------------------------------
20100712163104    I    #4184    SIM_InetMgr    Session 1 ended, result=1
20100712163104    I    #4184    SiteMgr     GeneralInetRequestThreadProc: GeneralInetRequest thread ended
20100712163104    x    #4184    SiteMgr     SiteMgr main control final release...
20100712163407    I    #3240    EPOJNI      Getting license data...
20100712163407    I    #3240    EPOJNI      Getting license data...
20100712163411    I    #3240    EPOJNI      Getting license data...
20100712163426    I    #3276    SiteMgrWrap    Created instance of Site Manager
20100712163426    I    #3276    SiteMgr     SetEPOMode: SiteMgr enter ePO mode, server=<MYEPOSERVER>, port=<PORT>, EPOUser=, Password=********
20100712163426    I    #3276    SiteMgr     DALInit: Connected to DAL successful
20100712163426    I    #3276    SiteMgr     SetEPOMode: Set ePO mode successful
20100712163426    I    #3276    SiteMgr     DownloadSiteCatalogThreadProc: Download site catalog thread started
20100712163426    I    #3276    SIM_InetMgr    Starting download session for site ePO FTP Repository
20100712163426    I    #3276    naInet      FTP Session initialized
20100712163426    I    #3276    NaInet      FTP Session 104 Logging into FTP Server: <MY REPOSITORY> using User: anonymous in WinInet mode
20100712163426    I    #3276    naInet      HTTP Session initialized
20100712163426    I    #3276    naInet      Connecting to HTTP Server using Microsoft WinInet
20100712163426    I    #3276    naInet      Trying to connect to Proxy Server <MY PROXY>:3128 using INTERNET_OPEN_TYPE_PROXY
20100712163426    I    #3276    naInet      Connected to Server: <MY REPOSITORY> on Port: 21 using WinInet
20100712163426    I    #3276    SIM_InetMgr    Started download session 1 for site ePO FTP Repository
20100712163426    I    #3276    SiteMgr     CheckSiteStatus: Downloading file SiteStat.xml from site ePO FTP Repository
20100712163426    I    #3276    SIM_InetMgr    Downloading file SiteStat.xml from session 1, LocalDir=C:\WINDOWS\TEMP\nai3356.tmp\00000001, RemoteDir=
20100712163426    I    #3276    NaInet      FTP session 104 Downloading file: /pub/epo45_dats/SiteStat.xml from FTP Server: <MY REPOSITORY>
20100712163426    I    #3276    NaInet      FTP session 104 Downloading file from FTP server <MY REPOSITORY> using WinInet [in proxy mode]
20100712163426    I    #3276    naInet      Open URL: ftp://<MY REPOSITORY>:21/pub/epo45_dats/SiteStat.xml
20100712163426    I    #3276    naInet      Trying to download using Microsoft WinInet library
20100712163426    I    #3276    naInet      Conneting to Proxy Server <MY PROXY>:3128 using INTERNET_OPEN_TYPE_PROXY
20100712163426    I    #3276    naInet      No resume download needed, calling InternetOpenUrl
20100712163426    I    #3276    NAINET      Resolving name <MY PROXY> to address
20100712163426    I    #3276    NAINET      Name resolved to <MY PROXY IP ADDRESS>
20100712163426    E    #3276    naInet      HTTP Server returned Error : 503
20100712163426    I    #3276    naInet      Failed to download the URL /pub/epo45_dats/SiteStat.xml using Wininet
20100712163426    I    #3276    SIM_InetMgr    Download file SiteStat.xml failed in session 1, nainet ret=0
20100712163426    I    #3276    SiteMgr     CheckSiteStatus: Failed to download SiteStat.xml from site ePO FTP Repository, hr=-2147467259
20100712163426    e    #3276    SiteMgr     Download sitestat.xml failed, error -803
20100712163426    I    #3276    naInet      HTTP Session closed
20100712163426    I    #3276    naInet      ------------------------------------------------------------
20100712163426    I    #3276    naInet      FTP Session 104 closed
20100712163426    I    #3276    naInet      ------------------------------------------------------------
20100712163426    I    #3276    SIM_InetMgr    Session 1 ended, result=1
20100712163426    I    #3276    SiteMgr     DownloadSiteCatalogThreadProc: Download site catalog thread ended
20100712163426    x    #3276    SiteMgr     SiteMgr main control final release...

Looking at that, I'm guessing it's a problem with the HTTP proxy. Something for me to investigate.

Mal09
Level 12
Report Inappropriate Content
Message 4 of 4

Re: Failed to download site status file

Mal09 wrote:

Looking at that, I'm guessing it's a problem with the HTTP proxy. Something for me to investigate.

And yep. Was a proxy issue - it wasn't allowing the route from EPO to the repositories (although replication was still working fine due to it being a direct connection etc). Now to hunt down who changed the proxy, network config or whatever else was the cause!

Message was edited by: Mal09 on 12/07/10 09:13:34 GMT