cancel
Showing results for 
Search instead for 
Did you mean: 
yej
Level 7

Failed to depoly agent

I have issues deploying agent through epo. All I got is one line error message "start service failed, system error: Overlapped I/O operation is in progress".  It doesn't really provide a lot of information I can troubleshoot. I can install the framepkg manually with no issue. Also, I was able to push out the agent at one point.  Anyone has any idea?

Update: It looks like only affecting windows 10 machines, I deployed agent to windows 7 with no issue.

0 Kudos
16 Replies
syedali
Level 11

Re: Failed to depoly agent

Hi yej,

Kindly provide the McAfee agent MSI installtion logs from the windows 10 client failing post reproducing the issue ?

Is HIPS installed on any of the system failing ?

Thanks,

Syed

0 Kudos
McAfee Employee

Re: Failed to depoly agent

​,

What version of agent are you trying to push to Windows 10 systems? Please see KB 51573 (McAfee Corporate KB - Supported platforms, environments, and operating systems for McAfee Agent and ... )

If you are able to install the same Agent package manually on Windows 10, check your task. Is this a "deployment" task or you are adding it to system tree by clicking new systems? Check your credentials and ensure that account has administrative rights.

0 Kudos
yej
Level 7

Re: Failed to depoly agent

The agent version is 5.3.  I can deploy the agent to existing machine that has the correct agent point to the my epo. But, If I try install on a client that has a McAfee Agent installed from a different ePO server, then it failed.  I remember I was able to do it before.

0 Kudos
ahawke
Level 7

Re: Failed to depoly agent

yej,

How are you deploying the agent through epo? You may see this issue if attempting to deploy via a client task or through product deployment.

You have a couple options depending on what you are trying to accomplish.

I suspect you are trying to do both of the following (as opposed to just one):1. upgrade agent 2. migrate

Try this:

1. Add(if not already there) systems in NEW ePO system tree - DO NOT deploy agent when adding system to system tree

2. Select the machine(s) you want to deploy agent to from the NEW ePO - of course they will be unmanaged at this point

3. Select Actions > Agent > Deploy Agents

     - DESELECT - Install only on systems that do not already have an agent managed by this ePO server

     - SELECT - Force installation over existing version

4. Complete the rest of the deploy form

This will install vs. upgrade and as a result the sitelist.xml will be configured for the new ePO.

LMK if this works

0 Kudos
yej
Level 7

Re: Failed to depoly agent

We have Rough system detection (RSD). Usually when I found system on the RSD, I can just right click the system and deploy agent.  Force installation over existing version is selected because I am deploying new agent to replace the existing one, but it failed with error "start service failed, system error: Overlapped I/O operation is in progress".  It doesn't really provide a lot of information I can troubleshoot.

0 Kudos
McAfee Employee

Re: Failed to depoly agent

Error 997. Overlapped I/O operation is in progress: KB2918614 breaks Windows Installer Service – Mic...

You can rename C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18 to C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18_old and re-install. If that doesn't work that link has other possible fixes.

Microsoft Hotfix - https://support.microsoft.com/en-us/kb/3000988

yej
Level 7

Re: Failed to depoly agent

What is your link has do with McAfee agent push?

0 Kudos
McAfee Employee

Re: Failed to depoly agent

It references the exact error in your message earlier. The Microsoft link I pasted references a particular Windows update KB2918614 that causes issues. So, if your systems happen to have to his particular patch, you can either remove it OR apply the Microsoft hotfix. Then try pushing / installing McAfee agent again.

0 Kudos
yej
Level 7

Re: Failed to depoly agent

First of all, I am not installing Microsoft visual studio.  Second, I can install agent manually so windows installer service is not broken.  The article you provided has nothing to do with McAfee.

0 Kudos