cancel
Showing results for 
Search instead for 
Did you mean: 

Fail to show agent log after upgrade to ePO 4.5

Jump to solution

I did a in-place upgrade from ePO 4.0 patch 3 to ePO 4.5 then upgrade it to ePO 4.5 patch 1.

I have 90% of client using agent 4.0.0.1444

Question 1:

I can do the "Show Agent Log" on ePO 4.0 P3 but now I cannot after the migration. does anyone have a clue to it?

Question 2:

BTW, I have another question that after upgrade to ePO 4.5 P1. I had deploy the MA 4.5.0.1270 to some PCs and the installation complete without error. However, it prompt ASCI error "Agent failed to communicate with ePO Server". after checking the log file. it seems that the agent is trying to connect to the epo port 443 (my epo ASCI port is 1080, and I had disable the ASCI secure port on the server). old agent 4.0.0.1444 can still communcate with ePO 4.5 without error. Only 4.5.0.1270 have ASCI error.

Message was edited by: KelvinCheng on 3/19/10 5:25:17 PM GMT+08:00
1 Solution

Accepted Solutions
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: Fail to show agent log after upgrade to ePO 4.5

Jump to solution

BTW, can I customized the secure agent communication port?


Yes. Please refer to KB66929 for the exact steps to do this.

5 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 6

Re: Fail to show agent log after upgrade to ePO 4.5

Jump to solution

Please check if the Agent Policy setting 'Accept connections only from the ePO server' is checked (this is on the General Tab. If it is checked and you are trying to open the agent log from a different system, it will fail.

For Question 2: You will need to enable Port 443 for MA 4.5 clients to communicate - this is because they use the secure channel (https) for communication and the payload is unencrypted. With MA 4.0 and earlier, the agent payload is encrypted but the transport itself was unsecure (http)

Re: Fail to show agent log after upgrade to ePO 4.5

Jump to solution

Thanks for the hints, Sailendra!

BTW,  I found that the "Enable remote access to log" in unchecked after the migration under the "Logging" tab. Thus I need to enbale it also to make the Show Agent Log working again.

For Q2, is that means if all clients are using MA 4.5 with ePO4.5 , then the port 1080 can be removed?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: Fail to show agent log after upgrade to ePO 4.5

Jump to solution

You are welcome

For Q2, is that means if all clients are using MA 4.5 with ePO4.5 , then the port 1080 can be removed?


I believe you refer to port 80 (agent communication port) which you may have customized to 1080. The answer is yes - you can only have port 443 enabled on your firewall and still get all clients to communicate with ePO 4.5 - provided they are on MA 4.5.

Re: Fail to show agent log after upgrade to ePO 4.5

Jump to solution

I believe you refer to port 80 (agent communication port) which you may have customized to 1080. The answer is yes - you can only have port 443 enabled on your firewall and still get all clients to communicate with ePO 4.5 - provided they are on MA 4.5.

Yes. I am talking about the agent communication port 80 (customized to 1080).

BTW, can I customized the secure agent communication port?

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: Fail to show agent log after upgrade to ePO 4.5

Jump to solution

BTW, can I customized the secure agent communication port?


Yes. Please refer to KB66929 for the exact steps to do this.