cancel
Showing results for 
Search instead for 
Did you mean: 
F-N
Level 7
Report Inappropriate Content
Message 1 of 7

Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

Hello,

I´m using:

Epolicy 4.0 Patch 4

VS 6.7.0.570

Agent 4.5.0.1270

Im trying to deploy the VS on a Windows 7 Enterprise Machine with EPO.

The Deployment of the Agent worked without problems, but he ignores all VS deployment Tasks. There is no error message in the Agent Monitor or in the Epolicy Server Log.

I tried to deploy the VS on a Vista machine with the exact same Task and it worked.

Any clues?

Tags (1)
1 Solution

Accepted Solutions

Re: Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

-- Try this SQl script, as it resets the Timestamps in the database, and should force a re-compile of the tasks.

--

DECLARE @ProductCode NVARCHAR(100)

DECLARE @PlatformCode NVARCHAR(100)

SET @ProductCode='EPOAGENTMETA'

SET @PlatformCode='WNT7W'

UPDATE [dbo].[EPOTask]

   SET [PlatformsSupported] = [PlatformsSupported]+'|'+@PlatformCode,

       [TheTimestamp] = @@DBTS

   WHERE [ProductCode] = @ProductCode And [PlatformsSupported] Not Like '%'+@PlatformCode+'%'

AND [PlatformsSupported] LIKE '%WXPW%'

GO

6 Replies

Re: Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

Make sure you are using the latest Extension for VSE 8.7 (Patch 2 repost). As most likely the issue is that the Supported Platforms (table in epo db) does not include Win7.

NOTE: do NOT remove the extension, only upgrade it as a removal will delete your tasks and polices.

If you are using the latest Extensions for MA and VSE then delete and recreate your deployment task, as it most likely was created when we did not support Win 7, thus the DB still doesn't have Win7 in the supportedplatforms column.

F-N
Level 7
Report Inappropriate Content
Message 3 of 7

Re: Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

I did both, i´ve the latest extensions and recreated the deployment task, but this does still not work.

The Epolicy Server is runnning with an SQL2000, is it possible that this version does not

support the new Windows 7 tables used by EPO? I know that you need 2005 or higher for

EPO 4.5 but hoped that a Databaseupgrade is not needed for EPO 4.0 and Windows 7 deployment.

Jetel
Level 7
Report Inappropriate Content
Message 4 of 7

Re: Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

Check the ini file which represents Deployment Task you created. Check line "Platform" if there is WNT7W...it should be like this: Platforms=WIN95|WIN98|WINME|WNTS|WNTW|WXPW|WXPS|WXPHE|W2KS|W2KW|WVST|WVSTS|WNT7W.

If WINT7W is not present you should run script as it is described in KB67321...https://kc.mcafee.com/corporate/index?page=content&id=KB67321&actp=search&searchid=1265373731424

This worked for our customer and I suppose it should work for you too.

F-N
Level 7
Report Inappropriate Content
Message 5 of 7

Re: Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

Ok, first of all i looked at my seven machine an saw that there are no tasks in the tasks folder.

After that i looked at my vista machine where i deployed the new virus scan wich has a few tasks in the folder.

The deployment task has the following parameters:

Platforms=WIN95|WIN98|WINME|WNTS|WNTW|WXPW|WXPS|WXPHE|W2KS|W2KW|WVST|WVSTS

So i headed to the SQL Server an took a look into the tables and like you excpected, there is no WNT7W in the "PlatformsSupported" column.

So i used the script but it changed "0" entries.

I changed the Table manually, reinstalled the Agent on the Seven machine, but there is still no change. After that, i created a new deployment task

and looked in the database, but again the WNT7W Tag is missing.

Nachricht geändert durch F-N on 08.02.10 06:20:56 CST

Re: Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

-- Try this SQl script, as it resets the Timestamps in the database, and should force a re-compile of the tasks.

--

DECLARE @ProductCode NVARCHAR(100)

DECLARE @PlatformCode NVARCHAR(100)

SET @ProductCode='EPOAGENTMETA'

SET @PlatformCode='WNT7W'

UPDATE [dbo].[EPOTask]

   SET [PlatformsSupported] = [PlatformsSupported]+'|'+@PlatformCode,

       [TheTimestamp] = @@DBTS

   WHERE [ProductCode] = @ProductCode And [PlatformsSupported] Not Like '%'+@PlatformCode+'%'

AND [PlatformsSupported] LIKE '%WXPW%'

GO

F-N
Level 7
Report Inappropriate Content
Message 7 of 7

Re: Epolicy 4.0 P4 does not deploy VS8.7.0.570 with Agent 4.5.0.1270 on Windows 7

Jump to solution

Wow, this worked!

Thank you all for you help