cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 1 of 15

Epo 5.3.2 RSD 5.0.5.120

Jump to solution

hello i have this issue. if i deploy RSD via ePO it is OK. if i try to remove the RSD from the systems via ePO it does not work:

if i remote connect the same system and from control panel i uninstall RSD , no problems

why RSD uninstall via ePO is not working ?

thanks in advance for your cooperation

ciao

1 Solution

Accepted Solutions
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 13 of 15

Re: Epo 5.9.1 RSD 5.0.5.130

Jump to solution

That is a policy enforcement error with ENS and not related to uninstalling RSD.  However, the agent version you are running has some known issues (I assume it is 5.0.6.220?).  Also, ENS and the agent have some timeout issues, which could be resulting in your policy enforcement issues.  What version of ens are you running?  I would suggest upgrading the agent to the latest 5.5.1 agent and any newer ENS version.  Once the agent is upgraded, try to remove RSD again.  If it fails, does it also fail if you remove it from add/remove programs?  That is not meant as a solution since you have other systems to remove it from also, but to see if there is any issue with corruption.  Does the master repository have the same version of RSD that you are trying to uninstall?

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

14 Replies
Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 2 of 15

Re: Epo 5.3.2 RSD 5.0.5.120

Jump to solution

just found that uninstalling first VSE 8.8 via ePO then uninstalling RSD via epo works. then i reinstalled VSE 8.8

instead of removing VSE i tried to disable "access protection" and "on-access scanner" but in this way RSD uninstall is not working with the err msg above.

any idea ?

i swear that days/weeks ago i hadn't problems installing/uninstalling RSD from ePO...

Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 3 of 15

Re: Epo 5.3.2 RSD 5.0.5.120

Jump to solution

I'm still stuck with this problem.

as workaround, for the many RSD i "wrongly" depolyed, i created a policy to disable the sensor.

still don't understand why install via ePO works in seconds and a subsequent uninstall fails as reported above

any idea?

thanks in advance for sharing and cooperate

McAfee Employee moekhass
McAfee Employee
Report Inappropriate Content
Message 4 of 15

Re: Epo 5.3.2 RSD 5.0.5.120

Jump to solution

​, are you running the most current extensions for RSD? What version of McAfee agent are you running?

RSD should uninstall gracefully. If not, there are other ways as you described, from control panel or using some scripting ..

Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 5 of 15

Re: Epo 5.3.2 RSD 5.0.5.120

Jump to solution

Hi Hassan,

    

it happens with agents with ver  5.0.5.658

yes i know there are other ways but unfortunately i have to remediate to a situation where it was installed on about 260 agents . so manual is a expensive option...

as i already said - if i run a client task to install RSD sensor it work in seconds , if on the same system i run the uninstall i get the error.

thanks for cooperation

Pmaquoi
Level 11
Report Inappropriate Content
Message 6 of 15

Re: Epo 5.3.2 RSD 5.0.5.120

Jump to solution

i've almost the same issue wit hagent 5.0.6 and epo 5.3.2

some installation of rogue sensor are not correctly done because of (written in the log) the fact that uninstalling the previous version is impossible.

Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 7 of 15

Re: Epo 5.3.2 RSD 5.0.5.120

Jump to solution

if i understand correctly you have problems in installing RSD via ePO. i have the opposite: no problems in deploying RSD via ePO but, if i try to run the task to remove RSD , it fails... :-(

Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 8 of 15

Re: Epo 5.9.1 RSD 5.0.5.130

Jump to solution

involved versions changed

epo 5.9.1

agent 5.0.6

rsd 5.0.5.130

but problem remains

I'm able to install new RSD component to agents via ePO client task BUT the task to uninstall RSD component from an agent fails

what makes this a big problem is that i should remove RSD from hundreds of agents

thanks in advance for your cooperation

Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 9 of 15

Re: Epo 5.9.1 RSD 5.0.5.130

Jump to solution

Sent Run Now task "Remove RSD" to "xxxxxxxxxx"
Run now task Remove RSD received.
Run now task Remove RSD started.
Run now task started.
Run now task Remove RSD failed.<br/>Details: Product "RSD_____4700" uninstallation failed, reason "Unknown error"..
Task Completed
Run now task Remove RSD failed.
Task Completed

Reliable Contributor boschind
Reliable Contributor
Report Inappropriate Content
Message 10 of 15

Re: Epo 5.9.1 RSD 5.0.5.130

Jump to solution

this is what is logged when the uninstall of RSD is attempted

2018-11-07 12:21:41 E #5936 ScrptExe Error trace:
2018-11-07 12:21:41 E #5936 Thread [Main thread]->
2018-11-07 12:21:41 E #5936 SessMgr [SessionManager::runScript:C:\ProgramData\McAfee\Agent\update\InstallMain.McS]->
2018-11-07 12:21:41 E #5936 ScrptExe [Executing section ScriptMain]->
2018-11-07 12:21:41 E #5936 ScrptExe [Call]->
2018-11-07 12:21:41 E #5936 ScrptExe [Executing section UninstallAllProducts]->
2018-11-07 12:21:41 E #5936 ScrptExe [LoopIf]->
2018-11-07 12:21:41 E #5936 ScrptExe [Executing section GetProductIDAndUninstallProduct]->
2018-11-07 12:21:41 E #5936 ScrptExe [Call]->
2018-11-07 12:21:41 E #5936 ScrptExe [Executing section UninstallProduct]->
2018-11-07 12:21:41 E #5936 ScrptExe [RunAppWait]->
2018-11-07 12:21:41 E #5936 ScrptExe Failed to invoke the application - error: 5