cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 1 of 16

EPO superagent repository replication failed

Jump to solution

The replication to a superagent repository is getting failed from EPO server.EPO server is able to reach and telnet to superagent repository.

 

Also when I am trying to reach & telnet to this repository from client machine there is no issue.When trying to access this repository from client system browser its giving 403 forbidden error.

 

I dont understand what actually problem is as everything seems to be correct.I also gone through different cKB & community articles but it  didnt worked

1 Solution

Accepted Solutions
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 12 of 16

Re: EPO superagent repository replication failed

Jump to solution

What version of the agent?  It appears some of the services aren't functioning properly.  When you removed the agent and reinstalled, did you delete the directory that the repo is set to use?  If you didn't, that needs to be completely removed so the agent superagent conversion process creates that itself.

Otherwise I would recommend opening a ticket with McAfee.

15 Replies
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 2 of 16

Re: EPO superagent repository replication failed

Jump to solution

check the epoapsvr log on the epo server to see what errors are there.  Then on the client, check the macmnsvc log for what errors are there.  Ensure the agent policy has lazy caching disabled.  if it is enabled, disable it, then restart the agent services on client.

Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 3 of 16

Re: EPO superagent repository replication failed

Jump to solution

Hi,

Thanks for the update.Below are the extract from EPO server Epoapsvr logs:-

20180405202907 I #03256 INETMGR Starting download session for site ePOSA_Servername.
20180405202907 I #03256 NAINET HTTP Session initialized
20180405202907 I #03256 NAINET Connecting to HTTP Server in socket-mode
20180405202907 I #03256 NAINET Connecting to Real Server: Servername.za.if.atcsg.net on port: 2082
20180405202907 E #03256 NAINET HTTPConnection.cpp(2245): Connected to Real Server: Servername.za.if.atcsg.net on port: 2082. No Proxy used!
20180405202907 I #03256 INETMGR Started download session 1 for site ePOSA_Servername.
20180405202907 I #03256 SITEMGR CheckSiteStatus: Downloading file SiteStat.xml from site ePOSA_Servername
20180405202907 I #03256 INETMGR Downloading file SiteStat.xml from session 1, LocalDir=C:\Windows\TEMP\nai990F.tmp\00000001, RemoteDir=.
20180405202907 I #03256 NAINET Open URL: http://Servername.za.if.atcsg.net:2082/Software/SiteStat.xml
20180405202907 I #03256 NAINET Trying to download using windows socket library
20180405202907 I #03256 NAINET Sending HTTP GET Request Header. No Authentication used
20180405202907 E #03256 NAINET HTTPConnection.cpp(1944): Unknown HTTP status code 403 encountered
20180405202907 I #03256 INETMGR Download file SiteStat.xml failed in session 1, nainet ret=0.
20180405202907 I #03256 SITEMGR CheckSiteStatus: Failed to download SiteStat.xml from site ePOSA_Servername, hr=-2147467259
20180405202907 e #03256 SITEMGR Download sitestat.xml failed, error -803
20180405202907 I #03256 NAINET HTTP Session closed

 

I tried to look for this error and found issue is resolved in McAfee agent 5.0.5 but I am already using 5.0.6.Also lazy caching is already disabled.

Can you please suggest something to resolve this issue

Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 4 of 16

Re: EPO superagent repository replication failed

Jump to solution

Hi,

I also have the screenshot from EPO server task showing failed superagent repository but I am not able to upload it on Mcafee community.I dont know why

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 5 of 16

Re: EPO superagent repository replication failed

Jump to solution

If the superagent is giving that 803 return code, you need to look at the macmnsvc log on the superagent to see what errors are there.

Is there a proxy server in environment?  EPO isn't set to use one, but perhaps it should.  Can you get to this url in the browser from the epo server (substitute servername with correct name)?  If you can, does the browser use a proxy?  If it does and you disable the proxy, try the url again to see if it fails.

http://Servername.za.if.atcsg.net:2082/Software/SiteStat.xml

 

Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 6 of 16

Re: EPO superagent repository replication failed

Jump to solution

Hi,

From the EPO I am getting the same error as 403 forbidden as I am getting from client machine.There is a proxy server in our environment.There i sproxy configuration in EPO proxy settings but I dont see any proxy setting in the browser.

Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 7 of 16

Re: EPO superagent repository replication failed

Jump to solution

Also I checked SiteStat.xml file on Superagent Repository server its showing as disabled.Below is the output from that file

<?xml version="1.0" encoding="UTF-8"?>

<SiteStatus Status="Disabled"> </SiteStatus>

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 8 of 16

Re: EPO superagent repository replication failed

Jump to solution

It shows disabled when a replication is occurring.  Make sure there is no replication occurring, stop agent services, set it back to enabled, start services and see if replication can succeed.  Otherwise you need to look at the log that I said to check and other tests.

 

Reliable Contributor haaris
Reliable Contributor
Report Inappropriate Content
Message 9 of 16

Re: EPO superagent repository replication failed

Jump to solution

There is no replication occuring this time.I already tried enabling sitetsat.xml file and restarting agent services but still same error

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 10 of 16

Re: EPO superagent repository replication failed

Jump to solution

then you are back to looking at the agent log that I mentioned - what errors are there?