Showing results for 
Search instead for 
Did you mean: 

EPO Agent 4.0

We are currently running the latest EPO 4.0 version and it seems the EPO agent 3.6 versions on the clients are only updating when manualy clicking on Update with the rightmouse button.

Also they recieve the following error :

Updates were not applied because they were not in the repository VSCANEU1000 EXTRADAT1000 BOCVSE_1000

Is this the reason why the auto update functionality fails? Agent logs do show that communication and policy enforcement is working fine with the 3.6cma agent version.

To resolve this issue I installed the latest 4.0 Agent version (patch 1 I believe) and also checked in the agent extension.

I then manualy deployed two of these 4.0 agent versions to two of our test pc's.

This seem to work, I don't see any mcafee dialogue popping up (like in the 3.6 version) but the system info in EPO now shows Mcafee agent version :

McAfee Agent, Product Coverage Reports, VirusScan Enterprise

The strange thing is that I'm unable to acces the logfile website ( http://pcname:8081/ ).

This gives me a HTTP 403 Forbidden. Has the website logging been removed in 4.0? If so, where can I find the agent logs for 4.0?

And last but not least, even with 4.0 agents installed I still get the repository error (see above) and also these agents are not updating by itself.

I can't downgrade to 3.6, this has been removed from the system repository it seems, there wasn't an option to move it to the previous repository when installing the 4.0 agent.

Am I now stuck with a non logging/bad working 4.0? Or is it normal that there is no more logging website for the clients? If so, how do I resolve the repository updat eproblem and which client task do I need to add to automaticaly update the client antivirus defenitions?

Thanks in advance for the help!
3 Replies

RE: EPO Agent 4.0

Quick update on the logging website for the clients, I tried pressing show agent log from the epo website and it DOES show the website for the clients.

It seems that using http://pchostname:8081 doesn't work and http://ipadress:8081 does work.

The dns is correct, I can ping the hostname and I recieve the same ip. Anybody know how to resolve this dns problem?

Or I always need to view the agent logs by ussing the show agent log button using epo? Instead of just opening a browser and typing in the http://hostname:8081

I guess the agent is installed properly, it's just the auto update and the repository error which isn't working 😞

Should I set global update to enabled for all packages? Does this update the clients?

Port 8081 not showing logs

Same problem for me (latest versions of epo and agent) : cannot access clients from http://hostname:8081

As a workaround, you can access the logs from "%allusersprofile%\Application Data\McAfee\Common Framework\DB"

To toubleshoot your problem, I would suggest to use the McAfee Agent Monitor :
x32 : "%ProgramFiles%\McAfee\Common Framework\CmdAgent.exe" /s
x64 : "%ProgramFiles(x86)%\McAfee\Common Framework\CmdAgent.exe" /s

Good luck.

Found it

I took a look to the problem and I found where it came from :

From the ePolicy Orchestrator Web Console:
1. Click the "Systems" menu
2. Click the "Policies" sub-menu
3. From the "Product" drop-down list, select "McAfee Agent"
4. Click on your policy ("My Default" by default) to edit it
5. Click the "Logging" tab
6. Tick "Enable remote access to log" checkbox
7. Click "Save" on the lower right corner

You just have to refresh the client agents for them to apply the modification, and it works!
More McAfee Tools to Help You
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • Visit: Business Service Portal
  • More: Search Knowledge Articles
  • ePolicy Orchestrator Support

    • Download the new ePolicy Orchestrator (ePO) Support Center Extension which simplifies ePO management and provides support resources directly in the console. Learn more about ePO Support Center