cancel
Showing results for 
Search instead for 
Did you mean: 
Quitch
Level 7
Report Inappropriate Content
Message 1 of 3

Domain <> X excludes blank. Bug?

Jump to solution

Is this a bug?

I am trying to setup the following query in ePO 4.5:

When a rogue system detection is triggered

And the OS platform is not Windows

And the domain is not Domain

Move the system to exceptions

However, this isn't triggering. I've been running queries and found that if you use "Domain does not equal X" then it only includes machine which have a domain entry. If the domain entry is blank it is excluded, but to me this appears to be incorrect behaviour as no domain is also not X.

Can anyone confirm?   

Message was edited by: Quitch on 08/02/11 16:09:52 GMT
1 Solution

Accepted Solutions
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: Domain <> X excludes blank. Bug?

Jump to solution

I think the default behaviour is to exclude blanks - try adding a "domain - value is blank" criterion as well...

HTH -

Joe

2 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: Domain <> X excludes blank. Bug?

Jump to solution

I think the default behaviour is to exclude blanks - try adding a "domain - value is blank" criterion as well...

HTH -

Joe

Quitch
Level 7
Report Inappropriate Content
Message 3 of 3

Re: Domain <> X excludes blank. Bug?

Jump to solution

That did the trick.

I would suggest here that the behaviour of "Does not equal" is counter-intuitive.