cancel
Showing results for 
Search instead for 
Did you mean: 

Distributed Repository doesn't replicate

Hi,

We are running ePolicy Orchestrator version 3.6.0.575 and our Repository Replication task continues to fail, although at one stage it did.

The repository is a UNCSite. I have pasted the las few entries from the EpoApSvr.log file so you can see the issue I think is causing the problem.

Regards

Mark

20091001010748 I #5628 SIM_InetMgr Session 1 ended, result=1
20091001010748 x #5948 SiteMgr SiteMgr main control final release...
20091001010748 I #5948 RManJNI Catalog version For Global updating is 20091001000638
20091001010748 I #5948 EPOJNI Processing console request file
20091001010748 I #5948 EPOJNI Console request file does not exist
20091001021600 I #5948 SiteMgrWrap Created instance of Site Manager
20091001021600 I #5948 SiteMgrWrap DispEventAdvise on Site Manager succeeded
20091001021600 I #5948 SiteMgr SetEPOMode: SiteMgr enter ePO mode, server=NOBEL, port=8443, EPOUser=, Password=********
20091001021600 I #5948 SiteMgr DALInit: Connected to DAL successful
20091001021600 I #5948 SiteMgr SetEPOMode: Set ePO mode successful
20091001021600 I #5948 SiteMgr DownloadSiteListThreadProc: Download sitelist thread started
20091001021600 I #5948 SiteMgr DownloadSiteListThreadProc: Download sitelist thread ended
20091001021600 I #5948 SiteMgr Get SiteMgr status 0
20091001021600 I #8000 SiteMgr ReplicationThreadProc: Replication thread started
20091001021600 I #8000 SiteMgr ReplicationThreadProc: Replication using 12 threads
20091001021600 I #8000 SiteMgr Replication Temp dir: C:\WINNT\TEMP\nai26AD.tmp\00000000
20091001021600 I #8000 SiteMgr DownloadSiteListThreadProc: Download sitelist thread started
20091001021600 I #8000 SiteMgr DownloadSiteListThreadProc: Download sitelist thread ended
20091001021600 I #8000 SIM_InetMgr Starting upload session for site ePO_NOBEL
20091001021600 I #8000 naInet HTTP Session initialized
20091001021600 I #8000 naInet Connecting to HTTP Server using Microsoft WinInet
20091001021600 I #8000 naInet Trying to connect to Real Server 10.61.1.148 using INTERNET_OPEN_TYPE_PRECONFIG
20091001021600 I #8000 naInet Connected to Server: 10.61.1.148 on Port: 82 using WinInet
20091001021600 I #8000 McUpload Start http session login...
20091001021600 I #8000 McUpload End http session login, status=0
20091001021600 I #8000 McUpload Http response status code = 200
20091001021600 I #8000 SIM_InetMgr Started upload session 1 for site ePO_NOBEL
20091001021600 I #8000 SiteMgr Relication on ePO server, skip download from master site
20091001021600 I #8000 SiteMgr Replication determining master site size
20091001021645 e #8000 SiteMgr GetFileInfo:: Failed to open file D:\Program Files\Network Associates\ePO\3.6.0\Db\Software\agent-hpux.zip, system error code 2
20091001021645 e #8000 SiteMgr Failed to get file size and hash info for D:\Program Files\Network Associates\ePO\3.6.0\Db\Software\agent-hpux.zip
20091001021645 e #8000 SiteMgr Failed to get the directory tree file size for D:\Program Files\Network Associates\ePO\3.6.0\Db\Software
20091001021645 I #8000 McUpload Start http session login...
20091001021646 I #8000 McUpload End http session login, status=0
20091001021646 I #8000 McUpload Http response status code = 200
20091001021646 I #8000 McUpload Http response status code = 200
20091001021646 I #8000 naInet HTTP Session closed
20091001021646 I #8000 naInet ------------------------------------------------------------
20091001021646 I #8000 SIM_InetMgr Session 1 ended, result=1
20091001021646 x #5948 SiteMgr SiteMgr main control final release...
20091001104210 I #2752 EPOJNI Getting license data...
20091001104210 I #2752 EPOJNI Got license data, buffer size = 153
20091001104212 I #5160 EPOJNI Getting license data...
19 Replies
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 20

RE: Distributed Repository doesn't replicate

The important line is this one:

20091001021645 e #8000 SiteMgr GetFileInfo:: Failed to open file D:\Program Files\Network Associates\ePO\3.6.0\Db\Software\agent-hpux.zip

This is saying that ePO is being told to replicate this file, but that it's not present.

I note that this is the root of the repo, which presumably means that you have got legacy support enabled for your pull tasks. Can I ask if you actually need this? A lot of people think they do but actually don't happy Unless you have any Novell servers updating themselves from an epo-managed repo, it's unlikely that you need this option...

Can I suggest you try the following:

1) In the ePO console, delete the dat package from the master repo
2) Do a Pull Now task - make sure that you do not select "enable legacy support"
3) Once complete, try a replication.

Does it work?

HTH -

Joe

RE: Distributed Repository doesn't replicate

Yeah I thought that line was the cause of the problem. And no, I don't have any need for Novell support so i can do without.

I have tried what you suggested and I'm afraid to report the same lines appear in the log file. I only deleted the current DAT package, should I have deleted the previous packages as well? Or do I need to manually clear out a the folder? What I don't understand is why it tries to copy something that it doesn't have.

Mark
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 20

RE: Distributed Repository doesn't replicate



That's fine - I wasn't expecting it to work, but it will make it easier to fix Smiley Happy
Replication tasks are driven by the replica.log files. What's happening here is that the replica.log is referencing a file that doesn't exist - the good news is it's comparatively easy to edit them.

Can you post the contents of D:\Program Files\Network Associates\ePO\3.6.0\Db\Software\replica.log, and a directory listing of D:\Program Files\Network Associates\ePO\3.6.0\Db\Software? Then I can show you how to edit the file accordingly...

Thanks -

Joe

RE: Distributed Repository doesn't replicate

Ok good. Your initial answer gave me an idea though, although far from ideal. By copying an old agent-hpux.zip file from the distributed repository to the master it allowed me to complete a replication. But I was hopign you'd come back with a better fix than that!

Here is the replica.log:

[General]
NumItems=29
[Item_1]
Name=catalog.z
Type=File
Size=4396
Hash=CD15632E7982DA8BF422C0BD9D7B77A6E66FEDE7
[Item_2]
Name=Current
Type=Directory
Size=0
Hash=
[Item_3]
Name=SuperDATInstall.mcs
Type=File
Size=5388
Hash=C6DB0E7BAB7BDAB134B4F7401A45353B025D3787
[Item_4]
Name=Setup.exe
Type=File
Size=323461
Hash=CB0E0E4955829EC522EDC130A0F3651AF70C3AA1
[Item_5]
Name=Previous
Type=Directory
Size=25972
Hash=
[Item_6]
Name=EceptHelper.mcs
Type=File
Size=620
Hash=10F9A996FE2B2BFA5F9A181D37550C6595239446
[Item_7]
Name=EceptCntIns.mcs
Type=File
Size=34324
Hash=1DB0C6F56D2A64496A70E33DED6511D6643D9028
[Item_8]
Name=agent-hpux.zip
Type=File
Size=7006
Hash=AE3EF5513CC06F134CF5F013ABB71A767A92DD19
[Item_9]
Name=agent-linux.zip
Type=File
Size=9609
Hash=DE60650C97CF92D9199CA62E1EBA21798110E1D0
[Item_10]
Name=agent-solaris.zip
Type=File
Size=16780
Hash=E207333E96F1A7B2929D0E77650C6716E3FF8D36
[Item_11]
Name=agent-windows.zip
Type=File
Size=255767
Hash=A4D43399D2BDD33EB4B4E7198432A5077E75EE68
[Item_12]
Name=Metadata.zip
Type=File
Size=692136
Hash=45980A739001866AAA2BF51B9CEBA7C5E183D51F
[Item_13]
Name=server.zip
Type=File
Size=603558
Hash=10B68C387812E59C98E4BA2906867B5CD66BABF8
[Item_14]
Name=dat-5353.zip
Type=File
Size=35780820
Hash=9430E1B0F8554476DBFB7AA178410EE1EE5530A6
[Item_15]
Name=avvdat-5353.zip
Type=File
Size=29407751
Hash=2FADD0344BDF92B4D055404EBAD07FDDF2A62A08
[Item_16]
Name=53445345.upd
Type=File
Size=647667
Hash=86FE9DDA8AF8D5D5F8C4FFAFA5384CCC552B2EB5
[Item_17]
Name=53445345avv.gem
Type=File
Size=395556
Hash=78E6CB2F4D7A741503CBE895D9C92CEF1D8C4FA5
[Item_18]
Name=53435344.upd
Type=File
Size=1007181
Hash=A09F8357133D97B4656DE7641E36F4735A8105E4
[Item_19]
Name=53435344avv.gem
Type=File
Size=719148
Hash=237D54B754F9ADA2D969371A494D8B6D201AE476
[Item_20]
Name=53425343.upd
Type=File
Size=488132
Hash=51EC58B88C82A5C8AE4D1C18C692BE6FB243C3F9
[Item_21]
Name=53425343avv.gem
Type=File
Size=249132
Hash=6E0A856F0BE24EB156C59A4F84A1D5C36CCE6BF5
[Item_22]
Name=53415342.upd
Type=File
Size=458337
Hash=C571E5E21E3E3538E43990B826E9C18C0E2148B9
[Item_23]
Name=53415342avv.gem
Type=File
Size=191220
Hash=E187924A3824E02672EDE18415B10B515F59338B
[Item_24]
Name=53405341.upd
Type=File
Size=393998
Hash=7B87B0D2F8BCBB03B31000662DA80A7EF3D50544
[Item_25]
Name=53405341avv.gem
Type=File
Size=174420
Hash=8612B57365B5DC29C5C33EBCF9D7CE28CB69ACA4
[Item_26]
Name=53395340.upd
Type=File
Size=276784
Hash=56CA9480E1794AFAC4D87352A023E0C2402C270C
[Item_27]
Name=53395340avv.gem
Type=File
Size=91588
Hash=673F59A878580BC058D9E2A5D83BFD830B205B0D
[Item_28]
Name=53385339.upd
Type=File
Size=360459
Hash=B162C7B3592AFDFB9C8E69C4068CF40EE65B8179
[Item_29]
Name=53385339avv.gem
Type=File
Size=201732
Hash=037273360B0E9D91515163701DD52116A8F560AE

*****and***** (i have since removed the agent-hpux.zip file)

Directory of D:\Program Files\Network Associates\ePO\3.6.0\DB\Software

01/10/2009 16:18 <DIR> .
01/10/2009 16:18 <DIR> ..
05/08/2008 01:01 360,459 53385339.upd
05/08/2008 01:01 201,732 53385339avv.gem
05/08/2008 01:01 276,784 53395340.upd
05/08/2008 01:01 91,588 53395340avv.gem
05/08/2008 01:01 393,998 53405341.upd
05/08/2008 01:01 174,420 53405341avv.gem
05/08/2008 01:01 458,337 53415342.upd
05/08/2008 01:01 191,220 53415342avv.gem
05/08/2008 01:01 488,132 53425343.upd
05/08/2008 01:01 249,132 53425343avv.gem
05/08/2008 01:01 1,007,181 53435344.upd
05/08/2008 01:01 719,148 53435344avv.gem
05/08/2008 01:01 647,667 53445345.upd
05/08/2008 01:01 395,556 53445345avv.gem
09/09/2009 08:44 9,609 agent-linux.zip
09/09/2009 08:44 16,780 agent-solaris.zip
09/09/2009 08:44 255,767 agent-windows.zip
05/08/2008 01:01 29,407,751 avvdat-5353.zip
01/10/2009 15:11 4,396 catalog.z
01/10/2009 15:11 <DIR> Current
05/08/2008 01:01 35,780,820 dat-5353.zip
01/10/2009 16:18 0 dir.txt
09/09/2009 08:44 34,324 EceptCntIns.mcs
09/09/2009 08:44 620 EceptHelper.mcs
06/10/2005 15:03 <DIR> GROUPSHD6000
09/09/2009 08:44 692,136 Metadata.zip
01/10/2009 01:05 <DIR> Previous
01/10/2009 15:11 2,894 Replica.log
09/09/2009 08:44 603,558 server.zip
30/03/2005 20:00 323,461 Setup.exe
01/10/2009 15:11 64 SiteStat.xml
25/08/2004 03:50 5,388 SuperDATInstall.mcs
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 20

RE: Distributed Repository doesn't replicate

Hmmm... all of those files in the root would imply that the pull task still had "enable legacy update" enabled. Can you delete the dat package again and do another pull with it definitely disabled? (And if there are any scheduled pull tasks configured, edit them so that legacy support is disabled?)
I'm expecting to see only a few files and folders in there...

Thanks -

Joe

RE: Distributed Repository doesn't replicate

I deleted the DAT package from the Repository and going to Manage Packages...

I've double checked the legacy setting in the DAT Pull from McAfee, and its turned off. And that is the only Pull task we have running. And the Distributed Replication failed again.

Mark
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 20

RE: Distributed Repository doesn't replicate

OK, great... what files are in the root of the master repo now? (The DB\Software folder)

RE: Distributed Repository doesn't replicate

Directory of D:\Program Files\Network Associates\ePO\3.6.0\DB\Software

01/10/2009 17:13 <DIR> .
01/10/2009 17:13 <DIR> ..
05/08/2008 01:01 360,459 53385339.upd
05/08/2008 01:01 201,732 53385339avv.gem
05/08/2008 01:01 276,784 53395340.upd
05/08/2008 01:01 91,588 53395340avv.gem
05/08/2008 01:01 393,998 53405341.upd
05/08/2008 01:01 174,420 53405341avv.gem
05/08/2008 01:01 458,337 53415342.upd
05/08/2008 01:01 191,220 53415342avv.gem
05/08/2008 01:01 488,132 53425343.upd
05/08/2008 01:01 249,132 53425343avv.gem
05/08/2008 01:01 1,007,181 53435344.upd
05/08/2008 01:01 719,148 53435344avv.gem
05/08/2008 01:01 647,667 53445345.upd
05/08/2008 01:01 395,556 53445345avv.gem
09/09/2009 08:44 9,609 agent-linux.zip
09/09/2009 08:44 16,780 agent-solaris.zip
09/09/2009 08:44 255,767 agent-windows.zip
05/08/2008 01:01 29,407,751 avvdat-5353.zip
01/10/2009 16:47 4,404 catalog.z
01/10/2009 16:47 <DIR> Current
05/08/2008 01:01 35,780,820 dat-5353.zip
01/10/2009 17:13 0 dir.txt
09/09/2009 08:44 34,324 EceptCntIns.mcs
09/09/2009 08:44 620 EceptHelper.mcs
06/10/2005 15:03 <DIR> GROUPSHD6000
09/09/2009 08:44 692,136 Metadata.zip
01/10/2009 01:05 <DIR> Previous
01/10/2009 16:47 2,894 Replica.log
09/09/2009 08:44 603,558 server.zip
30/03/2005 20:00 323,461 Setup.exe
01/10/2009 16:47 64 SiteStat.xml
25/08/2004 03:50 5,388 SuperDATInstall.mcs
29 File(s) 72,792,930 bytes
5 Dir(s) 3,362,680,832 bytes free
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 10 of 20

RE: Distributed Repository doesn't replicate




Hmm.. it's worse than I thought :-)
Can you post the contents of the replica.log again, as hopefully it's changed? Last time, I promise Smiley Happy

Thanks-

Joe