cancel
Showing results for 
Search instead for 
Did you mean: 

Deploying Visrus Scan with ePO 4

Hi All,

I have just installed ePO 4 as a clean installation and deployed the ePO agent to machines without any problems.

The issue is that I cannot install the VisrusScan agent nor the Spyware agent even though I have created a package for them. I created the packae by downloading the Zip file from the McAfee site and pointing the package at the Zip. I have also created a new Client Task using the Product Deployment (McAfee Agent) and chose both the AntiVirus and AntiSpyware applications.

The settings for this are to run every hour for 15 minutes. Out of the 19 machines that I have installed the agent on, only two had the AV software installed manually and these are the only two that have updated. None of theother machines are installing the software.

Any ideas?
10 Replies
mdyer
Level 7
Report Inappropriate Content
Message 2 of 11

Check the agent log

Take a look at the agent log and you should find some additional debugging info. You're correct in the steps that you've taken - as long as the deployment task is applicable to the machines based on where they are located in the system tree.

From the logs...

Cheers - This is what I found in the agent log on one of the machines and it is the same on others that I have checked. I have two lines highlighted that I have Googled and not found anything on them. I have also seen some 'LoadSchedule--error' errors too.

In the MCScript.log I can see that it actually downloads and verifies the VSE850Det.mcs, PkgCatalogue.z, and starts the installation and stops at 'Verifying setup.exe'. It appears to just stay there until the user restarts teh machine and then it goes through the process of downloading the files again and hangs at verifying.

The account that I am using is a local admin on the workstation and if I log on to the machines with that account I can manually run the installation without any problems.


0 fields of the task 38 are updated successfully
>>--CSchedule::ModifyTask
<<--CSchedule::ModifyTask hr=0x8000001b
>>--CSchedule::CreateTask
<<--CSchedule::CreateTask
m_szTaskName = -> Test Installation
m_szPlatforms = -> WIN95|WIN98|WINME|WNTS|WNTW|WXPW|WXPS|WXPHE|W2KS|W2KW|WVST|WVSTS
m_uTaskPriority = 99 -> 0
m_szOwnerSoftwareID = -> EPOAGENT3000
m_szVersion = -> 17427
m_szTaskType = -> Deployment
m_szCreatorSoftwareID = -> EPOAGENT3000
Enabled = 0 -> 1
StartDateTime = 00000000000000 -> 20071030120000
TaskRepeatable = 0 -> 1
RepeatOption = 0 -> 1
RepeatInterval = 0 -> 5
UntilOption = 0 -> 1
RepeatDays = 0 -> 1
nUntilMinute > 0 || nUntilHour >0--->false
m_lpSchedule->LoadSchedule --error
>>--CSchedule::AddTask
nUntilMinute > 0 || nUntilHour >0--->false
m_lpSchedule->LoadSchedule --error
Failed to add the task: error code= 0x80000029
<<--CSchedule::AddTask hr=0x80000029
<<--CSchedule::UpdateOneTask hr=0x80000029
Failed to update the task 40 of EPOAGENT3000 at enforcement (Error: 0x80000029)

RE: From the logs...

Try reinstalling the agents on one of the machines then do a wakeup call to see if it receives its scheduled tasks successfully.

RE: From the logs...

Unfortunately that hasn't resolved the issue. I still receive exactly the same things in the logs.

RE: From the logs...

Try rechecking in virus scan enterprise and maybe recreate the deployment tasks...
tonyb99
Level 13
Report Inappropriate Content
Message 7 of 11

RE: From the logs...

IT does sound like a corrupt task at the client.. you could try the following to check this.

pick a client
disable framework service
delete the task ini files from:
- x:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\Task
- x:\Documents and Settings\All Users\Application Data\Network Associates\Common Framework\Task\TaskInternalData
repair VSE from add remove
restart framework service
initiate contact with EPO server

RE: From the logs...

Unfortunately that didn't work either.

I am seeing messages such as '0 fields of the task 44 are updated successfully' in the Agent_machine.log

Here is the ini file for that particular job:

[Task]
TaskName=AV Install
Platforms=WIN95|WIN98|WINME|WNTS|WNTW|WXPW|WXPS|WXPHE|W2KS|W2KW|WVST|WVSTS
TaskPriority=0
SoftwareName=EPOAGENT3000
TaskID=44
CreatorSoftwareID=EPOAGENT3000
TaskType=Deployment
TaskVersion=23772
[DeploymentOptions]
DummyPolicy=0
UpdateAfterDeployment=0
[General]
TaskType=Deployment
[Install]
Install_1=VIRUSCAN8600
NumInstalls=1
[Install\VIRUSCAN8600]
InstallCommandLine=setup.exe
Language=0000
[Schedule]
GMTTime=0
RandomizationEnabled=0
RandomizationWndMins=0
RepeatDays=1
RepeatInterval=15
RepeatOption=1
RunIfMissed=0
RunIfMissedDelayMins=0
StartDateTime=20071108120000
StopDateValid=0
TaskRepeatable=1
Type=0
UntilDuration=20
UntilOption=1
[Settings]
Enabled=1
RunAtEnforcementEnabled=1
StopAfterMinutes=0
[Uninstall]
NumUninstalls=0
tonyb99
Level 13
Report Inappropriate Content
Message 9 of 11

RE: From the logs...

I dont know how 4.0 deals with them but I did find on 3.6.1 that update and other such tasks can interfere with the deployment task, have you tried temp disabling the update and any other tasks and just running the VSE install.??

BTW is there anything on these machines to start with like VSE 8.0?
In which case set this to uninstall and vse 8.5 to install as VSE is CXXX at removing prior versions with its own install (also allow more than 15 minutes if this is still in your task)

RE: From the logs...

Yes, sorry, should have mentioned that! I have disabled every other task and only have the deployment one running.

The machines currently have Trend installed (I have removed the password requirement to uninstall) but I have also removed Trend manually from two of the machines to see if this made any difference and it still showed the same behaviour.

I have removed the entire ePO client from a machines and sent it out again and this worked without any issues but the AV client will still not install.