cancel
Showing results for 
Search instead for 
Did you mean: 
dnf
Level 10

Deploying 4.6 agent to win7

I´m deploying agents to win xp clients and it work fine. But it wont work to win 7 clients.

I can access admin$ with the user I´m deploying and it downloads the "FramePkg.exe" installer. Is there something I´m missing that I should check to determine why isn´t working?

0 Kudos
15 Replies
dnf
Level 10

Re: Deploying 4.6 agent to win7

Could it be because of a 64 bits OS? Is there a difference on the agent version, patch or something?

0 Kudos
epoadm
Level 7

Re: Deploying 4.6 agent to win7

I have this same problem, but am not sure why. I do have a workaround, though. I have found that by adding the account I use to deploy the Agent to the administrators group on the ePO server, the software gets installed properly.

0 Kudos
dnf
Level 10

Re: Deploying 4.6 agent to win7

I´m not sure if I understood correctly. The user you use to deploy de agente has to be a member of the administrators group on the epo server itself? Apart from at the clients? Did it work for xp but not for win7 until you did that?

0 Kudos
rackroyd
Level 16

Re: Deploying 4.6 agent to win7

If the issue is specific to Win7 and not XP then perhaps UAC (User Access Control) is a factor ?

0 Kudos
dnf
Level 10

Re: Deploying 4.6 agent to win7

I´m trying to find out what the issue is. The user is in a group in the clients administrators group, so I don´t know why it´s not installing. The framework package downloads to the admin$ folder so I guess it´s not a permissions issue? I´m stuck right there now.

0 Kudos
Tristan
Level 15

Re: Deploying 4.6 agent to win7

Do you get any errors if you manually install the framepkg.exe that you can export from ePO?

0 Kudos
dnf
Level 10

Re: Deploying 4.6 agent to win7

For some reasons I have no rights/permissions to do it that way, but there is nothing that tells me it wouldn´t work....

FRMINST log file: In case somebody can see a clue

2012-11-27 14:27:00.306    I    #2972    Stub    Pkg   

2012-11-27 14:27:00.306    I    #2972    Stub    Pkg    START [FramePkg.exe  /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Common Framework"]

2012-11-27 14:27:00.306    I    #2972    Common    Pkg    CreateDirectory (C:\Windows\TEMP\mfeEBA9.tmp)

2012-11-27 14:27:01.539    I    #3660    Common    Pkg    CreateProcess (C:\Windows\TEMP\mfeEBA9.tmp\FrmInst.exe, /Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Common Framework" /FramePkg /OriginalFramePkg="C:\Windows\FramePkg.exe" /Cleanup="C:\Windows\TEMP\mfeEBA9.tmp" /LOGDIR="C:\Windows\TEMP\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword="")

2012-11-27 14:27:01    I    #2352    Setup    Ins    START [/Install=Agent /Silent /InstDir="<PROGRAM_FILES_DIR>\McAfee\Common Framework" /FramePkg /OriginalFramePkg="C:\Windows\FramePkg.exe" /Cleanup="C:\Windows\TEMP\mfeEBA9.tmp" /LOGDIR="C:\Windows\TEMP\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword=""]

2012-11-27 14:27:01    I    #2352    Setup    Ins    Windows 6.1.7600

2012-11-27 14:27:01    I    #2352    Setup    Ins    Running as System account, therefore no UI

2012-11-27 14:27:01    I    #2352    msiFix    Ins    Finding agent MSI product code

2012-11-27 14:27:01    I    #2352    msiFix    Ins    Got MSI product code {397F4DE2-3C5A-415C-9A36-1D8C2B30B92D}

2012-11-27 14:27:01    I    #2352    msiFix    Ins    Finding agent MSI version

2012-11-27 14:27:01    I    #2352    msiFix    Ins    Got agent MSI version 4.5.0301

2012-11-27 14:27:01    I    #2352    msiFix    Ins    Nothing to fix for this agent version

2012-11-27 14:27:01    I    #2352    Setup    Ins    Attempting to perform a setup operation

2012-11-27 14:27:01    I    #2352    Cmalib    Ins    Referencer 1 VIRUSCAN8700

2012-11-27 14:27:01    I    #2352    caShrLb    Ins    Installed version=4.5.0.1852

2012-11-27 14:27:01    I    #2352    caShrLb    Ins    Product count=1

2012-11-27 14:27:01    I    #2352    caShrLb    Ins    Managed mode=1

2012-11-27 14:27:01    I    #2352    Setup    Ins    Legacy installed=0

2012-11-27 14:27:01    I    #2352    Setup    Ins    Installing version=4.6.0.2935

2012-11-27 14:27:01    I    #2352    Setup    Ins    Higher version installed=0

2012-11-27 14:27:01    I    #2352    Setup    Ins    Existing Installed Path=C:\Program Files (x86)\McAfee\Common Framework

2012-11-27 14:27:01    I    #2352    Setup    Ins    Existing Data Path=C:\ProgramData\McAfee\Common Framework

2012-11-27 14:27:01    I    #2352    Setup    Ins    Existing setup program=C:\Program Files (x86)\McAfee\Common Framework\frminst.exe

2012-11-27 14:27:01    I    #2352    Setup    Ins    LangInRegistry=[040A]

2012-11-27 14:27:01    I    #2352    OptSet    Ins    /instdir ignored, product is already installed

2012-11-27 14:27:01    I    #2352    Setup    Ins    C:\Windows\SysWOW64\msiexec.exe /i "C:\Windows\TEMP\mfeEBA9.tmp\MFEagent.msi" ADDLOCAL=Main,Agent TRANSFORMS=:1034.mst /q REBOOT=R /l+*v "C:\Windows\TEMP\McAfeeLogs\MFEagent.msi.2012.11.27.14.27.01.log" SITEINFO="C:\Windows\TEMP\mfeEBA9.tmp\SiteList.xml" PRESERVEREPOSITORIES=True USELANGUAGE="040A" FRMINSTLOGFILE="C:\Windows\TEMP\McAfeeLogs\FrmInst_XXXXX"

2012-11-27 14:27:03.146    I    #3660    Stub    Pkg    Running as a service, therefore not waiting for installation to complete

2012-11-27 14:27:03.146    I    #2972    Stub    Pkg    END 0

2012-11-27 14:28:20.036    I    #4076    msacfg    cfg    Install site list,C:\Windows\TEMP\{1995804A-B1A2-4826-99DD-CEA1352D090B},1

2012-11-27 14:28:20.036    I    #4076    Cryptshim    cfg    Initializing crypto library

2012-11-27 14:28:20.036    I    #4076    Cryptshim    cfg    Using C:\ProgramData\McAfee\Common Framework\keystore as keystore path

2012-11-27 14:28:20.036    I    #4076    Cryptshim    cfg    Using C:\Program Files (x86)\McAfee\Common Framework\msaconfig.sig as exe signature file path

2012-11-27 14:28:20.192    I    #4076    MfeCryptC    cfg    RSA version : NIST Library Version 2.1.0.0

2012-11-27 14:28:20.192    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.192    I    #4076    MfeCryptC    cfg    RSA crypto role : User Role

2012-11-27 14:28:20.192    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.192    I    #4076    MfeCryptC    cfg    RSA crypto mode : NON-FIPS Mode

2012-11-27 14:28:20.192    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.255    I    #4076    Cryptshim    cfg    Successfully initialized crypto library

2012-11-27 14:28:20.255    I    #4076    Cmalib    cfg    Referencer 1 VIRUSCAN8700

2012-11-27 14:28:20.270    I    #4076    caShrLb    cfg    Installed version=4.6.0.2935

2012-11-27 14:28:20.270    I    #4076    caShrLb    cfg    Product count=1

2012-11-27 14:28:20.270    I    #4076    caShrLb    cfg    Managed mode=1

2012-11-27 14:28:20.270    I    #4076    stlscfg    cfg    Replacing SPIPE site in site list only

2012-11-27 14:28:20.333    I    #4076    stlscfg    cfg    Deleting sitecache.bin

2012-11-27 14:28:20.333    I    #4076    stlscfg    cfg    Removing old compiled policy

2012-11-27 14:28:20.333    I    #4076    stlscfg    cfg    Adding ReduceProcessPriority=1 to Agent.ini

2012-11-27 14:28:20.348    I    #4076    StSHlp    cfg    Creating ServerSiteList.xml

2012-11-27 14:28:20.348    I    #4076    Thread    cfg    Exit program

2012-11-27 14:28:20.364    I    #4076    msacfg    cfg    Initializing in NON-FIPS mode

2012-11-27 14:28:20.364    I    #4076    msacfg    cfg    Setting the key size to be used as Lower 1024 bits

2012-11-27 14:28:20.364    I    #4076    msacfg    cfg    Expecting these key files: C:\ProgramData\McAfee\Common Framework/srpubkey.bin, C:\ProgramData\McAfee\Common Framework/reqseckey.bin

2012-11-27 14:28:20.395    I    #4076    msacfg    cfg    Trying to re-initialize crypto libraries.

2012-11-27 14:28:20.395    I    #4076    Cryptshim    cfg    Released key data successfully

2012-11-27 14:28:20.395    I    #4076    Cryptshim    cfg    Initializing crypto library

2012-11-27 14:28:20.395    I    #4076    Cryptshim    cfg    Using C:\ProgramData\McAfee\Common Framework\keystore as keystore path

2012-11-27 14:28:20.395    I    #4076    Cryptshim    cfg    Using C:\Program Files (x86)\McAfee\Common Framework\msaconfig.sig as exe signature file path

2012-11-27 14:28:20.551    I    #4076    MfeCryptC    cfg    RSA version : NIST Library Version 2.1.0.0

2012-11-27 14:28:20.551    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.551    I    #4076    MfeCryptC    cfg    RSA crypto role : User Role

2012-11-27 14:28:20.551    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.551    I    #4076    MfeCryptC    cfg    RSA crypto mode : NON-FIPS Mode

2012-11-27 14:28:20.551    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.614    I    #4076    Cryptshim    cfg    Successfully initialized crypto library

2012-11-27 14:28:20.614    I    #4076    msacfg    cfg    Successfully re-initialized crypto libraries.

2012-11-27 14:28:20.614    I    #4076    Cryptshim    cfg    Successfully released key data

2012-11-27 14:28:20.614    I    #4076    MfeCryptC    cfg    Successfully freed key item

2012-11-27 14:28:20.614    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.629    I    #4076    Cryptshim    cfg    Successfully released key data

2012-11-27 14:28:20.629    I    #4076    MfeCryptC    cfg    Successfully freed key item

2012-11-27 14:28:20.629    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.645    I    #4076    Cryptshim    cfg    Successfully released key data

2012-11-27 14:28:20.645    I    #4076    MfeCryptC    cfg    Successfully freed key item

2012-11-27 14:28:20.645    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.660    I    #4076    Cryptshim    cfg    Successfully released key data

2012-11-27 14:28:20.660    I    #4076    MfeCryptC    cfg    Successfully freed key item

2012-11-27 14:28:20.660    I    #4076    MfeCryptC    cfg   

2012-11-27 14:28:20.660    I    #4076    Cryptshim    cfg    Successfully freed key data

2012-11-27 14:28:20.676    I    #4076    msacfg    cfg    Successfully imported the keys.

2012-11-27 14:28:20.676    I    #4076    msacfg    cfg    END 0

2012-11-27 14:28:40    I    #2352    Setup    Ins    MSI returned error 0: La operación se completó correctamente.

2012-11-27 14:28:40    I    #2352    Thread    Ins    Exit program

2012-11-27 14:28:40    I    #2352    Setup    Ins    END 0

2012-11-27 14:28:40.675    I    #3476    Main    Cle   

2012-11-27 14:28:40.675    I    #3476    Main    Cle    START [2884 /LOGDIR="C:\Windows\TEMP\McAfeeLogs" "C:\Windows\TEMP\mfeEBA9.tmp"]

2012-11-27 14:28:40.675    I    #3476    Common    Cle    WaitForSingleObject (calling FrmInst.exe, 30000)

2012-11-27 14:28:40.690    I    #3476    Main    Cle    Delete on reboot: C:\Windows\TEMP\mfeEBA9.tmp\cleanup.exe

2012-11-27 14:28:40.706    I    #3476    Main    Cle    Delete on reboot: C:\Windows\TEMP\mfeEBA9.tmp

2012-11-27 14:28:40.706    I    #3476    Main    Cle    END 0

El mensaje fue editado por: dnf on 27/11/12 7:59:59 CST
0 Kudos
Tristan
Level 15

Re: Deploying 4.6 agent to win7

Don't forget that on Win7 that even if your logged in as an administrator you don't have administrator rights. Right click 'Run As' to install it correctly.

Also from your log it appears that the agent has installed correctly. I can see is detected the already installed 4.5.0.1852 agent and successfully upgraded it to 4.6.0.2935

---> 2012-11-27 14:28:40 I #2352 Setup Ins MSI returned error 0: La operación se completó correctamente.

What makes you think it's not installing?

0 Kudos
dnf
Level 10

Re: Deploying 4.6 agent to win7

Hi Tristan, I saw that but the client still not showing up after an hour at the new console. While I´m writing this, it just appeared! I´ve tried so many things and I´m not sure which one worked. But at least now I know that it´s not a permissions issue at the client, ports or something I had no idea I had to configure or something. But in fact, I had to do something different than deploying to win xp. I´ll try to narrow what it was.

0 Kudos