Showing results for 
Search instead for 
Did you mean: 

Dependency Initialisation failure

On tuesday, our installation of ePO4 SP3 suddenly crashed. On rebooting and logging into ePO, the following errors were displayed below the login screen:

  • scp - Dependency RepositoryMgmt had initialization error
  • aramid - Dependency RepositoryMgmt had initialization error
  • EPOAGENTMETA - Dependency RepositoryMgmt had initialization error
  • RepositoryMgmt -

The server in question is 2003 32 bit with latest service pack and patches. Note that no new patches had been installed on this server prior to the crash. It is running SQL2005 express with SP3

Whatever caused this was not any of the following causes:

  1. Change of server name - NO has not been changed
  2. Mismatched port numbers - NO - Port number for both and the MSSQL installation were the same.
  3. Incorrect credentials - NO -Testing of the SQL connection from ePO to SQL server succeeded.

Assuming that for some reason the installation of ePO4 had corrupted itself, I tried the following;

  1. Reverting to a saved snapshot of the server
  2. Uninstall and clean install of ePO 4 on same server
  3. Install on brand new server with SP4 applied.

Unfortunately after a short while the errors reappear and although I can log into the console, the software menu icon is missing and thus ePO can no longer update the repository etc.

Can anyone help with this, as I have spent a significant proportion of time (days and nights!) since Tuesday.
Labels (1)
7 Replies
Level 7
Report Inappropriate Content
Message 2 of 8

RE: Dependency Initialisation failure

Was you SQL 2005 (gratis) empty ? It's possibly the cause of the crash.

Perhaps download again the installation package from ?

(you install pack could be corrupted)

Anyway, you can resarch on your disks if some mcafee files or, i think it's mainly possible : SQL files?
The snap could be unefficiant with this SQL which is a **** to uninstall.

RE: Dependency Initialisation failure

Thanks Pitch:) Unfortunately neither solution is the cause:( Everything installs OK and even after the dependency errors appear, I can still get a successful test connection to the SQL database from ePO4.

As I said, everything installs OK - the first update of the repository from NAIHTTP downloads and installs OK...all the policy settings I create work OK and the group creation and domain sync works properly. The dependency initialisation errors occur after:
Installation of SQL 2005 SP3 OR
Adding McAfee Agent 4 to the repository OR
Rebooting the server for the first time after Installation and setup of ePO4

Am getting bald patches tearing my hair out over this one<G>

RE: Dependency Initialisation failure

One of our customers is having the same problem, he hasn't changed IP nor name of ePO/SQL server and he is getting the same error messages.

  • scp - Dependency RepositoryMgmt had initialization error
  • aramid - Dependency RepositoryMgmt had initialization error
  • EPOAGENTMETA - Dependency RepositoryMgmt had initialization error
  • RepositoryMgmt - Master repository key corrupt

As we are also getting the "Master repository key corrupt" message it seems like the whole repository is corrupt.

We can always try to rebuild ePO's repository but we will have to check again all the software...

RE: Dependency Initialisation failure

Thanks Ulyses31..I will let the mcafee tech, who is now dealing with my case, know about this.

RE: Dependency Initialisation failure

We have rebuilt the repository but no luck 😞

Now the customer is telling me that the ePO server is also their DC so as McAfee says not installing ePO on a DC I suppose the problem can come go tis way

RE: Dependency Initialisation failure

Oh dear...not on a DC:( I hope the customer has another server they can add to their network to use as an ePO server.
I was advised, by McAfee tech support to to rebuild my sick server via using KB51438.
I will try this tomorrow, but I doubt it will solve the problem, as I have reinstalled (clean installs) and installed on a brand new server ( fully installed and configured and completely error free and yet the problem still occurs after a certain either after rebooting the new server for the first time or installing sql2005 sp3.

Path to repository changed.


We had this problem recently. It turned out that the path to our repository had changed.
The repository should be in C:\Program Files\Mcafee\ePolicy Orchestrator\server\extensions\installed\RepositoryMgmt but for some very strange reason ours was now within a sub directory of the RespositoryMgmt called RepositoryMgmt ie. C:\Program Files\Mcafee\ePolicy Orchestrator\server\extensions\installed\RepositoryMgmt\RepositoryMgmt
We just copied the contents of that directory back up one level and then everything worked again.
It definitely was not any of my colleges or myself that did this.
Hope this helps some sad admins out.
More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community