cancel
Showing results for 
Search instead for 
Did you mean: 

Dat Files Do Not Update With Windows 7 and ePO Agent 4.5

I am having an issue with my Windows 7 machines.  They currently have the ePO 4.5 agent installed, McAfee AntiVirus 8.7 and McAfee AntiSpyware 8.7.  However every few days I get a message from my Windows 7 machines that the dat files are out of date.  When I run a security update from the Windows 7 machine it communicates with my ePO server and updates it's dats.  But I have to initiate the update.  The agent does not.  Anyone else having this issue?

5 Replies

Re: Dat Files Do Not Update With Windows 7 and ePO Agent 4.5

Known issue that deployment task doesn't recognize win7 os and so won't run that task.

https://kc.mcafee.com/corporate/index?page=content&id=KB67594&actp=search&searchid=1268678761894

The task will either need recreating or sql tweaks on your epo db.  Hope that helps.

Re: Dat Files Do Not Update With Windows 7 and ePO Agent 4.5

Thank you for this however after I have completed all the steps (which I have done) how do I verify that Windows 7 is now a supported platform?  I sent an agent wake up call to my Windows 7 computers and they are still not updating automatically.  Please advise.

Re: Dat Files Do Not Update With Windows 7 and ePO Agent 4.5

Look at the agent log:          C:\ProgramData\McAfee\Common Framework\DB\Agent_computername.LOG

Look for this in the log file

2010-03-16 07:36:37 I #2536 Sched m_szTaskName =  -> Global Update
2010-03-16 07:36:37 I #2536 Sched m_szPlatforms =  ->  WIN95|WIN98|WINME|WNTS|WNTW|WXPW|WXPS|WXPHE|W2KS|W2KW|WVST|WVSTS
It should have WNT7W for Windows 7 in there.

Each task would have different platform codes.  Dig in to the kb article i sent and the linked ones at the bottom of it.  Good Luck.

Re: Dat Files Do Not Update With Windows 7 and ePO Agent 4.5

I found it.  Thanks it is working.  Thank you for your help.

Re: Dat Files Do Not Update With Windows 7 and ePO Agent 4.5

Cool, i was just going to comment that it appears those platform codes are only showing up on my tasks that aren't ok for Win7.  I'm still learning too...