cancel
Showing results for 
Search instead for 
Did you mean: 

Clients not communicating with ePO 4 server

I have recently upgraded to ePO 4.

All seemed to working fine until I notice that my clients are not communicating correctly with the server.

when i do an Manual update I see that the clients are getting the updates from ePO_{epo server} rather than connecting to ePO4_{ePO Server}

Clients are suprisingly getting correct dats and have upgraded to the latest AV Patches and Agent version. But ePO does not recognise this.

I have had a look through the SQL and my clients have seemed to stop communicating on the 21st of April (When I upgraded)

Any thoughts?
18 Replies
Scissor
Level 7
Report Inappropriate Content
Message 2 of 19

RE: Clients not communicating with ePO 4 server

I have a fresh install of ePo 4 (not an upgrade), and when I manually update my clients they connect to ePO_{server}.

I'm not sure why you are seeing ePO4_{server} in some of your logs.

I'm running the McAfee Agent 4.0 (not sure what version of the Agent you are running)
Unblack
Level 10
Report Inappropriate Content
Message 3 of 19

RE: Clients not communicating with ePO 4 server

We had the same issue. We had to uninstall the agent first.
FrmInst.exe /forceuninstall
Than reinstall the agent.

You can see the McAfee Agent Activity Log:
http://"Computername":8081/

RE: Clients not communicating with ePO 4 server

I will give this a go.

Got a few test PCs to see if this will give me some results.

Did you script the uninstall and reinstall of the new agent. Can you post what you did

RE: Clients not communicating with ePO 4 server

Hi,
is it possible that your Epo Security Keys after the Upgrade have changed?
i mean the Agent-server secure communication keys under Configurtaion-> Server Settings -> Security Keys.

When there is one Key which is showing not the correct numbers of clients u messed up something there.

RE: Clients not communicating with ePO 4 server

This is what I got where you have suggested.

I have no idea if this is correct or not


Agent-server secure {Server Name} (jHmj3CGX80KM5eoW37PF4yogsp8=) - 0 agents
communication keys: Legacy (HMW9L9yM2AbJY8qrvmNCNJpYXAI=) - 3074 agents - Master


Local master repository key pair: {Server Name} (uOAAxMx7ra9932HmE9WxiW4VwbE=)


Other repository public keys: McAfee (H7LGlPbFtbARjG6MsNaop1QOFaU=)

RE: Clients not communicating with ePO 4 server



This should be ok.
On the System Detail Page from an system shows there "Last Update" a valid date or does it shows the Date before u upgraded to epo?

When it shows the correct Date, why again u think then its not correct reporting?

RE: Clients not communicating with ePO 4 server

System Name IS166300
System Location My Organization\Corporate Domain\Main Sites\Civic
User Name bushea
Domain Name CORPORATE
IP Address 172.29.101.111
Operating System Windows XP Professional 5.1 Service Pack 2
Is 64 Bit OS Unknown
Description
Tags Workstation
System Tree Sorting Disabled
Managed State Managed
Agent Version 3.6.0.574
Last Update 5/21/09 10:45:31 AM
Installed Products McAfee Agent 3.6.0.574, Product Coverage Reports 3.6.0.574, VirusScan Enterprise 8.5.0.781.Wrk, McAfee AntiSpyware Enterprise Module 8.5.0.163
Custom 1
Custom 2
Custom 3
Custom 4
AntiSpyware Product Version 8.5.0.163
More

VirusScan Enterprise Product Version 8.5.0.781.Wrk
Language 0000
Hotfix/Patch Version 6
Service Pack
DAT Version 5614.0000
Engine Version 5301.4018
Engine (x64) Version
License Status
More

Product Coverage Reports Product Version 3.6.0.574
More

Agent Product Version 3.6.0.574
Language English
Hotfix/Patch Version




If you notice above, the last client connection is on the 21st.

If I connect to this client I get the following.

Scan engine version (32-bit): 5301.4018
dat Version: 5629.000
Dat Created on: 28 May 2009
Number if signitures ... : None
Names of Threats ... : None
Buffer overflow ... : 378
Installed Patches: 8

RE: Clients not communicating with ePO 4 server

So its not reporting the new Dat, new Agent, nor that its running Hotfix 8

RE: Clients not communicating with ePO 4 server

Hi,
in System details click on Show Agent Log.
Are there any failures?

When not click in the top of the agent log on View debug logs: FrameSvc current
Search for failures there.
ePO Support Center Plug-in
Check out the new ePO Support Center. Simply access the ePO Software Manager and follow the instructions in the Product Guide for the most commonly used utilities, top known issues announcements, search the knowledgebase for product documentation, and server status and statistics – all from within ePO.