cancel
Showing results for 
Search instead for 
Did you mean: 
romardy
Level 9
Report Inappropriate Content
Message 1 of 10

Client system product version didn't reflect properly on ePO

Jump to solution

Hi,

We have several clients that are not reporting properly to ePO.  We already upgraded the version of certain product. Upon checking physically on the machine, it has the latest product version but when looking at ePO it appears the old version still.

How to make this systems properly recognized by ePO? Is this a client issue not giving ePO the correct details?

Thanks!

1 Solution

Accepted Solutions
pboedges
Level 10
Report Inappropriate Content
Message 7 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

i have seen something similar to this as well, from what i have been able to determine is that when the agent installs over an existing version that in rare cases the registry key that maintains the version information does not change.

HKLM\SOFTWARE\NETWORK ASSOCIATES\EPOLICY ORCHESTRATOR\APPLICATION PLUGINS\EPOAGENT3000

STRING VALUE = VERSION

This is the key that i have found if i manually modify from old version to new version it will reflect this in the system infromation within ePO once an ASCI occurs.

9 Replies
ulyses31
Level 16
Report Inappropriate Content
Message 2 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

Hi Romardy, what products are you talking about,can you post a screenshot of what you see?

romardy
Level 9
Report Inappropriate Content
Message 3 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

Hi Lazzlo,

Product is McAfee agent that was recently upgraded to version 4.8 but still reflecting 4.6 on ePO.

Capture.JPG

Message was edited by: romardy on 7/17/13 2:46:51 AM CDT

Message was edited by: romardy on 7/17/13 2:47:17 AM CDT
ulyses31
Level 16
Report Inappropriate Content
Message 4 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

If you check for the last communication of this computer is it recent?

romardy
Level 9
Report Inappropriate Content
Message 5 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

Yes, Last Communication is up to date.

sawta
Level 8
Report Inappropriate Content
Message 6 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

I am having what sounds to be a very similar problem to Romardy.

I was recently given admin rights to an ePO server and the computers that I have been tasked with monitoring are reporting as being outdated for various products, (HIPS 8.0.0.2151 instead of 8.0.0.2239, DLP 9.1.2.1 instead of 9.2.1.13, same for DLP and PA).  This isn't affecting every machine, only a small amount out of several hundered, but my goal is to get 100% accuracy for a fast approaching inspection.

When I remote into these machines, the McAfee About information lists the Products as being at the proper verion number (2239 instead of 2151, for example).  I have tried to un-install & re-install these products using ePO's tagging system; it has worked on one or two of the machines, but I still have at least 15 more that this is not working on.  These machines also check in periodically or whenever doing the "Wake up agents" request.

Any ideas?

pboedges
Level 10
Report Inappropriate Content
Message 7 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

i have seen something similar to this as well, from what i have been able to determine is that when the agent installs over an existing version that in rare cases the registry key that maintains the version information does not change.

HKLM\SOFTWARE\NETWORK ASSOCIATES\EPOLICY ORCHESTRATOR\APPLICATION PLUGINS\EPOAGENT3000

STRING VALUE = VERSION

This is the key that i have found if i manually modify from old version to new version it will reflect this in the system infromation within ePO once an ASCI occurs.

sawta
Level 8
Report Inappropriate Content
Message 8 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

I'll give that a try.  Thanks for the response!

romardy
Level 9
Report Inappropriate Content
Message 9 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

Hi pboedges,

Tried your suggestion and it really works. I will try this also to other products.

Thanks for your help...

Message was edited by: romardy on 7/21/13 10:17:20 PM CDT

Message was edited by: romardy on 7/21/13 10:17:39 PM CDT
sawta
Level 8
Report Inappropriate Content
Message 10 of 10

Re: Client system product version didn't reflect properly on ePO

Jump to solution

I haven't had a chance to try this on all of the affected clients yet, but from the 3 or 4 that I've gotten to, this doesn't seem to be what the issue was.  I'm try to force uninstall/re-install the agents remotely for those machines and will check the registrey on the next batch of user machines this morning.