cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
lozaza
Level 8
Report Inappropriate Content
Message 1 of 13

Cannot wake up agent from EPO, agent listening only on IP v6

We have mcafee agent service TCP only listen on IPv6 address port 8081. Have tried different agent version 5.0.5, 5.5.0 5.5.1,restart the servicesdisable windows firewall and hips but doesnt help.

Found in the log as 

http.server listening to IPV6 only socket.

Telnet localhost 8081 works but 127.0.0.1 doesnt obviously. Hence, we cannot wake up agents from epo.

Wondering if something on the OS level that I need to change or the McAfee agent 

OS:windows 2012 r2

 

Labels (2)
12 Replies
McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 2 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

Hi,

Please  send wakeup call and share ePO server log.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
lozaza
Level 8
Report Inappropriate Content
Message 3 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

error code found in epo log as 10060 and -999. the task eventually timed out with 'unknow error'. IPV6 is disabled on the server. 

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 4 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

If IPV6 is disabled on epo server and the client is only using IPV6, you won't be able to send wakeup calls over that method. 

In epo server settings, agent contact method, what is that set to?  If IP address is first, move it to last and see if that helps.  Does nslookup for the client by netbios name resolve?

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

lozaza
Level 8
Report Inappropriate Content
Message 5 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

problem is not on the epo side, its the agent service binding to IP v6 socket only not ip v4. Regardless of agent contact method , wake up will never work. I am seeking if there is a way to force it to bind to IP v4 or its somewhere in the OS. 

netstat shows agent service pid on [::] not 0.0.0.0 while ipv6 is disbled.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 6 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

Is IPV4 enabled on the client?  Have you tried disabling ipv6 on the client?

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

lozaza
Level 8
Report Inappropriate Content
Message 7 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

correct IPv4 is enabled, mcafee agent can initiate the communication with epo just fine (from agent monitor) IP v6 is disabled.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 8 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

Is that the only system doing that or others?  That is very strange and sounds like an OS issue.  The agent binds to the network interface that the OS identifies.  Possibly something going on with that network stack on the server if that is the only one affected.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

lozaza
Level 8
Report Inappropriate Content
Message 9 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

there are couple of more boxes having the exact same problem which is quite odd Smiley Happy

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 10 of 13

Re: Cannot wake up agent from EPO, agent listening only on IP v6

Yes, it is.  I don't even know if Wireshark or tcpview would show what is going on.  Try running tcpview to see what is listening on your wakeup port.  It might be possible that there is something else listening on that port and preventing the agent from binding to it.  You might also want to put the agent in trace logging mode (kb82170).  When you put it in trace mode from command line, you have to check the agent logs for the word trace.  If it isn't there yet for new entries, restart the agent services.  That will then stay in trace mode till next restart of services. The macmnsvc log might show errors listening to that port. 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Member Rewards
McAfee Community rewards active and helpful members just like you. Click here to take a look at the first community members who received a special reward and were recognized by McAfee leader, Aneel Jaeel, for their participation and trusted knowledge in the community.