cancel
Showing results for 
Search instead for 
Did you mean: 
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 21 of 36

Re: Cannot access ePO 5.9, database error

Jump to solution

To log in with a Windows account, you have to be logged into the sql server or server that management studio is installed on with that account.  It uses the current logged on account for that.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Cannot access ePO 5.9, database error

Jump to solution

Then what would that account also need to be a part of to access the databases? Also, in the Computer Management, there is a ePO User Group. Who needs to be in that?

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 23 of 36

Re: Cannot access ePO 5.9, database error

Jump to solution

kb75766 lists sql permissions required in sql.  For a windows account, it also has to be in the windows local administrators group on the epo server.  See kb77757 regarding the epo user group. 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Cannot access ePO 5.9, database error

Jump to solution

At this point I think my course of action is this; I am going to uninstall ePO 5.9.0 and then install 5.10. I'm doing this because:

1. I cannot put in a domain user account into the localhost/core/config web page without the error that when I test the credentials, the name will not resolve to the domain. It is only the ePO application that cannot talk to the domain, the rest of the server can.

2. Since I cannot change the database account, I cannot get into the database.

If I proceed, will installing the 5.10 over write the current ePO_SQL database thereby removing the account issue?

Re: Cannot access ePO 5.9, database error

Jump to solution

Hope you guys are still there, because I have been able to get into the SQL Management Studio and create a couple of new logins, to solve my problem with getting into it. Now, when I go to the localhost/core/config page, and enter the new login and password, the test of credentials works. But the "Apply" stays grayed out, so I cannot apply the new settings. What do I need to do?

And thanks for all your help.

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 26 of 36

Re: Cannot access ePO 5.9, database error

Jump to solution

If the apply button is grayed out, there must be something not changed possibly.  You can try solution 3 in kb69850.

 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Cannot access ePO 5.9, database error

Jump to solution

I tried all 3 solutions, but no change. The Apply button is still grayed out.Is something else that needs to be changed?

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 28 of 36

Re: Cannot access ePO 5.9, database error

Jump to solution

Try restarting epo services, then try again.  The apply button won't activate unless there is an actual change to be made typically.  Did you try a different browser?  Add it to trusted sites?

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Cannot access ePO 5.9, database error

Jump to solution

I have restarted the service three times, put in the login and password, successfully tested the credentials, but no love. I have made the site a trusted one, still the same. Is there some permissions somewhere that need to be set?

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 30 of 36

Re: Cannot access ePO 5.9, database error

Jump to solution

You need to look at the orion log and the stderr.log after service restarts and the extensions load.  If you see any ssl/tls errors, what are they specifically?  What error does the sql server error log show?  5.9 and 5.10 require certain ciphers and protocols to be enabled.  see kb91296 and kb91304.  You can also use nmap on epo and sql servers to validate proper tls protocols and schannel ciphers are enabled.  See kb91115.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community