cancel
Showing results for 
Search instead for 
Did you mean: 

Can't import McAfee Agent 4 to Evaluation Branch

Hi,

I can't seemed to be able to do the above. My ePO Server is 4.0 Patch 2. Can anyone help me?

Thanks!
10 Replies

RE: Can't import McAfee Agent 4 to Evaluation Branch

Check your server settings:

Configuration > Server Settings > Repository Packages

However be aware: only agent 4.0 support all package types to be added to any branche. previous versions of the agent only support bracnhes to use for definition and enging updates.

This is actually why this server setting exists. You must set it to allow all package types in branches AFTER you have rolled out agent 4.0.

RE: Can't import McAfee Agent 4 to Evaluation Branch

Hi Medusoft,

Exactly what do you mean by "You must set it to allow all package types in branches AFTER you have rolled out agent 4.0." ?

I did the following sequence of events :
1. edited the setting in Configuration > Server Settings > Repository Packages
2. import McAfee Agent 4 to the evaluation branch
3. once done, i realised agent 3.6.0.574 which is in the 'current' branch, got overwritten by agent 4. as a result, both the 'current' & 'evaluation' branch now contained the same agent package.

anyone can offer any advice?

thanks!

RE: Can't import McAfee Agent 4 to Evaluation Branch

In my testing phase, the following occured. If i added anything to evaluation and previous of a type tha agent versions prior to 4.0 did NOT support (patches, service packs, hotfixes, full installations etc etc), the agent 3.x would not update from that repository anymore whatsoever.

For some reason the agent 3.x simply does not understand the repository anymore when an unsupported package is in evaluation or previous.

So the steps you should take are:


  1. Put Agent 4.0 in Current (remove it from evaluation or previous)
  2. Rollout the agent to all your systems
  3. Change the Repository Packages server setting to allow all packages to be checked in
  4. Done



If Agent 4.0 is in Current, it will still only be upgraded by systems that run a Software Deployment task which installs Agent 4.0, so if you want to do a phased rollout, just do not enable such a deployment task on all systems...

RE: Can't import McAfee Agent 4 to Evaluation Branch

Thanks for the information.

Now I've got a headache... I've a few Win2008 Servers around and needed to use McAfee Agent 4.0. I needed to generate the framepkg.exe so that these machines can manually install. For some reason, my boss doesn't want me to push down from ePO Server. If I were to import McAfee Agent 4.0 into the repository, 3.6 will be 'removed'.

No doubt I can control the release of McAfee Agent 4.0 to clients, but somehow I feel unsafe. Is there any other way I can setup McAfee Agent 4.0 on those Win2008 machines without having to use framepkg.exe? Can the existing McAfee Agent 4.0 files be used instead?

Thanks.

RE: Can't import McAfee Agent 4 to Evaluation Branch

No there isn´t.

Either use framepkg.exe manually or deploy it from ePO.

Framepkg.exe is available as a standalone version as well, which you could use to manually upgrade the agent on such platforms. It´s called FramePkg_upd.exe and is available among the downloads for McAfee Agent 4.0. It will upgrade agent 3.x to 4.0 maintaining settings etc.

RE: Can't import McAfee Agent 4 to Evaluation Branch

Oh yes, guess I missed FramePkg_upd.exe out.

With it, does it mean I can install ePO Agent 3.6 on Win2008 machines before using FramePkg_upd.exe to upgrade the Agent to 4.0?
tonyb99
Level 13
Report Inappropriate Content
Message 8 of 11

RE: Can't import McAfee Agent 4 to Evaluation Branch

yes it does

RE: Can't import McAfee Agent 4 to Evaluation Branch

Alrighty! Thanks everyone!!

RE: Can't import McAfee Agent 4 to Evaluation Branch

Maybe you could even do a clean install with it using the commandline switch SiteInfo, i never used it myself this way however.

Try:
FramePkg_upd.exe /?