cancel
Showing results for 
Search instead for 
Did you mean: 
Maytee
Level 7
Report Inappropriate Content
Message 1 of 14

Can't change language on ePo 4.5's first page

mcafee error.jpg

How this problem come from?

In Mcafee ePolicy Orchestrator 4.5 console user cannot log-in to console or use language setting.

i try to restart EPO service, it’s work. But just a period of time then this come back again.

the error shows as following

DataChannel - Dependency scheduler had initialization error 

LYNXSHLD1510 - Dependency EPOCore had initialization error 

AvertAlerts - Dependency scheduler had initialization error 

LYNXSHLDPARSER - Dependency core had initialization error 

GSD7REPORTS - Dependency core had initialization error 

VSEMAS850000 - Dependency VIRUSCAN8600 had initialization error 

issue - Dependency rs had initialization error 

VIRUSCANREPORTS - Dependency CommonEvents had initialization error 

rsd - Dependency Notifications had initialization error 

GSE7REPORTS - Dependency GROUPSHD7000 had initialization error 

Notifications - Dependency response had initialization error 

VSCANMAC8610 - Dependency ComputerMgmt had initialization error 

VIREXREPORTS - Dependency core had initialization error 

remote - Dependency core had initialization error 

SITEADV_1500 - Dependency EPOCore had initialization error 

epolicensing - Dependency console had initialization error 

epoMigration - Dependency AgentMgmt had initialization error 

Countermeasures - Dependency ComputerMgmt had initialization error 

EPOCore - Dependency ldap had initialization error 

SITEADVMETA - Dependency ComputerMgmt had initialization error 

response - Dependency scheduler had initialization error 

help - Dependency core had initialization error 

SMDWIN__7000 - Dependency ComputerMgmt had initialization error 

aramid - Dependency CommonEvents had initialization error 

AgentMgmt - Dependency RepositoryMgmt had initialization error 

GROUPSHD7000 - Dependency ComputerMgmt had initialization error 

InstallHelper - Dependency core had initialization error 

EPOAGENTMETA - Dependency ComputerMgmt had initialization error 

scheduler - Dependency console had initialization error 

ComputerMgmt - Dependency ldap had initialization error 

PolicyMgmt - Dependency ComputerMgmt had initialization error 

VIRUSCAN8700 - Dependency EPOCore had initialization error 

VSEMAS870000 - Dependency VIRUSCAN8700 had initialization error 

console - Dependency core had initialization error 

ldap - Dependency rs had initialization error 

VIRUSCAN8600 - Dependency EPOCore had initialization error 

rs - Dependency console had initialization error 

RepositoryMgmt - Dependency ComputerMgmt had initialization error 

core - Error creating bean with name 'core.db' defined in URL [jndi:/localhost/core/WEB-INF/beans.xml]: Instantiation of bean failed; nested exception is org.springframework.beans.BeanInstantiationException: Could not instantiate bean class [com.mcafee.orion.core.db.base.Database]: Constructor threw exception; nested exception is java.sql.SQLException: Login failed for user ''. The user is not associated with a trusted SQL Server connection. 

CommonEvents - Dependency ComputerMgmt had initialization error 

13 Replies
jmcleish
Level 13
Report Inappropriate Content
Message 2 of 14

Re: Can't change language on ePo 4.5's first page

Have a look at this post first to see if it helps:

http://community.mcafee.com/message/138185

Maytee
Level 7
Report Inappropriate Content
Message 3 of 14

Re: Can't change language on ePo 4.5's first page

so
thanks for ur quick reply, jmcleish

^^

i'm going to check it out

i'll add more information

as you can see the language combo box is looklike a blank box instead  of language name

to solve this as temporary is restart epo server service.

the ePo will come back and work well again.

but just a while this problem comeback again like looping T^T

Message was edited by: Maytee on 7/7/10 6:07:35 PM GMT+07:00
Maytee
Level 7
Report Inappropriate Content
Message 4 of 14

Re: Can't change language on ePo 4.5's first page

Some one plz help me

jmcleish
Level 13
Report Inappropriate Content
Message 5 of 14

Re: Can't change language on ePo 4.5's first page

Did you have  a look at that post?

What account do you use for epo to communicate with the DB?

What version of ePO /inc patch version.

Is this  a new install or one that has been working?

Highlighted
Maytee
Level 7
Report Inappropriate Content
Message 6 of 14

Re: Can't change language on ePo 4.5's first page

Re: Can't change language  on ePo 4.5's first page

Did you have  a look at that post?

What  account do you use for epo to communicate with the DB?

What  version of ePO /inc patch version.

Is this  a new install or one that has been  working

i dont' understand the first question for what account do i you for communicate with database

ePO version is 4.5  / build 851

this is the all new install server ( including OS, AV-server)

jmcleish
Level 13
Report Inappropriate Content
Message 7 of 14

Re: Can't change language on ePo 4.5's first page

If you goto

https://eposerver:portno/core/config

what account name is in the username field? is it someone's personal account or a service account used when it was setup.

If its someones personal account you need to change it to use a service account- either sql or domain that the password won't change on.

To create an sql account - log onto SQL and create an account with db owner  properties for the ePO db. Then re-configure the ePO DB config (https://eposerver:port/core/config)  to use this account. (You may need to restart the services etc)

Maytee
Level 7
Report Inappropriate Content
Message 8 of 14

Re: Can't change language on ePo 4.5's first page

if u mean the box under ssl communication with database server: combo box.  the username is administrator, sir

jmcleish
Level 13
Report Inappropriate Content
Message 9 of 14

Re: Can't change language on ePo 4.5's first page

That "administrator" account has to have rights to your sql db which i'm suspectimg most likely doesn't. The problem is that ePO can't contact the DB.

As mentioned in the post before.

Log into your SQL DB via SQL server managemnet studio and create a user with db_owner rights to the epo DB.

then, change the name and password in the ePO config page to use that account.

make sure you test the connection before you hit apply!

Regards

Jane

Message was edited by: jmcleish on 09/07/10 04:14:36 CDT
Maytee
Level 7
Report Inappropriate Content
Message 10 of 14

Re: Can't change language on ePo 4.5's first page

i'm not sure, am i misunderstanding something.

if the db server and McAfee server can't make connection, so it should be unable to open any time, right?

however, it can open and manage client until this problem show up, and after i restart epo server's service. i can login to manage client or policy again.

But, problem will occur again soon.

is this cause of the use of "administrator" user name

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community