cancel
Showing results for 
Search instead for 
Did you mean: 

AutoUpdate Repository without epo

Hello, I'm new to this site but this looks like a good place to post this question.

We have a small isolated (no internet connection) network which uses mcafee enterprise 8.5. I'm trying to maintain the virus definitions by editing the autoupdate repository and manually placing the virus definition files that our Corporate network uses into the new repository. Keeping in mind that I don't use epo, is there a list of files that I need to modify and what is the best way to go about this. I've been able to do this successfully one time but as soon as I attempt it a second time I run into problems. Is anyone out there doing anything similar and how do you handle it?

I've been trying to get this to work for a very long time so any insight is very much appreciated!!!

Thanks,

Tim
4 Replies

RE: AutoUpdate Repository without epo

the way i handled a similar situation was to specify one machine that would have an internet connection to a mcafee 'mirror' task, which downloads all the dats (and a bunch of other junk which you wont want, but i think is unavoidable)

then share out that UNC path, and set the other machines to update from the UNC path rather than the web.

from your post it isnt clear if there is any connectivity between these networks at all, or just not to the outside. this wouldnt work if you were planning on dropping dats off daily, say via usb or what not. though perhaps you could modify this approach to fit your needs.

Clarification

Thanks for the reply. My network is segmented off from our corporate network via a dmz. Traffic from my network is not allowed on to the corporate network and vice versa. Currently I have set up a share on one of my servers and edited all of the autoupdate repositorys to look at this share for updates. My current approach is to go out and grab the files that are downloaded daily and place them on USB and manually place them in my repository. As part of this I had to modify the sitelist.xml file. After doing this the first couple of times it stopped working. Now it is complaining about not being able to find sitestate.xml saying it cannot find a valid directory.

I'd like to continue with my approach but I'd like to understand why it doesn't like what I'm doing.

Thanks,

Tim

RE: Clarification

did you manually edit the xml file, or did you go to tools -> edit autoupdate repository list -> add -> UNC path?

i have no idea why it would stop working if it was running OK a few times through, nor do i know the ins and outs of the different xml files - hopefully someone with more knowledge can chime in on these bits.

but if you did edit it manually, i would try adding a repository via the menu and since you know what files to download/load on usb/drop into that share, give that another go.

sorry i cant be of more help.

RE: Clarification

I modified the autoupdate repository through the gui but there are some additional items that need to be modified through the xml file such as server and username and password information.

Thanks for the help.


Tim
More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community