cancel
Showing results for 
Search instead for 
Did you mean: 

Agents communication

Hi Guys, 

As I understand, during an agent deployment task outgoing communication from the ePO server on port 445 is required so that the installation files are placed on the target machine, but why do the agents need to communicate back on ports 445 or 137? 

Thanks, 

10 Replies
McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 2 of 11

Re: Agents communication

Please refer to KB66797 - port 445 (default port 443) is inbound to epo server, not outbound.  That kb lists all our ports, the direction needed and protocol it uses.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Agents communication

Thanks for your reply, am aware of the article, am not inquiring about port 443. Port 445 is also used outbound from the ePO

McAfee Employee hem
McAfee Employee
Report Inappropriate Content
Message 4 of 11

Re: Agents communication

McAfee agent doesn't need SMB ports for communication. It used only for ePO deployment because ePO will copy Agent file (framepkg.exe) to client machine's  Admnin$ share.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?please select Accept as Solution in my reply and together we can help other members?

Re: Agents communication

Thanks for your reply, but is there a reason the agents are communicating back on ports 445 and 137 ??

Reliable Contributor vnaidu
Reliable Contributor
Report Inappropriate Content
Message 6 of 11

Re: Agents communication

@Waseem_a 

Dear Waseem,

The port 445 and 137 are SMB ports which are used by Windows systems for file sharing. So in your case, the ports are being used for accessing the share drive to place Framepackage.

On the other hand, these ports are not used for Agent communication to ePO vise versa.

I hope this clarifies your question.

Venu

Re: Agents communication

Thanks for the clarification. 

The problem am facing is that am trying to deploy agents from the ePO, the server task logs completes with no issues. On the machine side, there is already an installed agent and ENS deployed but the machine is not communicating back to the ePO so it stays in an unmanaged state. (This were i started looking at the firewall logs). I see communication on port 443 which is allowed. (Other communication is on the ports I mention earlier, which are blocked, so i dont need to open these ports).

What can be the issue with these unmanaged machines ?

 

Highlighted
Reliable Contributor vnaidu
Reliable Contributor
Report Inappropriate Content
Message 8 of 11

Re: Agents communication

@Waseem_a 

If you have enabled the ADSync, then I would like you to check the KB article  and see if duplicate entries are being created in the system tree by following KB89427. But I suspect if this could not the issue with your case.

Ideally if a machine has MA installed, then it should try to establish a communication eventually an entry will be created in the ePO server.

If machine is reverting back to 'unmanaged' then somehow MA installed on the machine getting removed. I suggest to check the client/server task if present.

I also suggest you not to block the SMB ports.

 

Venu

Re: Agents communication

Thanks for your reply, am running ePO 5.10 version 3 but ill open the ports and see the outcome

 

McAfee Employee cdinet
McAfee Employee
Report Inappropriate Content
Message 10 of 11

Re: Agents communication

You would need to look at the agent masvc log (c:\programdata\mcafee\agent\logs) for any communication failures and also look at the server log on the epo server or agent handler that the agent is trying to connect to for the same time of the communication attempt.  It can fail from either side for many reasons.  Once you find the errors, you can look them up in our KB or post them here - just don't include any sensitive information.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community