cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
RickIA
Level 9
Report Inappropriate Content
Message 11 of 15

Re: Agent will not respond to server

It IS a hassle to have to push out agents like that again. what two server tasks were you referring to? I also noticed that I still do not see the machines showing up in EPO (4.5 Patch 1) so I had to go to the domain list and push to them that way. Odd as well that I am running MA 4.5 patch 1 on all the machines that talk to my EPO box, and recently setup a push of Patch 2 agent. I happened to be working on some new laptops and started to see the agent failed to connect to server error and found in the server.log all the server denials because of the duplicate GUIDs. So after I added the code to the server.ini they coudl talk, however I still don't see them all showing up in my console. I don't understand what is up with this since agent 4.5 is supposed to be doing GUID regeneration after imaging, correct?

apoling
Level 14
Report Inappropriate Content
Message 12 of 15

Re: Agent will not respond to server

Hi,

I don't understand what is up with this since agent 4.5 is supposed to be doing GUID regeneration after imaging, correct?

This is not automatic like one would imagine and does not happen after imaging, but upon special request sent by ePO server to compatible agents. (As for imaging is concerned you'd have to prepare the mage without the AgentGUID reg key so upon image installation, when agent services first starts on target client it generates the guid for the first time.)

Basically you'll have to have this server task present and enabled: "Duplicate Agent GUID - remove systems with potentially duplicated GUIDs". This task runs a query "Systems with High Sequence Errors" and performs the following action on the resulting set: "Move Agent GUDI to Duplicate list".

This duplicate list is a separate sql table populated by the above server task when it runs. Upon any agents with wrong sequence number is trying to connect thereafter , ePO server checks the agent version (to find out if its compatible with regen request) and this duplicate list and if it finds the guid there, send the regeneration code back to the agent. Agent regenerates its guid and next time should be accepted.

The query "Systems with High Sequence Errors" can be modified by you and you can determine in the Filter section, how many sequence errors you allow after which the guid should be put in the blacklist. By default it is 25.

Another server task is this: Duplicate Agent GUID - clear error count. This only clear sequence error count for agents communicating ok but may have problems in the past.

Attila

Message was edited by: apoling on 29/04/11 07:37:03 CEST
RickIA
Level 9
Report Inappropriate Content
Message 13 of 15

Re: Agent will not respond to server

Would that job be using the ePO Agent Key Updater using the product update choice? It seemed the most logical thing from what I could find.

apoling
Level 14
Report Inappropriate Content
Message 14 of 15

Re: Agent will not respond to server

No that's completely different thing, unrelated.

The task runs a query which lists which nodes in the database have a higher sequence number errors than the limit defined in the query. the task then puts the GUIDs of the resulting set of nodes in a SQL table. Task ends.

Attila

lfah2000
Level 10
Report Inappropriate Content
Message 15 of 15

Re: Agent will not respond to server

Same problem here. In my test environment for epo and windows deployment the new installed system is not communication with the epo server. Exept for the message in the logfile it seems to be communicating with epo. I'm not happy with that. The existing system in epo is not updated, a new system will not appear.

The error message contains this but is not applicable on my system

https://kc.mcafee.com/corporate/index?page=content&id=KB66245

using epo version epo 4.6 and mcafee agent 4.6 beta.

Reinstalling the agent with version 4.5 (4.5.0.1810) seems to solve the problem.

Updating the agent to 4.6 (a newer version 4.6.0.144) to see if the porblem has been solved.

The old was version 4.6.0.1120

More McAfee Tools to Help You

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community