cancel
Showing results for 
Search instead for 
Did you mean: 
stickman
Level 12
Report Inappropriate Content
Message 1 of 18

Agent removal task

Hi guys,

Been having issues with Agent 5.0.1. This is currently checked into evaluation branch in my environment. I disabled the client task to deploy agent 5.0.1. Would like to go back to agent 4.8. How do I go about? I have tried the following:

- Deleted system with Agent 5.0.1. and deployed 4.8. again, it stay on same version

- Forced removed (frminst.exe /forceuninstall) Agent 5.0.1. and deployed 4.8, it stays on the same version.

How would I revert all the systems that currently got the evaluation version installed back to current which is 4.8?

17 Replies
exbrit
Level 21
Report Inappropriate Content
Message 2 of 18

Re: Agent removal task

Moved to ePO for faster support.

---

Peter

Moderator

hem
Level 15
Report Inappropriate Content
Message 3 of 18

Re: Agent removal task

When you deleted the system running MA 5.0.1, would like to check if you select the option 'remove agent at next ASCI'. When next time, client machine communicates, did MA removal got initiated? If failed then what is the error message it failed with?

You tried force uninstall (frmInst.exe /forceuninstall). Does it fail? If failed then what is the error message it fails with?

stickman
Level 12
Report Inappropriate Content
Message 4 of 18

Re: Agent removal task

Yes I have selected the option to remove agent on next server communication. That goes through successfully, can see the agent stops and icon goes away in task bar. After that is done then I deploy the 4.8. agent from EPO, few minutes then I can see the agent is back in the taskbar but then it is still 5.0.1. and not 4.8. Also tried restarting after removing agent and still the same.

If I force it, it removes successfully but the thing is I have to roll back to current branch (4.8) from evaluation (5.0.1.) and forcing 4000 systems is not the way I want to go, only if I can force it from EPO, but I have tried using frminst.exe /forceuninstall in command box when deploying/removing softare and that is not working. What is the use of using evaluation if you can't roll back successfully?

mmcgary
Level 12
Report Inappropriate Content
Message 5 of 18

Re: Agent removal task

Removing the Agent from EPO will only uninstall the Agent if no other products are using it. What happens is the Agent is put into unmanaged mode similar to being installed along with the Virusscan package on a stand-alone machine. This was done by design so that client systems will still be able to update even though you may no longer want them to appear in your EPO system tree.

The 3 branches available in EPO's master repository are only named to help customers keep install packages organized. There is no technical meaning to the Current, Previous and Evaluation branches that carry any special behavior other than update packages (DAT, hotfixes, etc.) being pulled from Current by default.

Add the following to a Product Deployment task command line options for the 4.8 Agent which should successfully downgrade your 5.x version to 4.8:

/INSTALL=AGENT /FORCEINSTALL

stickman
Level 12
Report Inappropriate Content
Message 6 of 18

Re: Agent removal task

Thank you for explaining the branches mccgary.

Added the /INSTALL=AGENT /FORCEINSTALL to 4.8. product deployment task but it is still not going through. I can see from the status monitor the task received, installed, finished and freed but the version remains on 5.0.1.

Selection_019.png

Re: Agent removal task

Unfortunately I'm in the same boat, unable to downgrade, have tried above solution, also tried the deploy agent with 'Force installation over existing version' but not working either. The ability to rollback the agent is very important, as how else are you supposed to downgrade 100's if not 1000's of clients without individually uninstalling them ?(not an option). Trying to go from agent 5 back to 4.8 patch 3.

Anyone managed to do this successfully yet?

stickman
Level 12
Report Inappropriate Content
Message 8 of 18

Re: Agent removal task

Glad to hear I am not the only one. I found if I remove HIPS from the system completely then encryption goes through, disabling the policy does not work. Force install 4.8. does not work. Hope McAfee find solution for this quickly, I have lots of machines affected by this.

Re: Agent removal task

Hey minion, what issues were you having with agent 5.0.1? I'm thinking of updating to it rather than downgrading, but am very hesitant as you might guess!

stickman
Level 12
Report Inappropriate Content
Message 10 of 18

Re: Agent removal task

There seems to be issues with HIPS 8.0 patch 4 and Drive Encryption 7.1.1.454. Even if policy disabled it does not want to encrypt. Only encrypts if HIPS completely removed.