cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Agent failed to connect with epo

Hi All, i have problems with epo 4.6. In this day all agent can not connect to epo (Agent failed to connect with epo in Monitor) but new agent that fresh install that can connect to epo. I don't know why, please help me. Please check logs. Thanks!

8 Replies

Re: Agent failed to connect with epo

I see that maybe that cause problems?

COM Error: 0x80040E14

File: .\ePOData_Connection.cpp(650)

Function: CConxIndex::Execute

Meaning: IDispatch error #3092

Source: Microsoft OLE DB Provider for SQL Server

Description: Type DLP_CombinationDisplayName_type is not a defined system type.

DAL2_CProductProperty::AppendCustomSettingsSQL: Error 0x80040E14 inserting custom product settings.

COM Error: 0x80040E14

File: .\ePOData_ProductProperty.cpp(772)

Function: DAL2_CProductProperty::SaveAllSectionsOnConnection

Meaning: IDispatch error #3092

Re: Agent failed to connect with epo

I have one question:

If epo and client connect together just by ip address (not name). Can Agent and server will connect? Collect and Send Pros from agent and wake up from epo good? need resolve dns? Thanks!

apoling
Level 14
Report Inappropriate Content
Message 4 of 9

Re: Agent failed to connect with epo

Connection from agent to ePO server occurs first by IP then DNS and if that fails, by NetBIOS name so either of them should work. It appears from the server.log that this same logic applies when ePO tries to connect to agent (in a wake-up effort, for example).

The other type of traffic can occur once the connection is established.

Attila

Re: Agent failed to connect with epo

Thanks Attila, my problems is client side. In client logs show :

Trying with site: [::1]:81

Connecting to site: [::1] on port: 443

Agent communication failed, result=-2400

Agent     Exponential retry in 1266 seconds, error=-2400(Unable to connect to ePO Server)

KnowledgeBase KB73383 say about ipv6. I disable IP v6 but must re-deploy agent but my customer don't want do that because > 400PCs.

In enviroment workgroup they deploy agent manually before so re-deploy not feasibility. Have any solution for this without re-deploy agent.

My customer just connect epo through ipadress, not DNS or Netbios . Now client can not connect to epo by ip address (errors above). If i re-deploy agent or change dns to local dns that work fine. But > 400PCs workgroup can not do that

apoling
Level 14
Report Inappropriate Content
Message 6 of 9

Re: Agent failed to connect with epo

Hello,

there is a procedure to change merely the sitelist.xml on a client. I see chance for you to execute the tasks in Solution 2 of that KB article you mentioned without redeploying the agent.

Please review articles KB66892 and KB51529. First please try the method in the first article that replaces the sitelist.xml on the agent containing the new IP address and see if it alone works.

Attila

Re: Agent failed to connect with epo

Does the agent log shows the correct ePO server hostname?

Based on the recent log, i assume the agent-server communication port is changed to 81.

Telnet to the ePO server on port 81.

If telnet fails, reach your network team to check the connectivity.

If telnet succeed, check the sitelist.xml in the agent machine. Check if the server name/IP and the port is correct.

Update with ur findings.

Regards,

Kiran

Re: Agent failed to connect with epo

Hi Attila, in first KB still need re-deploy agent (4. Re-deploy the agent to the client computers.). Both KB that you mentioned still need direct manipulation on the client ( 400PCs on my customer). If i can do that on each clients so i just reinstall agent that resolve problems.

Hi Kiran, because my enviroment use workgroup with dns isp, google... not local dns so can not resolve hostname (client will connect back epo if i change dns to dns local). Now client just connect to epo with ipadress but on client logs that show " Trying with site: [::1]:81, Connecting to site: [::1] on port: 443" so i think client don't know ipaddress of epo to connect to

Thanks All!

apoling
Level 14
Report Inappropriate Content
Message 9 of 9

Re: Agent failed to connect with epo

Hello,

I think the SQL errors are in server.ini because the - I assume you have it -  DLP product extension needs rechecking in ePO: it appears that ePO cannot insert data to database field because certain fields does not exist. Please try re-checking the DLP product extension.

Other than that I only have seen duplicate sequence number errors a few times, failures to find clients IP by DNS names and a mixture of other issues not in great proportion. We'll take care of them later 🙂

Attila

More McAfee Tools to Help You
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • Visit: Business Service Portal
  • More: Search Knowledge Articles
  • ePolicy Orchestrator Support

    • Download the new ePolicy Orchestrator (ePO) Support Center Extension which simplifies ePO management and provides support resources directly in the console. Learn more about ePO Support Center