Showing results for 
Search instead for 
Did you mean: 

Active Directory User Login - Permission Sets

I'm trying to setup ePO 4.5 P3 so that we can provision users and permission sets by AD group membership.  I have the following pieces in place:

A functioning AD LDAP registered server

A group in AD with members

A permissions set in ePO associated to the AD group.

Server setting "Active Directory User Login" set to true (according to KB67576 this should automatically create ePO user records for Active Directory users upon login)

I've asked a member of the AD group associated to the permissions set to try logging in to ePO.  They receive this message "You do not have permissions to access ePolicy Orchestrator".  Referring to KB67576 again this apparently means the person has successfully authenticated to the ePO console but had no permissions set assigned.  However, when I look, no user record was created for this user which should have happened based on the "Active Directory User Login" setting.  So I feel like I'm stuck in a chicken/egg situation.  How to I assign a permissions set (other than AD group association which is already done) to a user record that doesn't exist?  If it won't let them login without a permissions set, how do you get the account created?  Manually creating an account would be rediculous and would make the "Active Directory User Login" completely useless.

Does anyone know what I'm missing here?  My next step is to open an SR.  But since the support portal is down I thought I'd ask the community first.

7 Replies

Re: Active Directory User Login - Permission Sets

Did you figure this one out? I can't get this to work either on p3.


Re: Active Directory User Login - Permission Sets

Not yet.  Trying to finish up a couple other SR's before starting this one.

Re: Active Directory User Login - Permission Sets

At least it works as expected in the 4.6 Beta.  Still working through an exisiting SR before attempting to tackle this one.

Level 10
Report Inappropriate Content
Message 5 of 8

Re: Active Directory User Login - Permission Sets

ePO creates the user account automatically when you allow login via AD, as you said that wouldn't make sense to have to do this manually.

We had a similar problem and in our case it turned out that the account we used to query the AD with did not have sufficient rights to all required AD objects. To narrow down the problem we temporarily borrowed a domain admin account and then it started working as expected. Also, some AD groups don't seem to play nicely with ePO, for instance I had no luck with a permission set that mapped to Domain Users whereas a smaller group with just a handful of members worked fine.

Another issue seems to be if you have multiple LDAP servers/domains configured then ePO 4.5 sometimes sends the login to a DC in the wrong domain. Try removing any LDAP servers not being used.


Re: Active Directory User Login - Permission Sets

Unfortunately doesn't seem to be the case here.  I tried Domain Admin and it still didn't work.  I currently have both 4.5 P3 and 4.6 beta pointing to the same ldap source and authenticating with the same account.  4.6 beta works, and 4.5 P3 does not.  Our environment is a single domain.

Message was edited by: woodsjw on 9/1/10 12:26:38 PM GMT-08:00
Level 10
Report Inappropriate Content
Message 7 of 8

Re: Active Directory User Login - Permission Sets

MS Netmon 3 has quite good filters for Kerberos and LDAP so if you set ePO to not authenticate over SSL (this will capture everything, including the LDAP lookup account password so be careful) and try again it might be possible to see what is going wrong. This is how we did the troubleshooting for the insufficient rights problem of the LDAP account.


Re: Active Directory User Login - Permission Sets


Wondering if you already had an answer on an SR about this.

Having the same issue. Domain admin does not work either.

on 9/7/10 9:53:40 AM GMT+01:00
More McAfee Tools to Help You
  • Subscription Service Notification (SNS)
  • How-to: Endpoint Removal Tool
  • Support: Endpoint Security
  • eSupport: Policy Orchestrator
  • Community Help Hub

      New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

    • Find Forum FAQs
    • Learn How to Earn Badges
    • Ask for Help
    Go to Community Help

    Join the Community

      Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

    • Get helpful solutions from McAfee experts.
    • Stay connected to product conversations that matter to you.
    • Participate in product groups led by McAfee employees.
    Join the Community
    Join the Community