Showing results for 
Show  only  | Search instead for 
Did you mean: 

"Unable to find valid repository" - Until I manually replicate???


My master repository (ePO server) updates once a day at at 3:30 PM.
The distributed repositories are then replicated once a day at 6:00 PM.
My clients update the next day between 10:00 AM and 12:00 PM.

It's done this way because it takes 4 hours to do an incremental update to all the repositories.

OK, now my problem. I've noticed that every day at 10:00 AM our internet usage spikes to 100% for about an hour. I moved the McAfee update task to 9:00 AM and the spike follows it. So for some reason the clients are not using the distributed repository or master repository and are jumping out to the internet.

The agents are told to use the order in the repository list and then have the local distributed repository, master repository and finally Http.

As I was testing now I tried to force a manual update on my agent to the local distributed repository and it told me "Unable to find a valid repository". That's odd I though. I then tried to update off the ePO server (master repository) and it worked. So I went back and tried to update from the distributed repository and it told me it was invalid. I checked the software package versions on the master and distributed repository and they were both the same.

I forced a replication between the two repositories, which only took 12 seconds, then tried to update from the local repository and it worked. :confused:

Why are my distributed repositories becoming invalid??? Is it because of the window between the replication of repositories and the agent updates???
10 Replies
Level 7
Report Inappropriate Content
Message 2 of 11

RE: "Unable to find valid repository" - Until I manually replicate???

If the overnight replication between the Master and Distributed repositories has completed successfully this shouldn't happen....are your task logs looking o.k. ?

Level 7
Report Inappropriate Content
Message 3 of 11

RE: "Unable to find valid repository" - Until I manually replicate???

What type of repositories are you using? For either the super agent or the UNC variety look at the sitestat.xml file in the folder tree. It should say ENABLED.

Also look at on of the clients, the mcScript log file is very forth-comming about where the updates are comming from. If your repositories are not in their - then either:
1) They are "disabled" - see above
2) They have never had a complete replication
3) The are DISABLED in the relevant McAfee agent policy

It sounds like you have "fallback" enabled on the McAfee Agent repository policies, hence if your local repositories are disabled (as above) - then its going to the mcafee internet site.


RE: "Unable to find valid repository" - Until I manually replicate???

Thanks for the replies.

I am using UNC repositories. My server task logs look good. The replications work all the time, with the occasional exception which is to be expected. I check the logs and it says replication complete with no warnings.

I checked the sitestat.xml file on a few repositories yesterday during the problem and they said Enabled.

On one of my dashboards I have "Master Repository Status". It shows my repository's DAT version and the latest available from McAfee. It seems like once it knows there's a newer one available that what I have all my distributed repositories start to act up. Am I imagining things?
Level 7
Report Inappropriate Content
Message 5 of 11

RE: "Unable to find valid repository" - Until I manually replicate???

Sounds like your repositories are not enabled on the McAfee Agent policies, or that the EPO server is a fall back repository.

What does the mcScript.log say for an affected client?


RE: "Unable to find valid repository" - Until I manually replicate???

My clients are configured to check the local repository first, then the ePO server, then McAfee HTTP.

Here's what the agent log says:
2009-04-06 13:45:07 i #1796 Updater Unable to find a valid repository.

So I checked the McScript log and found this:
2009-04-06 13:45:07 I #136 creposi [repository name] is not upto-date site. catalog version 20090405203753 < 20090406142337
2009-04-06 13:45:07 I #136 MueEep Script progress details : Event Type = " 3" Progress = " 1" Progress MAX = " 0" Message = "
2009-04-06 13:45:07 I #136 ScrptMain McAfee Update Engine is exiting with return code: 1
2009-04-06 13:45:07 I #136 SessMgr Unable to find any valid repository

So I am at least partially correct that it does think it's out of date. How do I prevent that?

I created a task to update the local repository this morning at 9:00 AM (It did its replication last night at 6:00 PM too). It only took 10 seconds to run this morning so I can't imagine it sent anything. I was hoping this would help but it didn't.

RE: "Unable to find valid repository" - Until I manually replicate???

Our network connection is being hammered, the update it is not working properly. :mad:

I just hit the auto update task on my client and it's pulling from the local repository. So....yeah, I'm stumped.

Is there any way to get a report on the EPO server as to where clients are downloading their updates?
Level 7
Report Inappropriate Content
Message 8 of 11

RE: "Unable to find valid repository" - Until I manually replicate???

I'd suggest that you stop allowing them to choose from a list and try forcing each site to a specific repository - then you can report on which clients have updated successfully which should mean that the ones which haven't would have tried to go elsewhere......


RE: "Unable to find valid repository" - Until I manually replicate???

I have all my sites pointing to their local repository now. We'll see how tomorrow goes. Thanks for the replies.

RE: "Unable to find valid repository" - Until I manually replicate???

My clients are updating and my internet connection is NOT being hammered. This is good.

Now, I need to figure out how to enable McAfeeHttp as repository but keep them from using it if my distributed repository is available.

Here's background info on how my agent repository policy is setup:
- Use this repository list
- Use order in repository list

Then I have all repositories disabled except the local one, the Epo server and McAfeehttp. Due to testing right now the only one enabled is the local one.

I had to setup a separate policy for every group because the "Select repository by" "ping time" and "Subnet distance" never worked. At our sites we have multiple VLANs (192.168.x.x and 10.x.x.x) and McAfee can't figure out, even by ping time what repository to use. It picks other repositories seemingly at random and destroys our frame connections.

So there should be no ambiguity for the agents as to what repository to use since every group is hard coded like this.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community