cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7
Report Inappropriate Content
Message 1 of 5

package check ins are hanging during pulls

I've got a weird problem with checking packages into the main repository, which I haven't been able to find any info on apart from this thread; http://community.mcafee.com/thread/22109?start=0&tstart=0. This occurs with manual or scheduled pulls using either http or ftp (v1 & v2) and has occurred on both DAT and VSE 8.7 Langpack packages. Basically, the problem is that there is no problem, since it sits there checking the package in forever without failing (the longest i've left it is over the weekend for 59+ hours), it just never completes the check in.

Also, although manual check ins do work, ever since this incident they  have required either the ePO application server or the entire VM to be  restarted after each package in order to free it up for the next. If i  don't, then it tells me that it's still waiting for the task to finish,  even though the package appears to have successfully been added to the  repository.

My problem seems to be summed up in this error in the EpoApSvr.log:  CheckInThreadProc: Site ePO_HA-ePO-01 is currently in use, abort...

Does  anyone know what might keep the site in use even after the site has  just been restarted?

This is ePO 4.5 patch 1 on a VM running Win2k8 x64 and SQL Server Express 2k8

Message was edited by: smiabe on 15/04/10 21:57:40 CDT
4 Replies
Highlighted
Level 7
Report Inappropriate Content
Message 2 of 5

Re: package check ins are hanging during pulls

This situation has resolved itself after manually checking in todays Emergency DAT 5959. Not sure what made the difference this time though.

Highlighted
Level 7
Report Inappropriate Content
Message 3 of 5

Re: package check ins are hanging during pulls

I'm also faced with hunging problem of pulls and manual checking doesn't resolve this problem. Task successfully completing but after long period of execution.

1/29/11 8:07:55 AM
67 hours 51 minutes
Update Master Repository
Server Task
admin
Completed

Please, help. Time intervals are very large for this checks

1/29/11 8:07:55 AMStarted: Pulling content from McAfeeHttp to Current branch
1/29/11 8:07:57 AMRepository Pull from site McAfeeHttp complete, no warnings
1/29/11 8:08:09 AM   Checking in package Current\VIRUSCAN8700\8.7.0\LangPack\0000
1/30/11 1:05:57 AM   Checking in package Current\VIRUSCAN8700\8.7.0\LangPack\0000 complete
1/30/11 1:06:09 AM   Checking in package Current\VSCANENG1000\5400.1158\Engine\0000
1/30/11 6:04:31 PM   Checking in package Current\VSCANENG1000\5400.1158\Engine\0000 complete
1/30/11 6:04:34 PM   Checking in package Current\BOCVSE__1000\516\DAT\0000
1/31/11 11:02:50 AM   Checking in package Current\BOCVSE__1000\516\DAT\0000 complete
1/31/11 11:04:44 AM   Checking in package Current\VSCANDAT1000\6240.0000\DAT\0000
2/1/11 3:59:24 AM   Checking in package Current\VSCANDAT1000\6240.0000\DAT\0000 complete
2/1/11 3:59:25 AMCompleted: Pulling content from McAfeeHttp to Current branch (Repository Pull successful from McAfeeHttp to Current branch)

Highlighted

Re: package check ins are hanging during pulls

I'm having the same issue.  We couldn't do a manual checkin and when I tried to delete the current DAT and do a new pull it crashes the ePO App Server service now.  We have no agent handlers so this is not the same as what is detailed in KB68414.

Level 7
Report Inappropriate Content
Message 5 of 5

Re: package check ins are hanging during pulls

Try going to https://secure.mcafee.com/apps/downloads/security-updates/security-updates.aspx?region=us and downloading and checking in the lastest DAT.

I can't really suggest anything else as this hasn't happened again and there is no clear reason why it stopped being an issue.

Actually, one other thing that I tried was changing the source site, so now my source sites are as below with Http2 the primary:

McAfeeFtp
FTP
ftp.nai.com/CommonUpdater
--
McAfeeFtp2
FTP
ftp.nai.com/CommonUpdater2
--
McAfeeHttp
HTTP
update.nai.com/Products/CommonUpdater
--
McAfeeHttp2
HTTP
update.nai.com/Products/CommonUpdater2
Enabled

Not sure if you've tried that.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community