cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
yoann63
Level 8
Report Inappropriate Content
Message 1 of 9

forcing agent communication by dns (instead of IP first)

Jump to solution

Hi,

i want to make a new entry in my dns server for my mcafee server (so it maybe accessible by intra network and extra network)

I use deployment by msi.

So i think i have to modify sitelist.xml.

What would be the best practice to make modification (agent usually communicate first using IP. I want to force using directly DNS.

Is it possible ?

And what field do i have to modify in the xml ? (only field "server" ?)

After that i have to re-generate my msi.

That's right ?

Thanks for your help.

1 Solution

Accepted Solutions
JoeBidgood
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

I think I see what you mean now

ePO by default writes its FQDN to the sitelist.xml that the clients use. You can override this behaviour by adding the ServerDNSName parameter to the server.ini file on the ePO server, then restarting the ePO services: this will create  a new sitelist.xml (and a new framepkg.exe that contains the new sitelist.)

So in your case you would add the following line to the end of server.ini:

ServerDNSName=mcafee.mycorporate.com

and restart the services. You should then be able to install the agent using the framepkg.exe, and sitelist.xml should contain your desired FQDN.

Is this what you wanted?

Thanks -

Joe

View solution in original post

8 Replies
JoeBidgood
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

I'm afraid this isn't possible - the agent is hard-coded to try IP address, then DNS, then NetBIOS.

However as long as the agent fails to talk to the IP address, it will automatically try DNS, so all that will really happen is there will be a small delay.

HTH -

Joe

yoann63
Level 8
Report Inappropriate Content
Message 3 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

OK,

one probleme resolved

But if i want to change the dns, how do i have to process ?

modifying the siteliste.xml only ?

(only the field "server" ?

Thanks

JoeBidgood
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

Can you explain a bit more what you are trying to do? Normally there shouldn't be any need to edit the sitelist manually...

Thanks -

Joe

yoann63
Level 8
Report Inappropriate Content
Message 5 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

in fact, actually we would like to make an entry in the DNS with a more official name for our server.

Is it possible de change this name ?

Thanks

JoeBidgood
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

Sorry, I'm afraid I'm still not sure what you're trying to do

What is the actual problem you're trying to solve?

Thanks -

Joe

yoann63
Level 8
Report Inappropriate Content
Message 7 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

ok, in fact our server's name is "myserverbob".

I'd like to make an entry in my dns which could be "mcafee.mycorporate.com" which would point to "myserverbob".

So i need to make change on agents which are out of our network.

So what is the best practice ?

I hope it will be more clear...

Thanks

Y

JoeBidgood
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

I think I see what you mean now

ePO by default writes its FQDN to the sitelist.xml that the clients use. You can override this behaviour by adding the ServerDNSName parameter to the server.ini file on the ePO server, then restarting the ePO services: this will create  a new sitelist.xml (and a new framepkg.exe that contains the new sitelist.)

So in your case you would add the following line to the end of server.ini:

ServerDNSName=mcafee.mycorporate.com

and restart the services. You should then be able to install the agent using the framepkg.exe, and sitelist.xml should contain your desired FQDN.

Is this what you wanted?

Thanks -

Joe

View solution in original post

yoann63
Level 8
Report Inappropriate Content
Message 9 of 9

Re: forcing agent communication by dns (instead of IP first)

Jump to solution

Hi,

sorry for late answer...

GREAT, it was exactly what i wanted to do.

Thanks a lot

Yoann

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community