cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

eeadmin.assignuser - ePO.API.Explorer

I am creating an powershell script that would assign specific encryption users to a specific machine.

Using ePO>API.Explorer 1.0.2.0. and according to parameters..

systemNode =True (specific machine)

nodeID = Computer

dn = CN=user1,OU=users,DC=Company,DC=com

However the command line I receive fails.

https://eposerver:8443/remote/eeadmin.assignUser?systemNode=True&nodeId=computer&dn=CN%3DUSER1%2COU%...

audit log in Epo shows

succcessful login but then

User Name:administrator
Priority:Low
Action:EE - Users
Details:Unknown exception, please check orion.log
Success:Failed
Start Time:9/25/14 12:35:13 PM CDT
Completion Time:9/25/14 12:35:13 PM CDT

Orion log shows ...

2014-09-25 12:35:13,940 ERROR [http-8443-Processor8] command.AssignUser  - Unknown System ID

java.lang.Exception: Unknown System ID

at com.mcafee.epe.core.command.UserAssignmentCommands.getNodeName(UserAssignmentCommands.java:297)

What am I missing? Is System ID not linked to nodeID?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community