cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

ePO upgrade from 5.3.0 to 5.3.1 and if keeps stopping at the same place in the installation. You can see the colored bar moving to the right is almost at the end of the install, then it stops and get a message that McAfee ePO is reverting back to original version.  I searched the logs file and tried to figured out where the problem is. 

I get the same problem when I try to upgrade to 5.3.2, it stops at the same place.

It looks like it could be a right issue or could it be that my Java JRE folder is not where the installation needs it to be, even though I point to it, in the installation process. 

Thanks.

 

7 Replies
Thussain
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

Thank you for posting your query here

I understand that you are trying to upgrade from ePO 5.3.0 to ePO 5.3.1

Did you Download and run the PIA tool on the ePO server. The PIA tool is available both on the product download page, and the software catalog within the ePO console, under the ePO section. I request you to kindly look into the below KB article 

https://kc.mcafee.com/corporate/index?page=content&id=KB71825

What are the error messages you see in the install logs? These can be accessed from Temp directory

The best way to resolve this issue would be to log a SR with the support team 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Re: ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

Yes I did run the PIA tool first, and it passed with no issues found.

Thanks.

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 8

Re: ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

ePO 5.3.1 requires version  1.8.0_51 of java.  What version is installed?  It may not be an issue with Java, but some other reason.

Go to your user temp directory to mcafeelogs folder and look at the install logs.  Look for return value 2 or 3 for what the error was and the command that was run above the error.  That command will then tell you what specific log to look at (typically the core-upgrade.log).  At the bottom of that log you may see a build failed error.  That is the error we need to know.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

One issue is that McAfee creates so many logs, under user and Program Data to name a few. But per your information under username/Appdata/Local/Temp/McAfeeLogs/ There was a install log file but went through it and did not find one return code 2, but I could have missed it.

I did see several lines  starting with Failure.

Here are a few:

Failure: Exception caught in function Convert String to Unicode Unexpected format.

Failure: Could not launch McTray

Failure: Setup failed while trying to migrate server tasks to the new server

Failure: XML Reader dll not found in the following location.

Failure: Set up was unable to delete the DATABASE as part of the Uninstall process

McAfee E Policy Orchestrator- Configuration Failed!

 

Thanks.

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

I will send you my email address in private message.  Please email me the msi log.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

This is still an issue. I tried to add all the SA roles to my Admin account to install per tech's advice, even added DB creator to my account and still get the same results that it reverts back to original version.

Looked into the logs files and could not find any with a return code of 2.

Thanks.

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 8

Re: ePO upgrades to 5.3.1 keeps stopping and then reverts back to original version-5.3.0

I sent you some info for how to look for errors.  Hopefully that helps since you can't send logs.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community