cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 15

ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

Hey,

I'm on an air gapped network with both my sql server and ePO on the same virtual machine running windows server 2008 R2 (SP1).

I run the installer in debug mode and get the message:

Failure: In LaunchAppAndWait while trying to run the following program: "D:\PROGRA~2\McAfee\ePolicy Orchestrator\Installer\Core\install.bat"

Return code:1

Error Message:Incorrect function.

CustomAction:MerMod_RunOrionANTInstaller

Unfortunately I can't share my log files but I can try and explain them as best I can. The Installation seems to hang on "Starting new McAfee Services" and there is an error that repeats 45 times "Failure: In LaunchAppAndWait while trying to run the following program: "D:\PROGRA~2\McAfee\ePolicy Orchestrator\ jre\bin\java.exe""

I've been working on this for about 3 weeks now and honestly any help is much appreciated.

I should add I also attempted to upgrade to 5.9.1 instead and received similar errors.

2 Solutions

Accepted Solutions
cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

KB91799 for this error:

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:955: com.mcafee.orion.core.ext.LocalizedExtensionException: Can't upgrade extension "D:/PROGRA~2/McAfee/EPOLIC~1/server/extensions/installed:ui" because it is not currently installed (4)

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

Former Member
Not applicable
Report Inappropriate Content
Message 10 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

Hello,

Thanks for the reply on the post.

D:\Program Files (x86)\McAfee\Server\extensions\installed\ProductDeployment\5.10.0.2428\install.xml:36: java.sql.SQLException: Subquery returned more than 1 value. This is not permitted when the subquery follows =, !=, <, <= , >, >= or when the subquery is used as an expression.

It seems that there empty product deployment task available and because of the ePO upgrade is getting failed.

This seems from the errors posted by you.

I would like to request you to please remove the empty product deployment from your ePO either by deleting the deployment task or selecting something there , It could not be an empty deployment task while attempting an upgrade.

Please check the below KB article:

https://kc.mcafee.com/corporate/index?page=content&id=KB90024 

 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

 

View solution in original post

14 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

Hello,

Thanks for your post.

I would like to request you to please check whether the rollback or upgrade log i created or not.

If yes please check those log and see whether the build is successful or build is failed.

Also please check the .msi log.

I hope that you have followed the KB90222 and KB87731.

For ciphers you can also try to use the IISCrypto Tool.

 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Former Member
Not applicable
Report Inappropriate Content
Message 3 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

core-upgrade.log:

BUILD FAILED

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:1964: The following error occurred while executing this line:

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:2012: The following error occurred while executing this line:

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:1806: The following error occurred while executing this line:

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:955: com.mcafee.orion.core.ext.LocalizedExtensionException: Can't upgrade extension "D:/PROGRA~2/McAfee/EPOLIC~1/server/extensions/installed:ui" because it is not currently installed (4)

 

core-rollback.log:

BUILD SUCCESSFUL

Even though the rollback log says successful, I have to reset the server to an earlier checkpoint because the ePO services fail to start post an install attempt.

EPO5100-Install-MSI.LOG:

FAILURE: While starting the service [MCAFEETOMCATSRV530]

CustomAction: MerMod_StartPreviousServicesRollback

It also fails while starting other services Apache/Event parser

I assumed I didn't need to do KB90222 because I didn't see any errors that resembled it, but If you think that will work I'll try it.

As for KB87731 I tried to resolve something similar to that with the workaround from KB89995, but it still seems to fail with the 2048 SHA-1 certificates.

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

You might want to look at a couple of kb's first - kb90874 - you can validate ciphers and tls protocols by running nmap - see kb91115.  

KB91296 and KB91270 list required ciphers and protocols.  The easiest way to ensure you have the right ones enabled is to download iiscrypto and run it on the epo server, choose best practices, then also validate the right ciphers are enabled - leave what that enables as best practice, but if any are missing from the kb's, enable them also.  You will then need to reboot the server.

 

Here are some troubleshooting steps also for that particular error.

STARTCURRENTSERVICES ERROR: 

2018/04/19 10:07:11 MerModCALog: FAILURE: In LaunchAppAndWait while trying to run the following program:  

"C:\PROGRA~2\McAfee\EPOLIC~1\jre\bin\java.exe"  

Return code: 1  

Error Message: Incorrect function.   

CustomAction: MerMod_StartCurrentServices   

[ErrorLog]  

ErrorString=FAILURE: Unable to start service [MCAFEETOMCATSRV530]  

ActionName=MerMod_StartCurrentServices  

CustomAction: MerMod_StartCurrentServices  

This is a common error.  Basically the install is validating that Tomcat is loaded and functional so it can continue with the install.  It will attempt that command 45 times.   

  1. Validate Tomcat is actually running 
  2. Check KB89995 to ensure that is not your issue or to resolve (1024 bit certificate). 
  3. If it is starting and then terminating, check the Orion log for any partially installed extensions or other errors, and the stderr.log for any issues there for why the service isn't starting properly.  A proper start of the service includes loading all the extensions, and ability to log into the console without seeing just MFS foundation services. 
  4. Resolve any issues found, then let it try again. 
  5. If it is running, validate its functionality.  Go to the browser to https://servername:8443/remote/core.get-status.  Enter the epo admin credentials when prompted.  If it is functional, you should receive an OK message back from web page.   

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

Additionally, if using a Windows account to authenticate to the database, make sure it is also a local administrator on the epo server.  Use an epo admin console account that is a global admin and epo authentication - not Windows authentication.  Be mindful also of special characters in passwords.  See KB66286.  Additionally, the install has to create apache certs, so in addition to that kb, be mindful of this:

User name or password contains reserved characters that cause the command to fail.
As mentioned in Step 3 of the regeneration process documented in KB90760, there are certain characters that are valid in a password, but which if present, cause the regeneration command to fail. 
The problem is because the characters are reserved characters that have special meanings for the command shell. Examples of such characters are &, <, and >.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

KB91799 for this error:

D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:955: com.mcafee.orion.core.ext.LocalizedExtensionException: Can't upgrade extension "D:/PROGRA~2/McAfee/EPOLIC~1/server/extensions/installed:ui" because it is not currently installed (4)

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

Former Member
Not applicable
Report Inappropriate Content
Message 7 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

I'm currently retrying the install after doing KB91799 but I'm not sure if I understand the note towards the bottom of the page.

"NOTE: Installation to a path that failed before 8.3 naming was enabled will still fail to that same path. Point the installation to a new directory path because 8.3 naming support is added to that path by default when enabled."

Should I expect the installation to fail? If it does is there a way to change the install path for an upgrade?

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

After your reboot, verify first that the shortname shows up correctly.  If your dir /x command shows Progra~1 for program files and program~2 for program files (x86), you are ok to install to the same directory, as 8.3 is valid and enabled.  To explain that statement below regarding it will fail again, that sometimes is true and sometimes not.  Sometimes when you enable 8.3 and directories already exist, it doesn't always enable it on the existing directories, especially if they are on a different drive.  However, IF you see the short name in front of the directory you want to install to, then yes, it is enabled and it is safe to install to.  If you do NOT see the short name there, then you would follow KB82122 to get it enabled on that directory.

Installation to a path that failed before 8.3 naming was enabled will still fail to that same path. Point the installation to a new directory path because 8.3 naming support is added to that path by default when enabled.

Verify that the 8.3 naming convention is enabled on the drive:

  1. Click Start, Run, type cmd, and then click OK.
  2. Type the following command and then press Enter:

    Dir /x

    You see that folders now have a column for short names, for example, Progra~1 for Program Files
     
  3. Type exit and press Enter.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Former Member
Not applicable
Report Inappropriate Content
Message 9 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

I applied KB91799 and it seems to have fixed a lot, but further along in the installation I'm getting errors very similar to the ones in KB84919 with the following exceptions.

epo-rollback.log:

BUILD FAILED
D:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\epo\build.xml:104: D:\PROGRA~2\McAfee\EPOLIC~1\apache_backup does not exist.

EPOST.ERR:

Error encountered while running command:ext.install Extension=file:///D:/PROGRA~2/McAfee/EPOLIC~1/INSTAL~1/ePO/EXTENS~2/epoST.zip
java.io.IOException: Error 0 :

The following error occurred while executing this line:

D:\Program Files (x86)\McAfee\Server\extensions\installed\ProductDeployment\5.10.0.2428\install.xml:98: The following error occurred while executing this line:

D:\Program Files (x86)\McAfee\Server\extensions\installed\ProductDeployment\5.10.0.2428\install.xml:36: java.sql.SQLException: Subquery returned more than 1 value. This is not permitted when the subquery follows =, !=, <, <= , >, >= or when the subquery is used as an expression.

EPO5100-Error.ini:

The same as the KB

 

I ran dir /x on all the different directories and noticed they were using the 8.3 naming convention correctly. Any suggestions on where to go from here?

Former Member
Not applicable
Report Inappropriate Content
Message 10 of 15

Re: ePO 5.3.1 to 5.10 upgrade fails towards end of install

Jump to solution

Hello,

Thanks for the reply on the post.

D:\Program Files (x86)\McAfee\Server\extensions\installed\ProductDeployment\5.10.0.2428\install.xml:36: java.sql.SQLException: Subquery returned more than 1 value. This is not permitted when the subquery follows =, !=, <, <= , >, >= or when the subquery is used as an expression.

It seems that there empty product deployment task available and because of the ePO upgrade is getting failed.

This seems from the errors posted by you.

I would like to request you to please remove the empty product deployment from your ePO either by deleting the deployment task or selecting something there , It could not be an empty deployment task while attempting an upgrade.

Please check the below KB article:

https://kc.mcafee.com/corporate/index?page=content&id=KB90024 

 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

 

View solution in original post

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community