cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 21 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Too old or too weak?  Possible - but more possible that you aren't using the correct one.  If it was too weak, epo 5.10 wouldn't have originally installed in the first place.  The error does seem to show that it is too short.

salt must be at least 128 bits

 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 22 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hello,

Thanks for uploading the logs.

from posted logs:
RestoreSnapshotServiceImpl: restoreServer:: Failed restore Keystore, restore failed (possibly wrong keystore password): salt must be at least 128 bits

It seems from the logs  that the provided  Keystore Passphrase is not correct.

For Ciphers you can run the IIS Crypto GUI after that click on best practices>apply and reboot the machine.

https://www.nartac.com/Products/IISCrypto/

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a Solution" if this reply resolves your query!

 

Highlighted
Level 8
Report Inappropriate Content
Message 23 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

FYI

ScreenShot2282.jpg

 

[dr-restore-server] com.mcafee.orion.dr.restore.StreamCrypto>> DEBUG enter StreamCrypto: decrypt::
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> DEBUG enter RestoreManipulator: retrieveValueFromServerProperty::
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE enter RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE exit RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE enter RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE exit RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> DEBUG exit RestoreManipulator: retrieveValueFromServerProperty:: value= ddddddchangedonpurpose==
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> DEBUG enter RestoreManipulator: retrieveValueFromServerProperty::
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE enter RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE exit RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE enter RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> TRACE exit RestoreManipulator: getDatabase:
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> DEBUG exit RestoreManipulator: retrieveValueFromServerProperty:: value= ddddchanged=
[dr-restore-server] com.mcafee.orion.dr.restore.StreamCrypto>> ERROR! salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.StreamCrypto>> ERROR! StreamCrypto: decrypt:: salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> ERROR! restoreKeystore StreamCrypto: decrypt:: salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR! RestoreSnapshotServiceImpl: restoreServer:: Failed restore Keystore, restore failed (possibly wrong keystore password): salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> ERROR! RestoreSnapshotServiceImpl: restoreServer:: com.mcafee.orion.dr.restore.DisasterRecoveryException: salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerCmd>> ERROR! ERROR! RestoreServerCmd: invoke:: Exception during execution of restoreServer= salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerCmd>> INFO exit RestoreServerCmd: invoke:: status= dr.cmd.restore.server.status.failure
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerTask>> INFO DONE! RestoreServerTask: execute:: restoreServerCmd status= dr.cmd.restore.server.status.failure

Highlighted

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hello,

 

Did you find a solution ?

I have the same error

 

Fabien

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 25 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Which exact error are you getting - this one below?

[dr-restore-server] com.mcafee.orion.dr.restore.StreamCrypto>> ERROR! salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.StreamCrypto>> ERROR! StreamCrypto: decrypt:: salt must be at least 128 bits

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hi,

Yes, but I just learned that I am not in the right version, server crash 5.9 and new 5.10

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 27 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Ok

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community