cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8
Report Inappropriate Content
Message 1 of 27

ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hi folks,

Due to a disaster, I've to restore McAfee using the DB Backup.

The original server was running under 2008R2 with sQL Server express 2012 and ePO 5.10 Update 4

I've setup a new 2016 server, setup SQL SErver Express 2012 and downloaded the latest ePO 5.10 release 4 installation.

I've started the restore and all of the sudden, I get this error message inthe logs with installation failed.

[dr-restore-server] com.mcafee.orion.dr.restore.RestoreManipulator>> ERROR! RestoreManipulator:: retrieveKeysFromDatabase:: java.sql.SQLException: com.mcafee.orion.core.db.base.DatabaseConnectivityException: Failed to get a connection: Network error IOException: protocol_version(70). Navigate to /core/config and verify database connection settings
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> ERROR! RestoreSnapshotServiceImpl: restoreServer:: com.mcafee.orion.dr.restore.DisasterRecoveryException: java.sql.SQLException: com.mcafee.orion.core.db.base.DatabaseConnectivityException: Failed to get a connection: Network error IOException: protocol_version(70). Navigate to /core/config and verify database connection settings
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerCmd>> ERROR! ERROR! RestoreServerCmd: invoke:: Exception during execution of restoreServer= java.sql.SQLException: com.mcafee.orion.core.db.base.DatabaseConnectivityException: Failed to get a connection: Network error IOException: protocol_version(70). Navigate to /core/config and verify database connection settings
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerCmd>> INFO exit RestoreServerCmd: invoke:: status= dr.cmd.restore.server.status.failure
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerTask>> INFO DONE! RestoreServerTask: execute:: restoreServerCmd status= dr.cmd.restore.server.status.failure

 

I've googled a bit and it seems that latest version requires, somehow, a SSL communication with the SQL Server Express. Is that correct? Is this error message related?

This would explain, why just after the login/pwd to DB, the installation shows the default ports and for the MS SQL it says:

SQL server TCP Port: 50440 and I can't change it.

 

Honestly, I just would like to restore the mcafee server ASAP. Any suggestions/best practices are more than welcome!

Looking forward to hearing from you.

26 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hi, 

 

Download IIS Crypto to your server:

https://www.nartac.com/Products/IISCrypto/Download

(The GUI Version)

 

Then apply best practices. There is a Best Practices button, once you click on it, it will set everything to best practices. After this just restart the server and see if you can restore this time. 

 

Ensure that when you use TLS 1.2, it is supported with your SQL, as some needs patching: 

https://support.microsoft.com/en-gb/help/3135244/tls-1-2-support-for-microsoft-sql-server

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thank You,

Siushan M.
Highlighted

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

See the article KB8773. Similarly also try to install ePO in that way as described in the article KB90222. 

if you need any difficulty in understanding anything kindly message me personally.

Highlighted
Level 8
Report Inappropriate Content
Message 4 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hello

 

thanks a lot for your quick reply. I've followed your suggestions,ran the app with best practices values, restarted and setup SQL 2012 SP4 and restarted. So now it fits the requirements.

I've ran the setup again and it failed with the following error.

 

[dr-restore-server] com.mcafee.orion.dr.restore.StreamCrypto>> ERROR! salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.StreamCrypto>> ERROR! StreamCrypto: decrypt:: salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> ERROR! restoreKeystore StreamCrypto: decrypt:: salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR! RestoreSnapshotServiceImpl: restoreServer:: Failed restore Keystore, restore failed (possibly wrong keystore password): salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> FATAL ERROR!
[dr-restore-server] ----------------------------
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreSnapshotServiceImpl>> ERROR! RestoreSnapshotServiceImpl: restoreServer:: com.mcafee.orion.dr.restore.DisasterRecoveryException: salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerCmd>> ERROR! ERROR! RestoreServerCmd: invoke:: Exception during execution of restoreServer= salt must be at least 128 bits
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerCmd>> INFO exit RestoreServerCmd: invoke:: status= dr.cmd.restore.server.status.failure
[dr-restore-server] com.mcafee.orion.dr.restore.RestoreServerTask>> INFO DONE! RestoreServerTask: execute:: restoreServerCmd status= dr.cmd.restore.server.status.failure

BUILD FAILED
C:\Program Files (x86)\McAfee\ePolicy Orchestrator\Installer\core\build.xml:1321: java.lang.Exception: dr.cmd.restore.server.status.failure
at com.mcafee.orion.dr.restore.RestoreServerTask.execute(RestoreServerTask.java:97)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:392)
at org.apache.tools.ant.Target.performTasks(Target.java:413)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
at org.apache.tools.ant.Main.runBuild(Main.java:811)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)

 

any clues?

looking forward to hearing from you.

Regards

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

It looks like you have entered the wrong Keystore Passphrase for the restore. 

try again with the correct passphrase... 

 

Do you have backup as per KB66616?

 

 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thank You,

Siushan M.
Highlighted
Level 8
Report Inappropriate Content
Message 6 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hello,

 

I've applied the same password as for the initial setup. Funny thing is that Mcafee ask me to enter it twice, like if it was a new setup for him.

About the KB, I haven't done the full backup with the certificates files, keystore folder, etc etc. The only thing I've left is the SQL Database.

is there a chance to recover or not?

 

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

If you do not have the folders/files from KB66616 and only this DB Backup, then unfortunately not. EPO tries to decrypt the database with the keystore passphrase you provide and if it is wrong then it will fail to decrypt and load the Folder/files from EPO Server. 

 

 

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thank You,

Siushan M.
Highlighted
Level 8
Report Inappropriate Content
Message 8 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

arffff....

So the DB is useless and I can't recover anything from it without all those files?

this is so bad.

thanks anyway.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hello,

Disaster Recovery means restoring the same files which we have backed up previously.

If you don't have anyone of them available in that case this is not going to work and you have to ended this after installing a new ePO Server.

Other thing you check in your database using the below query to check whether the snapshot is available or not.

Select * from Orionsnapshot 

Once the query will get executed successfully you will be able to see whether any Server Snapshot has been taken or not.

But still you need the Keystore passphrase to complete the recovery.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! l Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Highlighted
Level 8
Report Inappropriate Content
Message 10 of 27

Re: ePO 5.10 Restore installation fails Failed to get a connection: Network error IOException

Hi vivs

 

query Select * from Orionsnapshot  returned 78 rows. there is a snapshot available

same questions as asked above, no chance to be able to regenerate manually that folder?!

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community