Showing results for 
Show  only  | Search instead for 
Did you mean: 

ePO 4.0 patch 6 upgrade to 4.5 fails

I am currently facing a big issue upgrading to ePO 4.5. I am running ePO 4.0 patch 6. SQL 2005 SP3.

I get errors during the installation. A fresh install is not acceptable as all the policies have to be migrated with these upgrade.

here is the error log:


ErrorString=FAILURE: In LaunchAppAndWait while trying to run the following program:


Return code: 1

Error Message: Incorrect function.

CustomAction: MerMod_RunOrionANTInstaller

other error logs:
C:\Program Files\McAfee\ePolicy Orchestrator\Installer\core\build.xml:521: com.mcafee.orion.core.ext.ExtensionException: Cannot upgrade extension response because it is not currently installed
please this is very urgent

11 Replies

Re: ePO 4.0 patch 6 upgrade to 4.5 fails

people i need an answer

Level 14
Report Inappropriate Content
Message 3 of 12

Re: ePO 4.0 patch 6 upgrade to 4.5 fails


did the ePO upgrade completely fail (i.e you stayed on ePO 4.0 P6) or it is some failure messages that you've seen in upgrade logs?

When first, could you attach (not copy the content)  the log files of the upgrade?


McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 12

Re: ePO 4.0 patch 6 upgrade to 4.5 fails

It looks like there is a mis-match between what is listed in the OrionExtensions table on the ePO database and the files in the ePO installation. (ePolicyOrchestrator\Server\Extensions\Installed  - there is a folder for each installed extension and one or more subfolders with the version number underneath each extension folder)

The other location which must have the proper .xml files pointing to the extension installation folder for each of the extension above is under server\conf\Catalina\Localhost)

Was there any database restore that was done after upgrading to Patch 6?  If it was, and it was from a prior patch upgrade, then the installation folder and the database would be out of sync.

you can verify if the database is on Patch 6, by looking at the Version column for the system extensions such as EPOCore and PolicyMgmt in the OrionExtensions table. They should read

Then make sure that a subfolder with the version number listed is present under the extension Installed location mentioned before.

If you are certain that everything is in place and you still have these errors when trying to upgrade, I would suggest logging a case with McAfee Support for investigation.



Message was edited by: Sailendra Pamidi on 2/22/10 1:50:50 PM CST

Re: ePO 4.0 patch 6 upgrade to 4.5 fails

Thanks for your replies i appreciate. We eventually contacted mcafee and I was told to reduce the size of the database to atleast 10gb. The current size was 55gb. this was done but didnt resolve the issue. So we ended up with a clean install. the good thing is, i was able to export and import the system tree(which was complex, and highly populated) and other point products. mcafee support engineer sent in another workaround, which i still intend to try because we still have the copy of the eposerver that could not be upgraded, since we did a fresh install. i will also upload the workaround in a few days.

thanks. cheers

Re: ePO 4.0 patch 6 upgrade to 4.5 fails


We are getting the same error on our upgrade, can you please let me know what McAfee's other workaround was?


Re: ePO 4.0 patch 6 upgrade to 4.5 fails

I have been quite busy with EEPC issues, so I have not been able to upload the workaround.

However , you can send me your email address and i would forward it to you. (For security reasons you could send a non-official or personal email address)

Please note that this workaround is intended  for the ePO database.  Are you sure the error is the same or atleast related.


Level 7
Report Inappropriate Content
Message 8 of 12

Re: ePO 4.0 patch 6 upgrade to 4.5 fails

Hey babatola,

I am having similar issues, can I please know the workaround? I would prefer upgrading EPO 4.0 to 4.5 on the same box and once everything is stable, I can standup a new box and do a fresh install but this time I will connect  restored copy of 4.5 databse from legacy database box to the new box.

We have a huge database, like 50G and we can trim it down to 20-30 G, that would be great if you can please share the McAfee workaround.



Re: ePO 4.0 patch 6 upgrade to 4.5 fails


In our case McAfee that some folders were missing on our EPO install -  if you look at the logs it has locations it couldn't update, if you browse to there, it didn't have the right build number folders for Epo 4 patch 6 (e.g. 1184 - can't remember the build number for Patch 6) so they had to copy them from a healthy EPO Server to ours and re-ran setup. Had to do this about 5 times in different folders before it allowed the installation to go through.

I know it's not very descriptive, but i'm rushing to at least give you something to go on!

Good luck!

on 14/06/10 12:08:33 CDT

Re: ePO 4.0 patch 6 upgrade to 4.5 fails

I ran into this problem and ended up backing up my VSE policies (exporting them) and removing the VSE extension as well as the anti-spyware (as it depends on the VSE extension).  Once I removed it, I re-installed it and imported my policies.  The upgrade went good from there.  I actually had two of them I had to do this to, one was VSE and the other was the VSE Reporting extension.



You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community