cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Version of agent and ENS required for Mojave

We are starting to rollout Mojave to our MAC estate and we are getting an error message in the Legacy Software section (see attached). What i need to know is what version of the agent and what version of ENS should be installed (64bit only) to enable Mojave to work correctly. Also what elements of McAfee are being flagged as 32 bit in the screen shots?

 

screenshotscreenshot

5 Replies
Highlighted

Re: Version of agent and ENS required for Mojave

The Signining ID showing the error are FMPHelper & macompatsvc
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 6

Re: Version of agent and ENS required for Mojave

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: Version of agent and ENS required for Mojave

KB51109 is the master kb for supported environments for our products.

KB84934 - ENS Mac info

KB51573 - McAfee agent info

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted
Level 10
Report Inappropriate Content
Message 5 of 6

Re: Version of agent and ENS required for Mojave

Hello McAfee technical team, we are getting these two 32-bit components for Catalina OS.

macompatsvc: The compatibility service for the McAfee Agent service. The McAfee Agent service starts this service and communicates to the various managed product plugins.

FMPHelper: what is this? No info found in the web.

NOTES:

  • McAfee does not support the co-existence of 32-bit and 64-bit McAfee products. Migration to 64-bit applications is needed because of an operating system limitation; it can't co-exist with 32-bit legacy products. During the migration, there is an impact to local user interface capabilities for some of the 32-bit legacy products as outlined below.

 

Why is McAfee still installing these 32-bit components?

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 6

Re: Version of agent and ENS required for Mojave

FMP (Functional Module Platform (FMP)) is part of ENS, so you would need to ask that team about that.

The macompatsvc service - 

MA 5.x includes several processes that are 32-bit, including macompatsvc.exe and McScript_InUse.exe, and it requires the 32-bit subsystem for normal operation.

The compat service on mojave wont run, even if it's 32 bit.  We moved to the msgbus component for all products, so it being there wont cause harm.  I believe in MA 6, all MA services will run 64 bit.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community