cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Ccharb
Level 9
Report Inappropriate Content
Message 1 of 5

Upgrade EPO 5.9 to 5.10

Hello,

I want to upgrade my old 5.9 EPO to a new 5.10 Update 11 EPO.

I have an error to connect my database because : "Error: Database 'ePO_S17_events' does not exist"

I know that 5.9 doesnt have the event database, but what is the way to upgrade 5.9 to 5.10 ? I didn't find a KB with my problem.

Thanks for your help.

4 Replies
cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 5

Re: Upgrade EPO 5.9 to 5.10

Please open a ticket with us so we can review the logs to see what went wrong.  

It is possible the account for the database didn't have enough rights to create the database, but I can't say without looking at the logs.  Check to see what the error was - logs can be found in c:\programdata\mcafee\epolicy orchestrator\.  You should see a folder like install logs.  

In the msi log, look for return value in notepad++ for all instances.  Anything other than 0 or 1, check what that error was and above it you might see what command it ran.  In that command, it might give you a specific log to look at for the error.  Or you can just check all the logs for any errors.  Ignore any that start with property, as those are just cataloging potential errors.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Ccharb
Level 9
Report Inappropriate Content
Message 3 of 5

Re: Upgrade EPO 5.9 to 5.10

Hello,

I've checked from the EPO Update log, and the error is : "Error: Database 'ePO_XXX_events' does not exist"

That's normal because on my 5.9 EPO, this database doesn't exist, and 5.10 need it.

I want to know why the EPO updater doesn't create this database automatically. What is the process to upgrade 5.9 to 5.10 ? I've read that EPO updater is enough but it seems not. Do I need to have another server, and installing EPO 5.10 from scratch and import the config 5.9 to this new server ?

Thanks you.

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 5

Re: Upgrade EPO 5.9 to 5.10

What exact package for 5.10 are you running for the upgrade?  If you are just using update 11, that is only an update to an existing 5.10 server.  You first have to run the 5.10 base install, then run update 11 on epo.  Same process for any agent handlers.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Ccharb
Level 9
Report Inappropriate Content
Message 5 of 5

Re: Upgrade EPO 5.9 to 5.10

Hello,

I used the update 11 for EPO 5.10...

I've tried to use the 5.10 basic install, and indeed he is reaching my database. I'm gonna try to finish this install (after updating 2-3 extension obsolete) and will be back to you after this.

Thanks for your help.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community