cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 16

Unable to install Epo version 4.6 Patch 2

When i try to install Epo4.6 Patch 2 the installation stops and roles back to Epo 4.6.1. When i view te install log file i see the following error:


Property(C): NewerFoundError = A newer version of this application is already installed on this computer. If you wish to install this version, please uninstall the newer version first. Click OK to exit the wizard.


I need to install Epo 4.6 Patch 2 to use Mcafee MOVE av 2.5. Is there a solution to install Epo 4.6 Patch without errors?

In the attachement the install log file created with the commands "Setup.exe" /l*v InstallLog.txt"

Many thanks.

15 Replies
spamidi
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 16

Re: Unable to install Epo version 4.6 Patch 2

Hi

To dig deeper into why the install is failing, we need to run the setup with a debug flag. This usually generates additional debug message prompt dialogs while setup is executing some of the main steps. Please try this command line:

setup.exe DEBUGOUTPUT=2

The DEBUGOUTPUT parameter is case sensitive. So make sure you type it in all upper case. Once the setup fails, there is a prompt before it attempts the rollback. At that time grab the files from the current users temp directory.

we need to look for McAfeeLogs\EPO460-Troubleshoot folder.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
Former Member
Not applicable
Report Inappropriate Content
Message 3 of 16

Re: Unable to install Epo version 4.6 Patch 2

HI,

I try installed Patch 2 with the command "setup.exe DEBUGOUTPUT=2" see the images the output. But can i upload the "McAfeeLogs\EPO460-Troubleshoot" log files in this discussion or can i email you?

error1.jpg

error2.jpg

error3.jpg

spamidi
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 16

Re: Unable to install Epo version 4.6 Patch 2

Please attach the zip of the folder here.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
Former Member
Not applicable
Report Inappropriate Content
Message 5 of 16

Re: Unable to install Epo version 4.6 Patch 2

see attachement

Message was edited by: r.maas1999 on 6/5/12 12:53:17 PM CDT
spamidi
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 16

Re: Unable to install Epo version 4.6 Patch 2

Thanks for the logs. I could not find the main MSI installation log file but managed to get this from one of the logs (epo.err):

Error encountered while running command:ext.install extension=file:///C:/PROGRA~2/McAfee/EPOLIC~1/INSTAL~1/ePO/EXTENS~2/epo.zip

java.io.IOException: Error 0 :

Extention dir already exists:C:\Program Files (x86)\McAfee\ePolicy Orchestrator\Server\Extensions\installed\EPOCore\4.6.2.234

So it looks like the previous installation attempt for patch 2 left over the extension files. We need to remove these left over files before attempting the install again.

In this example the folder to be removed is the 4.6.2.234. There may be other extensions under the Extensions\installed\  folder structure with partially installed extension files for Patch 2 which would prevent a successful upgrade.

Also, if you can please gather any logs you find in the %Temp%\McAfeeLogs folder.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
Former Member
Not applicable
Report Inappropriate Content
Message 7 of 16

Re: Unable to install Epo version 4.6 Patch 2

I am sorry - are you saying you are not able to attach the zip of the troubleshoot folder for epo installation?


Hi Sailendra Pamidi, it works 🙂 see the log file in our discussion. But i have a new problem. When i use the debug option for some reason i have a 4.6.2 epo but in the extention i see it is still 4.6.1..

When i start the setup i only get the message i i want to remove EPO 4.6.2

 

Server.ini

[AgentUpgrade]
UnSupporedPlatformID=NVNW|RH70

[Server]
Version=4.6.2.234
HTTPPort=8088
AgentHttpPort=8081
ConsoleHTTPPort=
DatabaseSSL=request
UseNTLMv2=1
IsAgentHandlerPrimary=1
SecureHttpPort=8443
BroadcastPort=8082
DataSource=10.100.66.72\
CatalogVersion=20120605160020
EnableGlobalOneHourUpdate=0
GlobalUpdateRandomization=20
LastRegisteredServerName=ICTCYB1-EPO01
LastRegisteredServerIPAddress=10.104.33.10
LastRegisteredServerDNSName=ICTCYB1-EPO01.prod.bam.nl
LastRegisteredServerID=1
FipsMode=0

[AVERTAlertInfo]
AVERTAlertsServerName=myavert.avertlabs.com
AVERTAlertsPort=8801
AVERTAlertsURL=http://myavert.avertlabs.com:8801/reportservice.asmx?wsdl

[AuditPurgeInfo]
Enabled=no
Ceiling=800000
Frequency=5

extensions:

5-6-2012 19-59-55.jpg

spamidi
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 16

Re: Unable to install Epo version 4.6 Patch 2

I am afraid this does not look good. When the patch setup failed, it looks like it has updated some of the system extensions and not others. If you chose to continue the install anyway at the last prompt, then the setup might just attempt to complete but that puts ePO in a broken state.

Your best bet is to perform an uninstall and reinstall of ePO and restore from backup by following KB66616. Sorry.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
Former Member
Not applicable
Report Inappropriate Content
Message 9 of 16

Re: Unable to install Epo version 4.6 Patch 2

oke that no problem (I know the KB 🙂 ) but when i do a reïnstallation must i install epo version 4.6.1 or 4.6.2?

spamidi
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 10 of 16

Re: Unable to install Epo version 4.6 Patch 2

It should be the same as your backup (which means ePO 4.6.1).

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community