cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 8

The following required dependencies are missing

Hi 

Im on test platform for the MVISION EDR , which i get some error during check in for the extenstion.

As below is the requires and depencies that are missing.Can anyone help me with this.Thank You.

Requires:            

core

console

EPOCore

commonui-core-common

commonui-core-rest

response

CloudBridge2

DXLClient

DXLBrokerMgmt

DXLClientMgmt

mvision-edr-endpoint-snapshot-tool

mvision-edr-agent-package

mvision-edr-agent

Error:    

The following required dependencies are missing: CloudBridge2:2.0.0, DXLClient:5.0.0, DXLBrokerMgmt:5.0.0, DXLClientMgmt:5.0.0, mvision-edr-endpoint-snapshot-tool:6.4.0, mvision-edr-agent-package:3.0.0, mvision-edr-agent:3.0.0

7 Replies
Hem
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 8

Re: The following required dependencies are missing

These extensions can be downloaded from software manager.

CloudBridge2:2.0.0, DXLClient:5.0.0, DXLBrokerMgmt:5.0.0, DXLClientMgmt:5.0.0, mvision-edr-endpoint-snapshot-tool:6.4.0, mvision-edr-agent-package:3.0.0, mvision-edr-agent:3.0.0

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 8

Re: The following required dependencies are missing

If you go to software manager, you should be able to find all the required extensions.  The mvision items you listed as needed are found under mvision endpoint detection and response 3.0.  I am trying to locate cloud bridge  - software manager only has 1.3.  I will get back with you on that.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: The following required dependencies are missing

Any update on cloudbridge 2.0.0 ? Where can this be obtained as only 1.3 is availible in grant and software catalog

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 8

Re: The following required dependencies are missing

So sorry, got sidetracked.  Checking on it.  I can't find it either so far.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 8

Re: The following required dependencies are missing

This is currently in beta now and not available anywhere but through the beta program.  It should be found inside the main zip provided as part of the beta.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: The following required dependencies are missing

Hello,

 

I don't follow. McAfee MVISION EDR 3.0 is available in ePO Software Catalog under evaluation (Checked with multiple grant numbers). There are currently no Beta's available for download on the beta site for any product. I have never seen Beta's posted in Software Catalog before. 

An SNS came out in December with MVISION updates, at that point this is when EDR showed up in Software Catalog (and is still there).

If this is Beta then it has be posted to the wrong place and it is just luck that it can not install as there is a component missing.

https://kc.mcafee.com/corporate/index?page=content&id=SNS1840

So I guess this now turns into: Why is beta software being published in Software Catalog? or have I misunderstood what you mean when you say "This" in the context of "This is currently in beta now and not available anywhere but through the beta program" as MVISION EDR 3.0 IS available through Software Catalog. If you mean Cloudbridge 2.0 is currently in beta, why is this a dependency on non beta software that is published in Software Catalog?

P.S. Thankyou for replying to these forums, it is very helpful, especially for non urgent issues that do not warrent an SR but an answer would be useful. You're a credit to McAfee (not sarcasm, i know it might sound it in context of the above reply but I am sincere) .

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 8

Re: The following required dependencies are missing

I am working on finding out the discrepancies.  I will get back with you on this.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community