cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Tag exclusions not working for deployment task

I have three different deployment tasks in ePO 4.5.0.851 that are all restricted based on tags.

Task1 deploys to all except Tag1 and Tag2

Task2 deploys to only Tag1

Task3 deploys to only Tag2

However, I am seeing this behaviour:

Systems without either Tag1 or Tag2 receive only Task1 (as expected).

Systems with Tag1 receive both Task2 and Task1.

Systems with Tag2 receive both Task3 and Task1.

I have verified which tasks are being received by each system by checking the local folder <C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Task>. I have also verififed that the tags are being applied correctly to the systems.

So it appears to me that when I limit a task using tags, the option "Has any of these tags:" is working, but the option "And has none of these tags:" is not being handled correctly.

Has anyone else seen this sort of behaviour? Or perhaps I'm missing something in my understanding of how this is supposed to work.

Any help is appreciated.

Thanks,

Dave

4 Replies
Highlighted

Re: Tag exclusions not working for deployment task

I just experienced the same issue, and found another thread discussing this:

https://community.mcafee.com/message/100969

It appears it only checks for the "none of these" tags if there's something in the "any of these" list.

I'm about to enter a ticket with McAfee for this, but I think eobiont's work-around is the best for now:  take/make a tag that all systems are a member of, and put that in the "has any of these tags" field.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 5

Re: Tag exclusions not working for deployment task

I've just had a poke through the defect tracking database and it looks like this is fixed in the next patch (Patch 4 for ePO 4.5.)

HTH -

Joe

Highlighted

Re: Tag exclusions not working for deployment task

Thanks for the update, Joe.

Is there an ETA for Patch 4?  I haven't been keeping track of the release schedule.

Also, has this issue been checked in ePO 4.6?

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 5

Re: Tag exclusions not working for deployment task

The current release date that I know of (subject to change, of course) is early January. I haven't seen anything relating to this in 4.6 as yet - I'll try and test it when I get a sec.

HTH -

Joe

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community