cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
User16096767
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 1 of 9

Service account accessing ePO DB issue after migration

eventparser failing to connect using the same Service account used prior to migrating the DB.

Old DB Operating system - Windows 2008 R2

New DB Operating System - Windows 2012 R2. SQL server  Application 2012 

 

ePO Server Operating systems - Windows 2008 R2.

After migration, Service account connection shows successful from core/config, but eventparser failing

eventparser log

desc=Cannot generate SSPI context, msg=Unspecified error

 

Eventvwr Systeem log 
This indicates that the target server failed to decrypt the ticket provided by the client. This can occur when the target server principal name (SPN) is registered on an account other than the account the target service is using. Please ensure that the target SPN is registered on, and only registered on, the account used by the server. This error can also happen when the target service is using a different password for the target service account than what the Kerberos


ePO 5.3.2 to 5.10  - We will be upgrading as soon as the remaining legacy client gets upgraded to the latest Operating system. In case you wonder why we are still running on 5.3.2 🙂

 

8 Replies
vivs
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 9

Re: Service account accessing ePO DB issue after migration

Hello @User16096767 

Thanks for your post.

Could you please check the eventparser.log for detailed error.

Or,

Please provide me the event parser.log through Private Message option.

I hope that UDL Test connectivity is fine and it is successfull.

Please check the below KB article for UDL connection:

https://kc.mcafee.com/corporate/index?page=content&id=KB70929

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

User16096767
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 9

Re: Service account accessing ePO DB issue after migration

UDL connectivity test also failed with the same error.

 

We can RDP to ePO server using service account without any issues.  Driving me crazy here 🙂

vivs
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 9

Re: Service account accessing ePO DB issue after migration

Hello @User16096767 

Thanks for your response.

I would recommend to check eventparser.log once and if its not helping , Please open a Service Request with Support Team.

Do check the eventparser.log

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

 

 

Hawkmoon
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 9

Re: Service account accessing ePO DB issue after migration

KB70929 and the UDL test from are always a good test to perform!

As the UDL shows a limitation/restriction is in place else it would have worked, the trick is to find it now! Take a look at the SQLERROR log and even grab a Wireshark when that attempt is being made to see what/where this limitation/restriction is being applied.

Was my reply helpful?

If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 9

Re: Service account accessing ePO DB issue after migration

Did you set up the same user account in the new sql server with the same permissions?  Did you try core/config to reset password there and verify correct port and instance is being used?

 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

User16096767
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 7 of 9

Re: Service account accessing ePO DB issue after migration

we have done that. It shows connection successful from core/conf, but still failing.  UDL test is failing though.

User16096767
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 8 of 9

Re: Service account accessing ePO DB issue after migration

we have a service request . TSE believes the issue is not related to McAfee. 

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 9

Re: Service account accessing ePO DB issue after migration

Can you send me your SR number please in private message?  

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community