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haaris
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Message 1 of 12

Server Task in progress but not end task option is not highlighted

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Hi,

I have run the one task to deploy ENS on one of the server but the task seems to be not finished(either successful or failed) even its running from more than 5 hours.When I am trying to end the task this option is not highlighted.I know if we restart the EPO services then server task will end as failed but Is there any way to end the task ?Can we do it from EPO DB?

EPO Task_Progress.JPG

 

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cdinet
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Message 2 of 12

Re: Server Task in progress but not end task option is not highlighted

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Please refer to KB85013 - this is normal behavior if the cient can't respond for any reason.

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cdinet
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Message 2 of 12

Re: Server Task in progress but not end task option is not highlighted

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Please refer to KB85013 - this is normal behavior if the cient can't respond for any reason.

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haaris
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Message 3 of 12

Re: Server Task in progress but not end task option is not highlighted

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Hi @cdinet

Thanks a lot.  Got it.. So I did what actually written in the KB article

cdinet
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Message 4 of 12

Re: Server Task in progress but not end task option is not highlighted

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Yes you did 🙂

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Re: Server Task in progress but not end task option is not highlighted

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KB goes to broken link

cdinet
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Message 6 of 12

Re: Server Task in progress but not end task option is not highlighted

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That was unpublished for some reason, checking on why.  but here is what it stated:

Title
Server task configured to execute the 'Run Client Task Now' task, might run indefinitely, or get stuck 'In Progress'
Environment
McAfee ePolicy Orchestrator (ePO) 5.x
Problem(s)
Problem
If you configure a server task that executes a Run Client Task Now task against a group of computers, server tasks might then run indefinitely.

The Server task remains the In Progress state indefinitely.

The above is seen when one of the clients is not able to return to the ePO Server one of the following states:
Success
Or
Failed status

Cause
There are multiple scenarios in which this issue might occur. For example, when a system is shut off after receiving the "Run Client Task Now" task, but before the task completes.

This issue might also occur if the McAfee Agent is in a retry loop. This situation is where another previously scheduled task continues to retry repeatedly without actually completing. In this scenario, the client system receives the "Run Client Task Now" task, so the Abort After setting is not applicable. The task never actually starts on the client system, and so the Stop Client task after setting does not apply.
Solution(s)
Solution
This behavior is expected.

The Run Client Task Now task is designed to return progress based on messages received by the client system. If any circumstance prevents the client system from sending these status messages, the progress of the task can't be updated. So it is left in a pending state indefinitely.

If you encounter this situation, you can try to end the server task. But it might be needed to restart the ePO services. Usually, the original server task that is set to execute the 'Run Client Task Now', has already completed. It is the sub tasks that are trying to execute the 'Run Client Task Now' on the clients. There are no means to end these sub tasks through the Server Task Log screen.
Stop the ePO services.
Click Start, Run, type services.msc, and click OK.
Right-click the following services and select Stop:

McAfee ePolicy Orchestrator x.x.x Application Server
McAfee ePolicy Orchestrator x.x.x Server
McAfee ePolicy Orchestrator x.x.x Event Parser

Start the ePO services.
Click Start, Run, type services.msc, and clickOK.
Right-click the following services and click Start:

McAfee ePolicy Orchestrator x.x.x Application Server
McAfee ePolicy Orchestrator x.x.x Server
McAfee ePolicy Orchestrator x.x.x Event Parser

Close the services window.
It is possible in a future release to change the behavior to allow the server to end the task in certain circumstances. But, such a change would require significant rework in McAfee Agent and ePO and would not be possible until a future major release.

Also, do not use Run Client Task Now tasks, as the main method of scheduling client tasks. For example, such as DAT updates and product deployments. The best practice method of scheduling client tasks to run on a regular schedule, is to schedule the client tasks through the Assigned Client tasks tab, which is located in the System Tree.

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cdinet
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Message 7 of 12

Re: Server Task in progress but not end task option is not highlighted

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It was unpublished because 5.10 doesn't have the problem specific to that kb.

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ffigueroag
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Message 8 of 12

Re: Server Task in progress but not end task option is not highlighted

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Hello guys,

This content is retired and no longer available.

Anyone have another solution????

HELP!!!

 

cdinet
McAfee Employee
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Message 9 of 12

Re: Server Task in progress but not end task option is not highlighted

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What exact issue are you running into?  A run client task now will show in progress if it can't reach the client.  

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Re: Server Task in progress but not end task option is not highlighted

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Hello cdinet,

Thats correct, A run client task show in progress if it cant reach the client, but I cant end the task and server task log shown duration 22 hours or more

 

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